libapache2-mod-auth-pgsql_2.0.3-6.1_amd64.deb


Advertisement

Description

libapache2-mod-auth-pgsql - Module for Apache2 which provides PostgreSQL authentication

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libapache2-mod-auth-pgsql
Package version: 2.0.3
Package release: 6.1
Package architecture: amd64
Package type: deb
Installed size: 116 B
Download size: 18.33 KB
Official Mirror: ftp.br.debian.org
mod_auth_pgsql implements authentication and logging routines using PostgreSQL tables for Apache's authentication protocol.

    Download

    Source package: libapache2-mod-auth-pgsql

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libapache2-mod-auth-pgsql deb package:
      # sudo apt-get install libapache2-mod-auth-pgsql

    Files

    • /etc/apache2/mods-available/000_auth_pgsql.load
    • /usr/lib/apache2/modules/mod_auth_pgsql.so
    • /usr/share/doc-base/libapache2-mod-auth-pgsql
    • /usr/share/doc/libapache2-mod-auth-pgsql/NEWS.Debian.gz
    • /usr/share/doc/libapache2-mod-auth-pgsql/README
    • /usr/share/doc/libapache2-mod-auth-pgsql/TODO
    • /usr/share/doc/libapache2-mod-auth-pgsql/changelog.Debian.gz
    • /usr/share/doc/libapache2-mod-auth-pgsql/copyright
    • /usr/share/doc/libapache2-mod-auth-pgsql/mod_auth_pgsql.html

    Changelog

    2015-01-17 - Neil Williams <codehelp@debian.org> libapache2-mod-auth-pgsql (2.0.3-6.1) unstable; urgency=medium * Non-maintainer upload. * Apply patch from Launchpad to set freed pointers to NULL before subsequent checks against NULL. (Closes: #774313)

    2013-08-10 - Marco Nenciarini <mnencia@debian.org> libapache2-mod-auth-pgsql (2.0.3-6) unstable; urgency=low [ Peter Pentchev ] * Convert to the 3.0 (quilt) source format. * Use "PostgreSQL" instead of "pgsql" and "postgresql" in the package synopsis and long description. * Add a Homepage control field. * Add a blank line to the end of debian/NEWS to satisfy Lintian. * Add a doc-base file describing the HTML manual. * Add the 03-encoding.patch to allow a configurable connection encoding and to properly escape client-supplied values. (Closes: #512672) [ Marco Nenciarini ] * Minimize the rules file using debhelper 7 with apache2 sequencer. * Bump Standards-Version to 3.9.4: - change the section to "httpd" from "web" * Mention the logging ability in long desription. * Add the 04-apache-2.4.patch to make the package working with Apache 2.4. Patch from http://www.sky-air.net/wordpress/mod_auth_pgsql-at-apache2-4-2 (CLoses: #666814) * Drop postinst/prerm logic to migrate the load file name to 000_ prefix, as even the oldstable distribution has the 2.0.3-5 version. * Add VCS-* field URI in debian/control

    2007-10-16 - Marco Nenciarini <mnencia@debian.org> libapache2-mod-auth-pgsql (2.0.3-5) unstable; urgency=low [ Micha Lenk ] * Rename the config snippet in /etc/apache2/mods-available/ and the corresponding symlink in /etc/apache2/mods-enabled/ now having prefix 000_ in order to load the module auth_pgsql prior to other authentication modules (Closes: #399562). * On upgrade let the postinst script try to fix this bug too. [ Marco Nenciarini ] * debian/rules: removed dash from make clean invocation fixes lintian debian-rules-ignores-make-clean-error

    2006-10-08 - Marco Nenciarini <mnencia@debian.org> libapache2-mod-auth-pgsql (2.0.3-4) unstable; urgency=low * Bump debhelper compat level to 5. * Update Debian policy to version 3.7.2.2. No changes required. * Build with apache 2.2 (Closes: #391756)

    2006-03-14 - Marco Nenciarini <mnencia@debian.org> libapache2-mod-auth-pgsql (2.0.3-3) unstable; urgency=high * Force reloading of apache2 when mod-auth-pgsql is upgraded. (Closes: #356426) * urgency=high due to recent security issue. (Apache servers can often run for many months without needing to be restarted, so they would be still vulnerable.)

    2006-01-16 - Marco Nenciarini <mnencia@debian.org> libapache2-mod-auth-pgsql (2.0.3-2) unstable; urgency=low * debian/prerm: Fixed bashism (test with -[ao]).

    2006-01-15 - Marco Nenciarini <mnencia@debian.org> libapache2-mod-auth-pgsql (2.0.3-1) unstable; urgency=low * New upstream release

    2006-01-11 - Marco Nenciarini <mnencia@debian.org> libapache2-mod-auth-pgsql (2.0.2b1-7) unstable; urgency=high * SECURITY UPDATE: Arbitrary remote code execution with www-data privileges. CVE-2005-3656 Fix several format string vulnerabilities in ap_log_[rp]error() calls (patch stolen from Ubuntu) * debian/control: Bump Standards-Version to 3.6.2.0; no changes required

    2005-06-17 - Marco Nenciarini <mnencia@debian.org> libapache2-mod-auth-pgsql (2.0.2b1-6) unstable; urgency=low * Transition to new PostgreSQL architecture. * debian/control: Changed build dependency postgresql-dev to libpq-dev. * Makefile: Use pg_config to determine include directory.

    2004-08-23 - Marco Nenciarini <mnencia@debian.org> libapache2-mod-auth-pgsql (2.0.2b1-5) unstable; urgency=low * Added proper debian/watch file. * Modified debian/copyright to report the right dowload url.

    Advertisement
    Advertisement