libapache2-mod-apreq2_2.13-4+b1_amd64.deb


Advertisement

Description

libapache2-mod-apreq2 - generic Apache request library - Apache module

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libapache2-mod-apreq2
Package version 2.13
Package release 4+b1
Package architecture amd64
Package type deb
Installed size 169 B
Download size 50.86 KB
Official Mirror ftp.br.debian.org
The generic Apache request library (APR) contains modules for manipulating
client request data with the Apache API from Perl and C. Functionality
includes:
- parsing of application/x-www-form-urlencoded data
- parsing of multipart/form-data
- parsing of HTTP Cookies
This package contains the Apache module itself.

Alternatives

Package Version Architecture Repository
libapache2-mod-apreq2_2.13-4+b1_i386.deb 2.13 i386 Debian Main
libapache2-mod-apreq2 - - -

Requires

Name Value
apache2-api-20120211 -
libapr1 >= 1.2.7
libapreq2-3 = 2.13-4+b1
libaprutil1 >= 1.2.7+dfsg
libc6 >= 2.4

Replaces

Name Value
libapache2-request-perl << 2.05-dev-3
libapreq2 << 2.05-dev-5

Download

Type URL
Binary Package libapache2-mod-apreq2_2.13-4+b1_amd64.deb
Source Package libapreq2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libapache2-mod-apreq2 deb package:
    # sudo apt-get install libapache2-mod-apreq2

Files

Path
/etc/apache2/mods-available/apreq2.load
/usr/lib/apache2/modules/mod_apreq2.a
/usr/lib/apache2/modules/mod_apreq2.so
/usr/share/doc/libapache2-mod-apreq2/README
/usr/share/doc/libapache2-mod-apreq2/changelog.Debian.amd64.gz
/usr/share/doc/libapache2-mod-apreq2/changelog.Debian.gz
/usr/share/doc/libapache2-mod-apreq2/changelog.gz
/usr/share/doc/libapache2-mod-apreq2/copyright

Changelog

2014-07-17 - Steinar H. Gunderson <sesse@debian.org>
libapreq2 (2.13-4) unstable; urgency=medium
* Use $Config{vendorarch} instead of hard-coding /usr/lib/perl5
in the .install file. (Closes: #754996)
* Upgrade to debhelper compat v9. Bump versioned Build-Depends.
* Make libapache2-request-perl.install into an executable Perl script,
and make it output the right path runtime.
* Bump Standards-Version to 3.9.5 (no changes needed).
2013-11-15 - Steinar H. Gunderson <sesse@debian.org>
libapreq2 (2.13-3) unstable; urgency=high
* urgency=high, fixes an RC bug.
* Convert libapreq2-3 to multiarch; fixes an FTBFS as libtool
would sometimes want to relink mod_apreq2.so under make install, and only
looked in the multiarch directory when it did. (Closes: #729648)
* 04-pass-libdir-to-configure.patch: New patch, pass --libdir from
Makefile.PL to configure.
* In debian/rules, give the correct multiarch --libdir to Makefile.PL.
* Adjust the paths in libapreq2-3.install and libapreq2-dev.install
so that they are correct for multiarch.
* Delete unused patch 04-foo.
2013-07-30 - Julien Cristau <jcristau@debian.org>
libapreq2 (2.13-2.1) unstable; urgency=high
* Non-maintainer upload.
* Version libapreq2-3's Conflicts/Replaces on libapreq2 as << 2.13-2~
(closes: #717026).
2013-07-15 - Steinar H. Gunderson <sesse@debian.org>
libapreq2 (2.13-2) unstable; urgency=low
* Build against Apache 2.4. (Closes: #666802)
* Build-depend on apache2-dev instead of apache2-prefork-dev. 
* Depend on apache2-api-20120211 instead of apache2.2-common.
* Use dh_apache2 for handling of maintainer scripts and .load files
instead of calling a2dismod ourselves.
* Add a build-dependency on the virtual package dh_apache2.
* Fix some Lintian issues.
* Rename apreq.load to apreq2.load.
* Create a dummy build-indep target.
* Switch to build flags from dpkg-buildflags (many smaller hacks needed
to make them propagate correctly throughout the build system),
to get the hardening flags right.
* Add versioned dependency on dpkg-dev to get the buildflags.mk file.
* Rename libapreq2 to libapreq2-3.
* Add appropriate Conflicts/Replaces on the old libapreq2 package
for a smooth transition.
* Update internal dependencies.
* Bump Standards-Version to 3.9.4.
* Build mod_apreq2.so with no rpath, by hacking libtool after configure.
For some reason, seemingly this was not reported properly by Lintian
before.
* Call dh_autotools-dev* at the right points to get updated config.sub
and config.guess.
* Build-depend on autotools-dev.
* Make the shlibs file contain a versioned dependency. (Closes: #697683)
2011-02-28 - Steinar H. Gunderson <sesse@debian.org>
libapreq2 (2.13-1) unstable; urgency=low
* New upstream release.
* Properly links in libapr-1 when building binaries.
(Closes: #615739)
* Don't install .la files (remove from libapreq2-dev.install and
libapache2-mod-apreq2.install); the one we installed was broken,
and they're generally discouraged anyway.
(Not reported in Debian, but LP: #651396, and fixes a Lintian error.)
* Update to Standards-Version 3.9.1 (no changes needed).
2010-05-26 - Steinar H. Gunderson <sesse@debian.org>
libapreq2 (2.12-2) unstable; urgency=medium
* 03-link-in-apr-shared-objects.patch: New patch, fixes so APR shared
objects are properly linked into the Perl modules. This makes it possible
to load the modules (although still not instantiate Apache2::Request
objects) from scripts that are not run under mod_perl.
Fix from Damyan Ivanov. (Closes: #573062)

See Also

Package Description
libapache2-mod-auth-cas_1.0.9.1-4_amd64.deb CAS authentication module for Apache2
libapache2-mod-auth-gssapi_1.0.3-2_amd64.deb GSSAPI Authentication module for Apache2
libapache2-mod-auth-kerb_5.4-2.2_amd64.deb apache2 module for Kerberos authentication
libapache2-mod-auth-mellon_0.9.1-1_amd64.deb SAML 2.0 authentication module for Apache
libapache2-mod-auth-ntlm-winbind_0.0.0.lorikeet+svn+801-4_amd64.deb apache2 module for NTLM authentication against Winbind
libapache2-mod-auth-openid_0.8-1_amd64.deb OpenID authentication module for Apache2
libapache2-mod-auth-openidc_1.6.0-1_amd64.deb OpenID Connect authentication module for Apache
libapache2-mod-auth-pgsql_2.0.3-6.1_amd64.deb Module for Apache2 which provides PostgreSQL authentication
libapache2-mod-auth-plain_2.0.52_amd64.deb Module for Apache2 which provides plaintext authentication
libapache2-mod-auth-pubtkt_0.8-4_amd64.deb key-based single-sign-on authentication module for Apache
libapache2-mod-auth-tkt_2.1.0+dfsg-1_amd64.deb lightweight single-sign-on authentication module for Apache
libapache2-mod-authn-sasl_1.2-2_amd64.deb SASL authentication backend provider for Apache
libapache2-mod-authn-webid_0~20110301-2_amd64.deb WebID FOAF+SSL authentication module for Apache
libapache2-mod-authnz-external_3.3.2-0.1+b1_amd64.deb authenticate Apache against external authentication services
libapache2-mod-authnz-pam_0.9.3-1_amd64.deb PAM authorization checker and PAM Basic Authentication provider
Advertisement
Advertisement