libapache-htpasswd-perl_1.8-1.1_all.deb


Advertisement

Description

libapache-htpasswd-perl - Manage Unix crypt-style password file

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libapache-htpasswd-perl
Package version: 1.8
Package release: 1.1
Package architecture: all
Package type: deb
Installed size: 80 B
Download size: 15.95 KB
Official Mirror: ftp.br.debian.org
This module comes with a set of methods to use with htaccess password files. These files (and htaccess) are used to do Basic Authentication on a web server. The passwords file is a flat-file with login name and their associated crypted password. You can use this for non-Apache files if you wish, but it was written specifically for .htaccess style files.

Alternatives

    Download

    Source package: libapache-htpasswd-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libapache-htpasswd-perl deb package:
      # sudo apt-get install libapache-htpasswd-perl

    Files

    • /usr/share/doc/libapache-htpasswd-perl/README.gz
    • /usr/share/doc/libapache-htpasswd-perl/changelog.Debian.gz
    • /usr/share/doc/libapache-htpasswd-perl/copyright
    • /usr/share/man/man3/Apache::Htpasswd.3pm.gz
    • /usr/share/perl5/Apache/Htpasswd.pm

    Changelog

    2011-08-20 - Salvatore Bonaccorso <carnil@debian.org> libapache-htpasswd-perl (1.8-1.1) unstable; urgency=low * Non-maintainer upload. * patch HTpasswd.pm, META.yml, Makefile.PL and test.pl to use Digest::SHA from perl core instead of Digest::SHA1. The patch also fixes the test to check for Digest::SHA instead of Digest::MD5 when testing SHA1-hashed passwords. Drop libdigest-sha1-perl from (Build-)Depends. (Closes: #636853).

    2009-01-03 - Tatsuki Sugiura <sugi@nemui.org> libapache-htpasswd-perl (1.8-1) unstable; urgency=low * New upstream release. (Closes: #468266, 493050) NMU Patch was applied. Thanks Jaldhar H. Vyas.

    2008-02-27 - Jaldhar H. Vyas <jaldhar@debian.org> libapache-htpasswd-perl (1.8-0.1) unstable; urgency=low * NMU. * New upstream version (Closes: #439461) * Added dependencies. * Fixed lintian errors + standards version 3.7.3 + Build-Depends instead of Build-Depends-Indep + proper copyright notice.

    2005-10-27 - Tatsuki Sugiura <sugi@nemui.org> libapache-htpasswd-perl (1.6.0-1) unstable; urgency=low * New upstream release (Closes: #329490, #177023)

    2002-08-31 - Tatsuki Sugiura <sugi@nemui.org> libapache-htpasswd-perl (1.5.5-1) unstable; urgency=low * New upstream release

    2002-08-21 - Tatsuki Sugiura <sugi@nemui.org> libapache-htpasswd-perl (1.5.3-3) unstable; urgency=low * build script has been changed; package was build with binary-indep (Closes: #157461)

    2002-06-17 - Tatsuki Sugiura <sugi@nemui.org> libapache-htpasswd-perl (1.5.3-2) unstable; urgency=low * source package has been updated for new policy * dependency has been fixed * upload debian offical archive (Closes: #150195)

    2002-06-17 - Tatsuki Sugiura <sugi@nemui.org> libapache-htpasswd-perl (1.5.3-1) unstable; urgency=low * New upstream release

    2001-04-07 - Tatsuki Sugiura <sugi@assist.media.nagoya-u.ac.jp> libapache-htpasswd-perl (1.5.2-1) unstable; urgency=low * upstream update (applied 1.5.1p1-1's newline patch)

    2001-04-04 - Tatsuki Sugiura <sugi@assist.media.nagoya-u.ac.jp> libapache-htpasswd-perl (1.5.1p1-1) unstable; urgency=low * upstream update * newline patch applied

    Advertisement
    Advertisement