libalien-sdl-perl_1.444-1_all.deb


Advertisement

Description

libalien-sdl-perl - helper to get, build and use SDL libraries

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libalien-sdl-perl
Package version: 1.444
Package release: 1
Package architecture: all
Package type: deb
Installed size: 34 B
Download size: 22.82 KB
Official Mirror: ftp.br.debian.org
Perl's idea of a metapackage to provide C library dependencies for Perl SDL application. When building from source, this package can be used to detect and get configuration settings from an installed SDL and related libraries. As a binary package, it provides on native libs used when building this package. This package provides Perl module Alien::SDL

Alternatives

    Download

    Source package: libalien-sdl-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libalien-sdl-perl deb package:
      # sudo apt-get install libalien-sdl-perl

    Files

    • /usr/share/doc/libalien-sdl-perl/README.gz
    • /usr/share/doc/libalien-sdl-perl/TODO
    • /usr/share/doc/libalien-sdl-perl/changelog.Debian.gz
    • /usr/share/doc/libalien-sdl-perl/changelog.gz
    • /usr/share/doc/libalien-sdl-perl/copyright
    • /usr/share/man/man3/Alien::SDL.3pm.gz
    • /usr/share/man/man3/Alien::SDL::ConfigData.3pm.gz
    • /usr/share/perl5/Alien/SDL.pm
    • /usr/share/perl5/Alien/SDL/ConfigData.pm

    Changelog

    2014-09-30 - Damyan Ivanov <dmn@debian.org> libalien-sdl-perl (1.444-1) unstable; urgency=medium * Team upload [ Dominique Dumont ] * Imported Upstream version 1.444 * copyright: updated year * added patch to fix build option in Build.PL [ Salvatore Bonaccorso ] * Update Vcs-Browser URL to cgit web frontend [ Damyan Ivanov ] * add explicit build-dependency on libmodule-build-perl it is being phased out of perl core * build-depend on libjpeg-dev instead of libjpeg8-dev (Closes: #763477) * adjust the libjpeg-dev dependency of libalien-sdl-dev-perl too * Standards-Version: 3.9.6 (no changes needed)

    2014-04-11 - Dominique Dumont <dod@debian.org> libalien-sdl-perl (1.440-5) unstable; urgency=medium [ gregor herrmann ] * Strip trailing slash from metacpan URLs. [ Dominique Dumont ] * copyright: updated year * control: - removed hard-coded dependencies on lib packages (Closes: #744146) * updated descriptions

    2014-01-26 - gregor herrmann <gregoa@debian.org> libalien-sdl-perl (1.440-4) unstable; urgency=medium * Team upload. * (Build-)depend on unversioned libtiff-dev/libtiff5. Closes: #736718 * Declare compliance with Debian Policy 3.9.5.

    2013-09-09 - Dominique Dumont <dod@debian.org> libalien-sdl-perl (1.440-3) unstable; urgency=low * control: * Put back alternate deps on libgl1* which are virtual packages * add version to BD on libtiff4

    2013-09-08 - Dominique Dumont <dod@debian.org> libalien-sdl-perl (1.440-2) unstable; urgency=low [ gregor herrmann ] * Explicitly build-depend on Archive::Extract. (Closes: #711680) [ Dominique Dumont ] * Added patch to disable link with rpath. Otherwise lintian complains loudly about libsdl-perl * control: * added a version to libtiff4 dependency - removed alternate dep to unknown libgl1 package * copyright: updated years * bumped compat to 9

    2013-05-13 - gregor herrmann <gregoa@debian.org> libalien-sdl-perl (1.440-1) unstable; urgency=low * Team upload. [ gregor herrmann ] * debian/control: update {versioned,alternative} (build) dependencies. * Adjust build and runtime dependencies to allow other OpenGL implementations. Thanks to Jerome Vouillon for the bug report. (Closes: #695027) * debian/rules: make override more dh-ish. * debian/control: remove unused ${perl:Depends} from libalien-sdl-dev- perl. [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) * Change search.cpan.org based URIs to metacpan.org based URIs [ gregor herrmann ] * New upstream release. Fixes "fatal error with perl 5.18: SDL.h'tempfile' can't be called as a method at /usr/share/perl5/Alien/SDL.pm line 243." (Closes: #708082) * debian/copyright: switch formatting to Copyright-Format 1.0. * Bump debhelper compatibility level to 8. * Set Standards-Version to 3.9.4 (no changes).

    2012-02-25 - Dominique Dumont <dod@debian.org> libalien-sdl-perl (1.430-4) unstable; urgency=low * control: added missing dependencies on libsdl-net1.2*

    2012-02-25 - Dominique Dumont <dod@debian.org> libalien-sdl-perl (1.430-3) unstable; urgency=low * control: new libalien-sdl-dev-perl metapackage. * control: bumped standard version to 3.9.3 (no other changes)

    2012-02-22 - Dominique Dumont <dod@debian.org> libalien-sdl-perl (1.430-2) unstable; urgency=low * copyright: updated (c) year * control: * updated description + added missing runtime dependencies

    2012-01-15 - Dominique Dumont <dod@debian.org> libalien-sdl-perl (1.430-1) unstable; urgency=low * Imported Upstream version 1.430 * control: add dependency info to help backport on squeeze

    Advertisement
    Advertisement