libadns1-dev_1.5.0~rc1-1_amd64.deb


Advertisement

Description

libadns1-dev - Asynchronous-capable DNS client library (development)

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libadns1-dev
Package version 1.5.0~rc1
Package release 1
Package architecture amd64
Package type deb
Installed size 240 B
Download size 79.73 KB
Official Mirror ftp.br.debian.org
adns is a resolver library for C (and C++) programs.  In contrast
with many existing interfaces, it can be used in an asynchronous,
non-blocking manner, and has a convenient interface which doesn't
require the application to handle any DNS data formats.  Many queries
can be handled simultaneously.
This package contains the development files used for C/C++ programs.

Alternatives

Package Version Architecture Repository
libadns1-dev_1.5.0~rc1-1_i386.deb 1.5.0~rc1 i386 Debian Main
libadns1-dev - - -

Requires

Name Value
libadns1 = 1.5.0~rc1-1
libc6-dev -

Conflicts

Name Value
libadns0 -

Download

Type URL
Binary Package libadns1-dev_1.5.0~rc1-1_amd64.deb
Source Package adns

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libadns1-dev deb package:
    # sudo apt-get install libadns1-dev

Files

Path
/usr/include/adns.h
/usr/lib/libadns.a
/usr/lib/libadns.so
/usr/share/doc/libadns1-dev/GPL-vs-LGPL.gz
/usr/share/doc/libadns1-dev/README.Debian
/usr/share/doc/libadns1-dev/README.gz
/usr/share/doc/libadns1-dev/README.html
/usr/share/doc/libadns1-dev/TODO
/usr/share/doc/libadns1-dev/changelog.Debian.gz
/usr/share/doc/libadns1-dev/changelog.gz
/usr/share/doc/libadns1-dev/copyright

Changelog

2014-10-26 - Ian Jackson <ijackson@chiark.greenend.org.uk>
adns (1.5.0~rc1-1) unstable; urgency=medium
* New upstream version.  Closes:#411263.
There are now no changes to upstream code (other than .gitignore).
* Remove vbuf__append_quoted1035 from symbols file.
* Add missing Build-Dependency on `lynx' (for README).
2014-10-20 - Ian Jackson <ijackson@chiark.greenend.org.uk>
adns (1.5.0~rc0-0~exp1) experimental; urgency=low
* New upstream version.  Closes: #392102, #384372.
* Not using upstream tarball because it contains some junk.
* Made myself the Maintainer.  Closes: #765629.
* Delete spurious Makefile and src/config.h.
* Clarify and improve package Descriptions.
* In symbols file: ignore all symbols `adns__*' with a regex rule.
* Remove obsolete emacs local variables stanza from debian/changelog.
* Add dh and debian files to .gitignore.
* Add -dbg package.  Closes: #489301.
* Remove values from rcsids, to remove diffs from upstream.
* Add ${misc:Depends} to quieten lintian (no change to the .debs).
* Support dpkg-buildflags (ie, build with hardening).
* Patch regress/Makefile.in to fix problem with .SECONDARY declaration.
* Add test case output and common.make to `make [dist]clean'.
2008-09-17 - Robert S. Edmonds <edmonds@debian.org>
adns (1.4-2) unstable; urgency=low
* Acknowledge NMU.
* libadns1 'Recommends: libadns1-bin' to 'Suggests: adns-tools'; closes:
#435593, #491513.
* Document CVE-2008-1447 / CVE-2008-4100 poisoning vulnerability in
README.Debian; closes: #492698.
2008-07-24 - Ian Jackson <ian@davenant.greenend.org.uk>
adns (1.4-1.1) unstable; urgency=low
* adns-tools Provides libadns1-bin.  Closes: #492145.
2008-06-15 - Robert S. Edmonds <edmonds@debian.org>
adns (1.4-1) unstable; urgency=low
* New maintainer; closes: #485995.
* Acknowledge NMU; closes: #361419.
* Rename libadns1-bin to adns-tools; closes: #91298, #349797.
2006-10-17 - Ian Jackson <ian@davenant.greenend.org.uk>
adns (1.4-0.1) unstable; urgency=low
* New upstream version, in NMU by upstream, approved by Debian
maintainer (closes: #361419).  Package is almost exactly upstream 1.4
with .diff.gz from 1.1-4; all Debian changes outside debian/* have
been addressed upstream.  Changes to debian/*:
- provision of libadns.so by debian/rules is no longer needed as this
is done by the upstream makefiles.
- new utility adnsheloex moved out of -dev package into -bin.
2005-12-10 - Bernd Eckenfels <ecki@debian.org>
adns (1.1-4) unstable; urgency=low
* re-applied missing hack to make regression  tests work on hurd kernel
* make sure hcommon.c is rebuild on debian builds
2005-12-09 - Bernd Eckenfels <ecki@debian.org>
adns (1.1-3) unstable; urgency=low
* yet another architecture problem: sparc requires ENOTSOCK which is
defined in regress/hcommon.c but not regress/hcommon.c.m4
2005-12-09 - Bernd Eckenfels <ecki@debian.org>
adns (1.1-2) unstable; urgency=low
* added int castings for len arg pointer arithmetic to printf
* removed some memleak details, cause this makes ALPHA and IA64 builds fail
2005-12-08 - Bernd Eckenfels <ecki@debian.org>
adns (1.1-1) unstable; urgency=low
* new upstream version (Closes: #342491)
* not all patches took over (debian/todo-patches.txt)
works on sparc64 gcc4
* new standards version (3.1 -> 3.6.1) no changes
* thanks to NMUs

See Also

Package Description
libadns1_1.5.0~rc1-1_amd64.deb Asynchronous-capable DNS client library
libadolc-dev_2.5.2-2_amd64.deb ADOLC development libs and headers
libadolc2_2.5.2-2_amd64.deb ADOLC automatic differentiation system, runtime libs
libadplug-2.2.1-0_2.2.1+dfsg3-0.1_amd64.deb free AdLib sound library
libadplug-dev_2.2.1+dfsg3-0.1_amd64.deb free AdLib sound library (development)
libaether-java_1.13.1-2_all.deb Library to handle Java artifact repositories
libafflib-dev_3.7.5-1_amd64.deb Advanced Forensics Format Library (development files)
libafflib0_3.7.5-1_amd64.deb Advanced Forensics Format Library
libafs-pag-perl_1.02-1+b1_amd64.deb Perl bindings for AFS PAG manipulation
libafsauthent1_1.6.9-2+deb8u7_amd64.deb AFS distributed file system runtime library (authentication)
libafsrpc1_1.6.9-2+deb8u7_amd64.deb AFS distributed file system runtime library (RPC layer)
libafterimage-dev_2.2.12-3_amd64.deb imaging library designed for AfterStep - development files
libafterimage0_2.2.12-3_amd64.deb imaging library designed for AfterStep - runtime files
libafterstep1_2.2.12-3_amd64.deb shared libraries for the AfterStep window manager
libagg-dev_2.5+dfsg1-9_amd64.deb AntiGrain Geometry graphical toolkit (development files)
Advertisement
Advertisement