libace-flreactor-dev_6.2.8+dfsg-1_amd64.deb


Advertisement

Description

libace-flreactor-dev - ACE-GUI reactor integration for FLTK - development files

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libace-flreactor-dev
Package version 6.2.8+dfsg
Package release 1
Package architecture amd64
Package type deb
Installed size 66 B
Download size 44.82 KB
Official Mirror ftp.br.debian.org
This package contains header files and static library for the ACE-FLTK
reactor integration.

Alternatives

Package Version Architecture Repository
libace-flreactor-dev_6.2.8+dfsg-1_i386.deb 6.2.8+dfsg i386 Debian Main
libace-flreactor-dev - - -

Requires

Name Value
libace-dev = 6.2.8+dfsg-1
libace-flreactor-6.2.8 = 6.2.8+dfsg-1
libfltk1.1-dev >= 1.1.4

Download

Type URL
Binary Package libace-flreactor-dev_6.2.8+dfsg-1_amd64.deb
Source Package ace

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libace-flreactor-dev deb package:
    # sudo apt-get install libace-flreactor-dev

Files

Path
/usr/include/ace/FlReactor/ACE_FlReactor_export.h
/usr/include/ace/FlReactor/FlReactor.h
/usr/lib/libACE_FlReactor.so
/usr/lib/pkgconfig/ACE_FlReactor.pc
/usr/share/doc/libace-flreactor-dev/changelog.Debian.gz
/usr/share/doc/libace-flreactor-dev/changelog.gz
/usr/share/doc/libace-flreactor-dev/copyright
/usr/share/lintian/overrides/libace-flreactor-dev

Changelog

2014-10-01 - Pau Garcia i Quiles <pgquiles@elpauer.org>
ace (6.2.8+dfsg-1) unstable; urgency=medium
* New upstream version
* Drop patch 25-versioned_so.diff (applied upstream)
* Drop patch 36-fix-typos.diff (applied upstream)
* Drop patch 38-fix-predictable-filename-in-tmp.diff (applied upstream)
* Drop patch largefile.diff (applied upstream)
2014-09-07 - Pau Garcia i Quiles <pgquiles@elpauer.org>
ace (6.2.7+dfsg-2) unstable; urgency=medium
* Add patch 38-fix-predictable-filename-in-tmp. Closes: #760709
2014-06-29 - Pau Garcia i Quiles <pgquiles@elpauer.org>
ace (6.2.7+dfsg-1) unstable; urgency=low
[ Johnny Willemsen ]
* New upstream release. Closes: #746825, #724774, #734393
[ Pau Garcia i Quiles ]
* Enable hardening
* Add Large File Support
* Add lintian overrides for safe-to-be-ignored issues
* Add patch 36-fix-typos (submitted upstream)
* Add patch 37-remove-google-tracking
* Update standards to 3.9.5.0
* Repack upstream source using get-orig-source.sh and add usage note to
README.source
* Remove all TAO-related stuff due to DFSG-incompatibility
* Remove deprecated DM-Upload-Allowed field
2013-01-01 - Thomas Girard <thomas.g.girard@free.fr>
ace (6.1.7-1) UNRELEASED; urgency=low
[ Pau Garcia i Quiles ]
* New upstream release
* Add new library ACE XML_Utils (packages: libace-xml-utils-{6.1.3,dev})
(adds a build-depenency on xerces3)
[ Johnny Willemsen ]
* Integrate most Debian changes into upstream repo, hence drop no longer
relevant patches.
* Ship and use TAO_ACE.mwc; this simplify makefile generation, compilation,
and installation.
[ Thomas Girard ]
* debian/README.source: update instructions.
* debian/patches/15-use-lzo2.diff: rework this patch.
* debian/fix_doxygen.sh: adapt to latest changes.
* debian/patches/reduce-doxygen-doc.diff: regenerate.
* debian/control lintian fixes:
o Bump Standards-Version: to 3.9.4.
o Tighen dependency on debhelper to be on par with debian/compat.
o Drop obsolete DM-Upload-Allowed: section. For the record, details
on how to do this now is available from:
https://lists.debian.org/debian-devel-announce/2012/09/msg00008.html
* Add *_RLECompressor and ACE_Compressor libraries.
2012-06-16 - Thomas Girard <thomas.g.girard@free.fr>
ace (6.1.2-1) experimental; urgency=low
* New upstream release.
* debian/patches/16-ace-inet-pkgconfig-files.diff: drop, integrated.
* debian/patches/prevent_doxygen_ace_manpages.diff: ditto.
* debian/patches/reduce-doxygen-doc.diff: reworked since HTMLHelp is
no longer generated.
* debian/patches/20-versioned_libs.diff: refreshed.
* debian/patches/34-bts386713.diff: refreshed.
* debian/patches/92-default-ACE_ROOT.diff: refreshed.
2013-10-08 - Barak A. Pearlmutter <bap@debian.org>
ace (6.0.3+dfsg-0.2) unstable; urgency=low
* NMU to rebuild with up-to-date tool chain (closes: #723856)
2013-01-23 - Ralf Treinen <treinen@debian.org>
ace (6.0.3+dfsg-0.1) unstable; urgency=low
* NMU with maintainers blessing.
* Remove upstream files with nonfree licence (closes: #697848) or
without source (closes: #697847):
- repack the orig tarball by removing:
bin/LabVIEW_RT/*.exe
examples/{C++NPv2,C++NPv1,APG}/
TAO/
- debian/control: drop all packages named *tao*
- debian/rules: drop everything related to tao
- remove all hunks applying to TAO files in patch
- reduce-doxygen-doc.diff
- drop patch 34-bts386713.diff since it applies only to TAO files.
- debian/copyright: remove copyright entries of TAO/, and of the 
directories under examples/ that have been removed.
* Bump version in build-dependency on debhelper to >=9 since we are using
debhelper compatibility level 9.

See Also

Package Description
libace-foxreactor-6.2.8_6.2.8+dfsg-1_amd64.deb ACE-GUI reactor integration for FOX
libace-foxreactor-dev_6.2.8+dfsg-1_amd64.deb ACE-GUI reactor integration for FOX - development files
libace-htbp-6.2.8_6.2.8+dfsg-1_amd64.deb ACE protocol over HTTP tunneling library
libace-htbp-dev_6.2.8+dfsg-1_amd64.deb ACE protocol over HTTP tunneling library - development files
libace-inet-6.2.8_6.2.8+dfsg-1_amd64.deb ACE Inet protocol library
libace-inet-dev_6.2.8+dfsg-1_amd64.deb ACE Inet protocol library - development files
libace-inet-ssl-6.2.8_6.2.8+dfsg-1_amd64.deb ACE SSL-enabled Inet protocol library
libace-inet-ssl-dev_6.2.8+dfsg-1_amd64.deb ACE SSL-enabled Inet protocol library - development files
libace-perl_1.92-3+b1_amd64.deb Object-Oriented Access to ACEDB Databases
libace-qtreactor-6.2.8_6.2.8+dfsg-1_amd64.deb ACE-GUI reactor integration for Qt
libace-qtreactor-dev_6.2.8+dfsg-1_amd64.deb ACE-GUI reactor integration for Qt - development files
libace-rmcast-6.2.8_6.2.8+dfsg-1_amd64.deb ACE reliable multicast library
libace-rmcast-dev_6.2.8+dfsg-1_amd64.deb ACE reliable multicast library - development files
libace-ssl-6.2.8_6.2.8+dfsg-1_amd64.deb ACE secure socket layer library
libace-ssl-dev_6.2.8+dfsg-1_amd64.deb ACE secure socket layer library - development files
Advertisement
Advertisement