levee_3.5a-3_amd64.deb


Advertisement

Description

levee - very small vi clone

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name levee
Package version 3.5a
Package release 3
Package architecture amd64
Package type deb
Installed size 130 B
Download size 51.93 KB
Official Mirror ftp.br.debian.org
Extremely small screen oriented editor based on the Unix editor "vi".
It provides a terse, powerful way to enter and edit text. This
programs dates back to 1980's; at the dawn of personal computing.

Alternatives

Package Version Architecture Repository
levee_3.5a-3_i386.deb 3.5a i386 Debian Main
levee - - -

Requires

Name Value
libc6 >= 2.4
libtinfo5 -

Provides

Name Value
editor -

Download

Type URL
Binary Package levee_3.5a-3_amd64.deb
Source Package levee

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install levee deb package:
    # sudo apt-get install levee

Files

Path
/usr/bin/levee
/usr/share/doc/levee/NEWS.Debian.gz
/usr/share/doc/levee/changelog.Debian.gz
/usr/share/doc/levee/changelog.gz
/usr/share/doc/levee/copyright
/usr/share/man/man1/levee.1.gz
/usr/share/menu/levee

Changelog

2012-03-23 - Jari Aalto <jari.aalto@cante.net>
levee (3.5a-3) unstable; urgency=low
* debian/control
- (Build-Depends): Rm dpkg-dev; not needed with debhelper 9.
- (Standards-Version): Update to 3.9.3.1.
* debian/copyright
- Update to format 1.0.
* debian/rules
- Enable all hardening flags.
- Use DEB_*_MAINT_* variables.
2012-02-23 - Jari Aalto <jari.aalto@cante.net>
levee (3.5a-2) unstable; urgency=low
* New maintainer. (Closes: #558604)
* debian/copyright
- Update to DEP5.
* debian/levee.<name>
- Rename files to plain <name>.
* debian/menu
- (Description): improve content.
* debian/patches
- Remove dpkg generated patch. Everything is already included in
separate patches (Closes: #643179).
* debian/compat
- Update to 9.
* debian/control
- (Vcs-*): Move from Svn to Git.
- (Build-Depends): debhelper 9, dpkg-dev 1.16.1.
- (Depends): Add ${misc:Depends}.
- (Description): Add more details (Lintian).
- (Standards-Version): 3.9.2.
* debian/{manpages,install}
- New files.
* debian/rules
- Update to dh(1).
- Use hardened CFLAGS.
http://wiki.debian.org/ReleaseGoals/SecurityHardeningBuildFlags
* debian/upstream.changelog
- New file.
[tony mancill]
* Add myself to Uploaders: in d/control. 
2010-02-14 - Jari Aalto <jari.aalto@cante.net>
levee (3.5a-1.1) unstable; urgency=low
* Non-maintainer upload.
* Move to packaging format "3.0 (quilt)" due to patch.
* debian/patches
- (Number 10): Add patch to fix Gcc 4.4 error: conflicting types
for getline (RC bug FTBFS serious; Closes: #548965).
2008-06-24 - Felipe Augusto van de Wiel (faw) <faw@debian.org>
levee (3.5a-1) unstable; urgency=low
* New upstream release.
* Providing virtual package 'editor'. (Closes: #398748).
* Fixed documentation. (Closes: #144956, #144957).
- levee upstream calls it lv but in Debian we have a name conflict, so
the binaries, manpages and documentation should point to levee in
Debian.
* Fixed items pointed by Lintian warnings.
- debian-rules-ignores-make-clean-error
[ ! -f Makefile ] || $(MAKE) distclean
- ancient-standards-version
Updated Standards-Version from 3.7.2 to 3.8.0 without any changes.
- debian-rules-sets-DH_COMPAT
Removed DH_COMPAT from debian/rules and added debian/compat.
- menu-item-uses-apps-section
Renamed Apps to Applications in debian/menu and fixed levee long title.
* Added a debian/watch.
* Added Vcs-Svn, Vcs-Browser and Homepage to debian/control.
* Added NEWS.Debian with info about the binary name.
* Updated dbian/rules with some clean up.
* Updated debian/copyright.
* Updated maintainer scripts.
- Added preinst to fix the update-alternatives from old name.
2006-07-30 - Felipe Augusto van de Wiel (faw) <felipe@cathedrallabs.org>
levee (3.4o-7) unstable; urgency=low
* New maintainer. (Closes: #352612).
* Acknowledge NMUs.
- Thanks Moshe (Closes: #144943, #144947, #144956, #144957).
* Bump Standards Version to 3.7.2, with no changes.
* DH_COMPAT=4
* Fixing lev.1 lintian complain
- Lines starting with ' must be escaped with \, 'cc' became \'cc'
2003-07-08 - Tim Vandermeersch <tim.vandermeersch@pandora.be>
levee (3.4o-6) unstable; urgency=low
* New maintainer.  (closes: #192651)
* Fixed lintian error: package-lacks-versioned-build-depends-on-debhelper 2
(update to DH_COMPAT=3)
* Fixed 2 lintian warnings
* Applied Antraxz' patch to fix warning at compilation (closes: #193425)
* Fixed file-conflict (closes: #175912)

See Also

Package Description
leveldb-doc_1.17-1_all.deb LevelDB documentation
lfc-dli_1.8.7-3.1+b1_amd64.deb LCG File Catalog (LFC) data location interface (dli) server
lfc-server-mysql_1.8.7-3.1+b1_amd64.deb LCG File Catalog (LFC) server with MySQL database backend
lfc-server-postgres_1.8.7-3.1+b1_amd64.deb LCG File Catalog (LFC) server with postgres database backend
lfc_1.8.7-3.1+b1_amd64.deb LCG File Catalog (LFC) client
lfhex_0.42-3.1_amd64.deb large file hex editor
lfm_2.3-1_all.deb simple but powerful file manager for the UNIX console
lft_2.2-4_amd64.deb layer-four traceroute
lftp_4.6.0-1+deb8u1_amd64.deb Sophisticated command-line FTP/HTTP/BitTorrent client programs
lgc-pg_1.2.3+dfsg-3_amd64.deb LGeneral converter for Panzer General game data
lgeneral-data_1.0-1_all.deb strategy game in the tradition of Panzer General -- data
lgeneral_1.2.3+dfsg-3_amd64.deb strategy game in the tradition of Panzer General
lgogdownloader_2.19-1_amd64.deb downloader for GOG.com files
lhapdf-ccwrap-doc_5.9.1-3_all.deb C++ Bindings for LHAPDF - documentation
lhapdf-pdfsets-minimal_5.9.1-3_all.deb Minimal PDF Sets of LHAPDF
Advertisement
Advertisement