leafnode_1.11.10-2_amd64.deb


Advertisement

Description

leafnode - NNTP server for small sites

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name leafnode
Package version 1.11.10
Package release 2
Package architecture amd64
Package type deb
Installed size 846 B
Download size 232.63 KB
Official Mirror ftp.br.debian.org
Leafnode is a news server suitable for small, limited-bandwidth sites
with only a few users ('leaf' sites). It keeps track of which groups
are being read, and downloads only articles in those groups. Leafnode
has been designed to require no maintenance and to be easy to set up.
Perl is required to use some optional features of the package for
handling very low volume newsgroups.

Alternatives

Package Version Architecture Repository
leafnode_1.11.10-2_i386.deb 1.11.10 i386 Debian Main
leafnode - - -

Requires

Name Value
debconf >= 0.5
debconf-2.0 -
inet-superserver -
libc6 >= 2.14
libpcre3 >= 1:8.35
logrotate -
netbase -
openbsd-inetd -
tcpd -

Provides

Name Value
news-transport-system -

Conflicts

Name Value
news-transport-system -
newsx -

Download

Type URL
Binary Package leafnode_1.11.10-2_amd64.deb
Source Package leafnode

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install leafnode deb package:
    # sudo apt-get install leafnode

Files

Path
/etc/cron.d/leafnode
/etc/cron.daily/leafnode
/etc/logcheck/ignore.d.paranoid/leafnode
/etc/logcheck/ignore.d.server/leafnode
/etc/logcheck/ignore.d.workstation/leafnode
/etc/logcheck/violations.ignore.d/leafnode
/etc/logrotate.d/leafnode
/etc/news/leafnode/do-fetch-news
/etc/news/leafnode/filters
/etc/ppp/ip-down.d/leafnode
/etc/ppp/ip-up.d/leafnode
/usr/bin/leafnode-version
/usr/bin/newsq
/usr/bin/touch_newsgroup
/usr/sbin/applyfilter
/usr/sbin/checkgroups
/usr/sbin/fetchnews
/usr/sbin/leafnode
/usr/sbin/texpire
/usr/share/doc/leafnode/CREDITS.gz
/usr/share/doc/leafnode/FAQ.txt.gz
/usr/share/doc/leafnode/KNOWNBUGS.gz
/usr/share/doc/leafnode/NEWS.Debian.gz
/usr/share/doc/leafnode/NEWS.gz
/usr/share/doc/leafnode/README-FQDN.gz
/usr/share/doc/leafnode/README.Debian
/usr/share/doc/leafnode/README.gz
/usr/share/doc/leafnode/changelog.Debian.gz
/usr/share/doc/leafnode/changelog.gz
/usr/share/doc/leafnode/copyright
/usr/share/doc/leafnode/touch_newsgroup.README
/usr/share/doc/leafnode/examples/archivefaq.pl
/usr/share/doc/leafnode/examples/config.example
/usr/share/doc/leafnode/examples/filters.example
/usr/share/leafnode/config.example
/usr/share/leafnode/debian-config
/usr/share/man/man1/leafnode-version.1.gz
/usr/share/man/man1/newsq.1.gz
/usr/share/man/man1/touch_newsgroup.1.gz
/usr/share/man/man8/applyfilter.8.gz
/usr/share/man/man8/checkgroups.8.gz
/usr/share/man/man8/fetchnews.8.gz
/usr/share/man/man8/leafnode.8.gz
/usr/share/man/man8/texpire.8.gz

Changelog

2015-03-20 - Moritz Muehlenhoff <jmm@debian.org>
leafnode (1.11.10-2) unstable; urgency=medium
* base-passwd 3.5.30 changed the shell of the "news" system user to
nologin. Fix the daily cron job to use a shell, otherwise old
articles are no longer expired. Thanks to Jan Braun for the
report! (Closes: #759869)
2014-06-25 - Moritz Muehlenhoff <jmm@debian.org>
leafnode (1.11.10-1) unstable; urgency=medium
* New upstream release, patches getaddrinfo and whoami
have been merged upstream 
* Add myself as co-maintainer to help out a bit
* Add Japanese debconf translatation, thanks "victory" (Closes: #718919)
* Bump standards version
* Don't install upstream installation instructions, spotted by Lintian
2012-04-16 - Robert Grimm <rob@robgri.de>
leafnode (1.11.8-3) unstable; urgency=low
* Avoid segfault in whoami() (closes: #667998).
* Enable all hardened build flags.
2012-04-06 - Robert Grimm <rob@robgri.de>
leafnode (1.11.8-2) unstable; urgency=low
[ Christian Perrier ]
* Fix pending l10n issues. Debconf translations:
* Italian (Dario Santamaria).  Closes: #615879
* Polish (Michał Kułach).  Closes: #665306
[ Robert Grimm ]
* Enabled hardened build flags.
* postinst cleanup.
* Standards version 3.9.3 (no changes).
* Added two patches from upstream git.
- Add IPv6 support to whoami().
- Use AF_UNSPEC for getaddrinfo.
2010-06-13 - Robert Grimm <rob@robgri.de>
leafnode (1.11.8-1) unstable; urgency=low
* New upstream release.
- Fix file descriptor leak in getbody_newno() (closes: #568128).
* Added Danish Debconf translation, kindly provided by
Joe Hansen <joedalton2@yahoo.dk> (closes: #581055).
* Depend on netbase.  
* Standards version 3.8.4 (no changes).
* Switch to dpkg source 3.0 (quilt) format.
2009-12-17 - Robert Grimm <rob@robgri.de>
leafnode (1.11.7.rel-2) unstable; urgency=low
* Standards version 3.8.3 (no changes).
* Mentioned in README.Debian that the need to use touch_newsgroups is
considered a bug.
* Removed tabstop in the last line of filters (closes: #424949).
* New Maintainer (closes: #536023).
2009-04-21 - Mark Brown <broonie@debian.org>
leafnode (1.11.7.rel-1) unstable; urgency=low
* New upstream release.
2009-04-14 - Mark Brown <broonie@debian.org>
leafnode (1.11.7.rc4-1) unstable; urgency=low
* New upstream release.
2009-03-24 - Mark Brown <broonie@debian.org>
leafnode (1.11.7.rc3-1) unstable; urgency=low
* New upstream release.
2009-02-21 - Mark Brown <broonie@debian.org>
leafnode (1.11.7.rc2-1) unstable; urgency=low
* New upstream release.
* Standards version 3.8.0 (no changes).

See Also

Package Description
leafpad_0.8.18.1-4_amd64.deb GTK+ based simple text editor
leaktracer_2.4-5_amd64.deb Simple and efficient memory-leak tracer for C++ programs
leave_1.12-2.1_amd64.deb Reminds you when you have to leave
lebiniou-data_3.11-1_all.deb datafiles for Le Biniou
lebiniou_3.22-1+b1_amd64.deb displays images that evolve with sound
ledger-el_3.1+dfsg1-2_all.deb command-line double-entry accounting program (emacs interface)
ledger_3.1+dfsg1-2_amd64.deb command-line double-entry accounting program
ledgersmb_1.3.40-1_all.deb financial accounting and ERP program
ledit_2.03-2_all.deb line editor for interactive programs
ledmon_0.79-2_amd64.deb Enclosure LED Utilities
leds-alix-source_0.0.1-1.1_all.deb Source for the LEDs driver of PCEngines ALIX 2/3 boards
legit_0.1.1-4_all.deb Git extension to assist in manipulating branches
lekhonee-gnome_0.11-3_amd64.deb desktop client for wordpress blogs
leksah-server_0.12.1.2-3+b5_amd64.deb haskell editor - GHC interface
leksah_0.12.1.3-6_amd64.deb haskell editor - GHC interface
Advertisement
Advertisement