ldc_0.14.0.dfsg-1_amd64.deb


Advertisement

Description

ldc - LLVM D Compiler

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name ldc
Package version 0.14.0.dfsg
Package release 1
Package architecture amd64
Package type deb
Installed size 27.02 KB
Download size 7.50 MB
Official Mirror ftp.br.debian.org
LDC is a compiler for the D programming Language. It is based on the
latest DMD frontend and uses LLVM as backend.
LDC already compiles a lot of D code, but should still be considered
beta quality. Take a look at the tickets to get a better impression
on what still needs to be implemented.
This is the actual ldc compiler

Alternatives

Package Version Architecture Repository
ldc_0.14.0.dfsg-1_i386.deb 0.14.0.dfsg i386 Debian Main
ldc - - -

Requires

Name Value
libc6 >= 2.15
libconfig++9 -
libedit2 >= 2.11-20080614
libffi6 >= 3.0.4
libgcc1 >= 1:4.1.1
libstdc++6 >= 4.9
libtinfo5 -
zlib1g >= 1:1.2.0

Provides

Name Value
d-compiler -
d-v2-compiler -

Download

Type URL
Binary Package ldc_0.14.0.dfsg-1_amd64.deb
Source Package ldc

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ldc deb package:
    # sudo apt-get install ldc

Files

Path
/etc/ldc2.conf
/etc/bash_completion.d/ldc
/usr/bin/ldc2
/usr/bin/ldmd2
/usr/share/doc/ldc/README.md
/usr/share/doc/ldc/changelog.Debian.gz
/usr/share/doc/ldc/copyright
/usr/share/man/man1/ldc2.1.gz
/usr/share/man/man1/ldmd2.1.gz

Changelog

2014-08-26 - Konstantinos Margaritis <markos@debian.org>
ldc (1:0.14.0.dfsg-1) unstable; urgency=medium
* Remove vcbuild/ files, not useful for a Linux build anyway and non-free.
Rename version as 0.14.0.dfsg-1. (Closes: #759371)
2014-08-25 - Konstantinos Margaritis <markos@debian.org>
ldc (1:0.14.0-1) unstable; urgency=medium
* Just list the supported architectures for now, will add the rest once
support is properly added, working with upstream to add both kfreebsd and
powerpc, s390x will follow.
* Separate phobos2 standard library into separate packages, both static and
shared libs will be provided.
* Packaging now kept in git@alioth (Vcs-Git fields updated accordingly,
Closes: #753967)
2014-06-24 - Konstantinos Margaritis <markos@debian.org>
ldc (1:0.13.0-1) unstable; urgency=medium
* New upstream release, that matches dmd 2.064
* Set /usr/include/dlang/ as install path, to match upstream decision
2014-03-08 - Konstantinos Margaritis <markos@debian.org>
ldc (0.13.0alpha2-1) unstable; urgency=medium
* New upstream release
* Actually change maintainer field in control file
* Add /usr/include/d/common in the include path, all D external packages will
be placed there.
* Also include shared library libldc.so
2014-02-14 - Konstantinos Margaritis <markos@debian.org>
ldc (0.13.0alpha1-1) unstable; urgency=medium
* New upstream release. Closes: #726910.
* New maintainer Closes: #730798.
* Fixes lots of FTBFS bugs.
Closes: #625037, #627566, #707372, #654605, #730782.
2010-02-27 - Arthur Loiret <aloiret@debian.org>
ldc (0.9.1+hg1634-1) unstable; urgency=low
* New upstream snapshot:
- Merge DMD 1.056.
* debian/patches/06_sh4.diff: Fix build on sh4.  Closes: #560437.
Thanks to Nobuhiro Iwamatsu.
* debian/patches/03_ldc-conf.diff: Add /usr/include/d/ldc to include paths.
* debian/control:
- Recommends libtango-ldc-dev.  Closes: #561731.
- Bump Standards-Version to 3.8.4.
2009-12-07 - Arthur Loiret <aloiret@debian.org>
ldc (0.9.1+hg1596-3) unstable; urgency=low
* 04_kfreebsd.diff: Add missing hunk to treat kfreebsd-gnu as freebsd.
* 05_alpha.diff: Port on alpha.
2009-12-05 - Arthur Loiret <aloiret@debian.org>
ldc (0.9.1+hg1596-2) unstable; urgency=low
* Link with -Wl,--no-relax on alpha.
* 04_kfreebsd.diff: Port on kfreebsd-gnu.  Closes: #559350.
Thanks to Cyril Brulebois <kibi@debian.org> for the patch.
* debian/ldc.1, debian/ldmd.1: Add manpages.
* Build in VERBOSE mode.
2009-12-03 - Arthur Loiret <aloiret@debian.org>
ldc (0.9.1+hg1596-1) unstable; urgency=low
* Upload to unstable.  Closes: #508070.
2009-12-02 - Arthur Loiret <aloiret@debian.org>
ldc (0.9.1+hg1596-1~exp1) experimental; urgency=low
* New upstream snapshot.
- Merge DMD 1.051.

See Also

Package Description
ldirectord_3.9.3+git20121009-3.1_all.deb Monitors virtual services provided by LVS
ldm-server_2.2.15-2_all.deb server components for LTSP display manager
ldm-themes_15.01.2_all.deb Collection of themes for the LTSP login manager
ldm_2.2.15-2_amd64.deb LTSP display manager
ldmtool_0.2.3-3_amd64.deb tool for managing Microsoft Windows dynamic disks
ldnsutils_1.6.17-5+b1_amd64.deb ldns library for DNS programming
ldp-docbook-dsssl_0.0.20040321-2_all.deb The Linux Documentation Project's DSSSL stylesheets
ldp-docbook-xsl_0.0.20040321-2_all.deb The Linux Documentation Project's XSL stylesheets
ldtp-doc_2.3.1-1_all.deb Documentation for LDTP packages
ldtp_2.3.1-1_all.deb Linux Desktop Testing Project (LDTP)
le-dico-de-rene-cougnenc_1.3-2.1_amd64.deb the "Dico" by Rene Cougnenc
le_1.14.9-2_amd64.deb Text editor with block and binary operations
leafnode_1.11.10-2_amd64.deb NNTP server for small sites
leafpad_0.8.18.1-4_amd64.deb GTK+ based simple text editor
leaktracer_2.4-5_amd64.deb Simple and efficient memory-leak tracer for C++ programs
Advertisement
Advertisement