lcalc_1.23+dfsg-3_amd64.deb


Advertisement

Description

lcalc - program for calculating with L-functions

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name lcalc
Package version 1.23+dfsg
Package release 3
Package architecture amd64
Package type deb
Installed size 444 B
Download size 135.01 KB
Official Mirror ftp.br.debian.org
lcalc is a program for computing zeros and values of L-functions.
Supported L-functions include the Riemann zeta function, the
L-function of the Ramanujan delta function, and L-functions
of elliptic curves defined over the rationals.

Alternatives

Package Version Architecture Repository
lcalc_1.23+dfsg-3_i386.deb 1.23+dfsg i386 Debian Main
lcalc - - -

Requires

Name Value
libc6 >= 2.15
libgcc1 >= 1:4.1.1
libpari-gmp-tls4 >= 2.5.0-1
libstdc++6 >= 4.4.0

Download

Type URL
Binary Package lcalc_1.23+dfsg-3_amd64.deb
Source Package lcalc

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lcalc deb package:
    # sudo apt-get install lcalc

Files

Path
/usr/bin/lcalc
/usr/share/doc/lcalc/README.gz
/usr/share/doc/lcalc/changelog.Debian.gz
/usr/share/doc/lcalc/copyright
/usr/share/man/man1/lcalc.1.gz

Changelog

2014-05-18 - Tobias Hansen <thansen@debian.org>
lcalc (1.23+dfsg-3) UNRELEASED; urgency=medium
* Fix FTBFS with gcc-4.9. (Closes: #746867)
* With pari_2.7.patch the package build-depends now on pari >= 2.7
instead of >= 2.5. (Closes: #746048)
2014-04-08 - Tobias Hansen <thansen@debian.org>
lcalc (1.23+dfsg-2) unstable; urgency=medium
* Add patch fix_pari_include.patch:
Fix pari includes to work with Pari 2.7 in Debian. (Closes: #743327)
* Move pari_2.5.patch to pari_2.7.patch
and add add further change (call ellinit with 3 parameters)
(Closes: #743327)
* Bump standards-version to 3.9.5.
2013-07-19 - Tobias Hansen <thansen@debian.org>
lcalc (1.23+dfsg-1) unstable; urgency=low
* Repack tarball to remove binary file.
2013-06-30 - Tobias Hansen <thansen@debian.org>
lcalc (1.23-2) unstable; urgency=low
* Ship the shared library liblfunction (Closes: #702901).
* Move from experimental to unstable.
2013-01-12 - Tobias Hansen <thansen@debian.org>
lcalc (1.23-1) experimental; urgency=low
* New upstream release (Closes: #592426).
* New maintainer Debian Science Team, uploader me,
with permission from Tim Abbott.
* Transition to dh (compat level 9).
* Enable hardening flags via dpkg-buildflags.
* Standards-Version 3.9.4
* Remove unnecessary mpfr and gmp dependencies.
(Like in Sage, the package is currently built without mpfr.
It fails to build when mpfr is enabled.)
* Install the README file.
* Use copyright format 1.0.
* Create watch file.
* debian/patches/gcc.patch:
debian/patches/pari_2.5.patch:
- Refresh and add headers.
* debian/patches/lcalc-const-fixes.patch:
- Remove: Was mostly applied upstream and the remaining 3 const
fixes caused FTBFS.
* debian/patches/Makefile.patch:
- Add: Mostly a patch from Sage to use $CC, $CXX, $CXXFLAGS
and $CPPFLAGS properly.
2011-12-10 - Luca Falavigna <dktrkranz@debian.org>
lcalc (0.0.20080205-1.2) unstable; urgency=low
* Non-maintainer upload.
* debian/control:
- Build-depend on versioned libpari-dev (>= 2.5) (Closes: #644092).
2011-08-14 - Luca Falavigna <dktrkranz@debian.org>
lcalc (0.0.20080205-1.1) unstable; urgency=medium
* Non-maintainer upload.
* debian/patches/gcc.patch:
- Fix FTBFS with newer gcc (Closes: #624986).
* debian/patches/pari_2.5.patch:
- Port to pari 2.5 API (Closes: #635506).
2008-05-30 - Tim Abbott <tabbott@mit.edu>
lcalc (0.0.20080205-1) unstable; urgency=low
* Initial release (Closes: #480088).

See Also

Package Description
lcas-interface_1.3.19-2_all.deb Local Centre Authorization Service API
lcas-lcmaps-gt4-interface_0.3.0-2_amd64.deb Mapping interface between Globus Toolkit and LCAS/LCMAPS
lcd4linux_0.11.0~svn1200-3_amd64.deb Grabs information and displays it on an external lcd
lcdf-typetools_2.104~dfsg-1_amd64.deb tools for OpenType, multiple-master, and Type 1 fonts
lcdproc-extra-drivers_0.5.7-2_amd64.deb extra drivers for the LCD display driver daemon
lcdproc_0.5.7-2_amd64.deb LCD display driver daemon and clients
lcl-1.2.4_1.2.4+dfsg2-1_amd64.deb Lazarus Components Library - LCL suite
lcl-gtk2-1.2.4_1.2.4+dfsg2-1_amd64.deb Lazarus Components Library - GTK+ backend
lcl-gtk2_1.2.4+dfsg2-1_all.deb Lazarus Components Library - GTK+ backend dependency package
lcl-nogui-1.2.4_1.2.4+dfsg2-1_amd64.deb Lazarus Components Library - no GUI backend
lcl-nogui_1.2.4+dfsg2-1_all.deb Lazarus Components Library - no GUI backend dependency package
lcl-qt4-1.2.4_1.2.4+dfsg2-1_amd64.deb Lazarus Components Library - Qt backend
lcl-qt4_1.2.4+dfsg2-1_all.deb Lazarus Components Library - Qt backend dependency package
lcl-units-1.2.4_1.2.4+dfsg2-1_amd64.deb Lazarus Components Library - backend independent components
lcl-units_1.2.4+dfsg2-1_all.deb Lazarus Components Library - backend independent components dependency package
Advertisement
Advertisement