lava-tool_0.11.2-2_all.deb


Advertisement

Description

lava-tool - command line utility for LAVA

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name lava-tool
Package version 0.11.2
Package release 2
Package architecture all
Package type deb
Installed size 409 B
Download size 49.52 KB
Official Mirror ftp.br.debian.org
This package provides a user space connection to a
LAVA (Linaro Automated Validation Architecture)
instance for submitting test jobs or querying the instance
for device and job status over XMLRPC.

Alternatives

Package Version Architecture Repository
lava-tool_0.11.2-2_all.deb 0.11.2 all Debian Main
lava-tool - - -

Requires

Name Value
libpython2.7-stdlib -
python << 2.8
python >= 2.7
python-argcomplete >= 0.3
python-json-schema-validator >= 2.0
python-keyring -
python-setuptools -
python-xdg >= 0.19
python-yaml >= 3.10

Replaces

Name Value
lava-dashboard-tool << 0.8
lava-scheduler-tool << 0.6

Download

Type URL
Binary Package lava-tool_0.11.2-2_all.deb
Source Package lava-tool

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lava-tool deb package:
    # sudo apt-get install lava-tool

Files

Path
/usr/bin/lava
/usr/bin/lava-dashboard-tool
/usr/bin/lava-tool
/usr/lib/python2.7/dist-packages/lava_tool-0.11.2-nspkg.pth
/usr/lib/python2.7/dist-packages/lava/commands.py
/usr/lib/python2.7/dist-packages/lava/config.py
/usr/lib/python2.7/dist-packages/lava/parameter.py
/usr/lib/python2.7/dist-packages/lava/device/__init__.py
/usr/lib/python2.7/dist-packages/lava/device/commands.py
/usr/lib/python2.7/dist-packages/lava/device/templates.py
/usr/lib/python2.7/dist-packages/lava/device/tests/__init__.py
/usr/lib/python2.7/dist-packages/lava/device/tests/test_commands.py
/usr/lib/python2.7/dist-packages/lava/device/tests/test_device.py
/usr/lib/python2.7/dist-packages/lava/helper/__init__.py
/usr/lib/python2.7/dist-packages/lava/helper/command.py
/usr/lib/python2.7/dist-packages/lava/helper/dispatcher.py
/usr/lib/python2.7/dist-packages/lava/helper/template.py
/usr/lib/python2.7/dist-packages/lava/helper/tests/__init__.py
/usr/lib/python2.7/dist-packages/lava/helper/tests/helper_test.py
/usr/lib/python2.7/dist-packages/lava/helper/tests/test_command.py
/usr/lib/python2.7/dist-packages/lava/helper/tests/test_dispatcher.py
/usr/lib/python2.7/dist-packages/lava/helper/tests/test_template.py
/usr/lib/python2.7/dist-packages/lava/job/__init__.py
/usr/lib/python2.7/dist-packages/lava/job/commands.py
/usr/lib/python2.7/dist-packages/lava/job/templates.py
/usr/lib/python2.7/dist-packages/lava/job/tests/__init__.py
/usr/lib/python2.7/dist-packages/lava/job/tests/test_commands.py
/usr/lib/python2.7/dist-packages/lava/job/tests/test_job.py
/usr/lib/python2.7/dist-packages/lava/script/__init__.py
/usr/lib/python2.7/dist-packages/lava/script/commands.py
/usr/lib/python2.7/dist-packages/lava/script/tests/__init__.py
/usr/lib/python2.7/dist-packages/lava/script/tests/test_commands.py
/usr/lib/python2.7/dist-packages/lava/script/tests/test_script.py
/usr/lib/python2.7/dist-packages/lava/testdef/__init__.py
/usr/lib/python2.7/dist-packages/lava/testdef/commands.py
/usr/lib/python2.7/dist-packages/lava/testdef/templates.py
/usr/lib/python2.7/dist-packages/lava/testdef/tests/__init__.py
/usr/lib/python2.7/dist-packages/lava/testdef/tests/test_commands.py
/usr/lib/python2.7/dist-packages/lava/tests/__init__.py
/usr/lib/python2.7/dist-packages/lava/tests/test_commands.py
/usr/lib/python2.7/dist-packages/lava/tests/test_config.py
/usr/lib/python2.7/dist-packages/lava/tests/test_parameter.py
/usr/lib/python2.7/dist-packages/lava/tool/__init__.py
/usr/lib/python2.7/dist-packages/lava/tool/command.py
/usr/lib/python2.7/dist-packages/lava/tool/dispatcher.py
/usr/lib/python2.7/dist-packages/lava/tool/errors.py
/usr/lib/python2.7/dist-packages/lava/tool/main.py
/usr/lib/python2.7/dist-packages/lava/tool/commands/__init__.py
/usr/lib/python2.7/dist-packages/lava/tool/commands/help.py
/usr/lib/python2.7/dist-packages/lava_dashboard_tool/__init__.py
/usr/lib/python2.7/dist-packages/lava_dashboard_tool/commands.py
/usr/lib/python2.7/dist-packages/lava_dashboard_tool/main.py
/usr/lib/python2.7/dist-packages/lava_dashboard_tool/tests/__init__.py
/usr/lib/python2.7/dist-packages/lava_dashboard_tool/tests/test_commands.py
/usr/lib/python2.7/dist-packages/lava_scheduler_tool/__init__.py
/usr/lib/python2.7/dist-packages/lava_scheduler_tool/commands.py
/usr/lib/python2.7/dist-packages/lava_tool/__init__.py
/usr/lib/python2.7/dist-packages/lava_tool/authtoken.py
/usr/lib/python2.7/dist-packages/lava_tool/dispatcher.py
/usr/lib/python2.7/dist-packages/lava_tool/interface.py
/usr/lib/python2.7/dist-packages/lava_tool/utils.py
/usr/lib/python2.7/dist-packages/lava_tool-0.11.2.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/lava_tool-0.11.2.egg-info/SOURCES.txt
/usr/lib/python2.7/dist-packages/lava_tool-0.11.2.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/lava_tool-0.11.2.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/lava_tool-0.11.2.egg-info/namespace_packages.txt
/usr/lib/python2.7/dist-packages/lava_tool-0.11.2.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/lava_tool-0.11.2.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/lava_tool-0.11.2.egg-info/zip-safe
/usr/lib/python2.7/dist-packages/lava_tool/commands/__init__.py
/usr/lib/python2.7/dist-packages/lava_tool/commands/auth.py
/usr/lib/python2.7/dist-packages/lava_tool/tests/__init__.py
/usr/lib/python2.7/dist-packages/lava_tool/tests/test_auth_commands.py
/usr/lib/python2.7/dist-packages/lava_tool/tests/test_authtoken.py
/usr/lib/python2.7/dist-packages/lava_tool/tests/test_commands.py
/usr/lib/python2.7/dist-packages/lava_tool/tests/test_utils.py
/usr/share/doc/lava-tool/README
/usr/share/doc/lava-tool/changelog.Debian.gz
/usr/share/doc/lava-tool/copyright
/usr/share/man/man1/lava-tool.1.gz
/usr/share/python/ns/lava-tool

Changelog

2014-06-27 - Neil Williams <codehelp@debian.org>
lava-tool (0.11.2-2) unstable; urgency=medium
* Enable the autopkgtests in debian/control.
2014-06-10 - Neil Williams <codehelp@debian.org>
lava-tool (0.11.2-1) unstable; urgency=medium
* New upstream release - completes the removal of
versiontools. (Closes: #749871)
* Add autopkgtests support.
2014-05-12 - Neil Williams <codehelp@debian.org>
lava-tool (0.11.1-1) unstable; urgency=medium
* New upstream release
* Drop versiontools dependency.
2014-05-09 - Neil Williams <codehelp@debian.org>
lava-tool (0.11-1) unstable; urgency=medium
* New upstream release
2014-05-07 - Neil Williams <codehelp@debian.org>
lava-tool (0.10-1) unstable; urgency=medium
* Initial release. (Closes: #747350: ITP: lava-tool -- command line
utility for LAVA)
2013-12-08 - Neil Williams <codehelp@debian.org>
lava-tool (0.8.2-1) unstable; urgency=medium
* New upstream release
2013-11-19 - Neil Williams <codehelp@debian.org>
lava-tool (0.8.1-1) unstable; urgency=low
* New upstream release
2013-10-08 - Neil Williams <codehelp@debian.org>
lava-tool (0.7.2-1) unstable; urgency=low
* Update for working support of a native Debian LAVA install.
2013-06-05 - Neil Williams <codehelp@debian.org>
lava-tool (0.7.1-1) unstable; urgency=low
* Initial release

See Also

Package Description
lava_2014.09.1-1_all.deb Linaro Automated Validation Architecture metapackage
lavapdu-client_0.0.3-2_all.deb LAVA PDU client
lavapdu-daemon_0.0.3-2_all.deb LAVA PDU control daemon
lazarus-1.2.4_1.2.4+dfsg2-1_all.deb IDE for Free Pascal - suite
lazarus-doc-1.2.4_1.2.4+dfsg2-1_all.deb IDE for Free Pascal - documentation
lazarus-doc_1.2.4+dfsg2-1_all.deb IDE for Free Pascal - documentation dependency package
lazarus-ide-1.2.4_1.2.4+dfsg2-1_amd64.deb IDE for Free Pascal - common IDE files
lazarus-ide-gtk2-1.2.4_1.2.4+dfsg2-1_amd64.deb IDE for Free Pascal - GTK+ version
lazarus-ide-gtk2_1.2.4+dfsg2-1_all.deb IDE for Free Pascal - Last GTK+ version dependency package
lazarus-ide-qt4-1.2.4_1.2.4+dfsg2-1_amd64.deb IDE for Free Pascal - Qt version
lazarus-ide-qt4_1.2.4+dfsg2-1_all.deb IDE for Free Pascal - Last Qt version dependency package
lazarus-ide_1.2.4+dfsg2-1_all.deb IDE for Free Pascal - common IDE files dependency package
lazarus-src-1.2.4_1.2.4+dfsg2-1_all.deb IDE for Free Pascal - LCL source code
lazarus-src_1.2.4+dfsg2-1_all.deb IDE for Free Pascal - LCL source code dependency package
lazarus_1.2.4+dfsg2-1_all.deb IDE for Free Pascal - SDK dependency package
Advertisement
Advertisement