ktorrent_4.3.1-2+b1_amd64.deb


Advertisement

Description

ktorrent - BitTorrent client based on the KDE platform

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name ktorrent
Package version 4.3.1
Package release 2+b1
Package architecture amd64
Package type deb
Installed size 3.95 KB
Download size 994.18 KB
Official Mirror ftp.br.debian.org
This package contains KTorrent, a BitTorrent peer-to-peer network client, that
is based on the KDE platform. Obviously, KTorrent supports such basic features
as downloading, uploading and seeding files on the BitTorrent network.
However, lots of other additional features and intuitive GUI should make
KTorrent a good choice for everyone. Some features are available as plugins
hence you should make sure you have the ones you need enabled.
- Support for HTTP and UDP trackers, trackerless DHT (mainline) and webseeds.
- Alternative UI support including Web interface and Plasma widget.
- Torrent grouping, speed capping, various download prioritization
capabilities on both torrent and file level as well as bandwidth
scheduling.
- Support for fetching torrent files from many sources including any local
file or remote URL, RSS feeds (with filtering) or actively monitored
directory etc.
- Integrated and customizable torrent search on the Web.
- Various security features like IP blocking and protocol encryption.
- Disk space preallocation to reduce fragmentation.
- uTorrent compatible peer exchange.
- Autoconfiguration for LANs like Zeroconf extension and port forwarding via
uPnP.
- Scripting support via Kross and interprocess control via DBus interface.
- SOCKSv4 and SOCKSv5 proxy, IPv6 support.
- Lots of other useful built-in features and plugins.

Alternatives

Package Version Architecture Repository
ktorrent_4.3.1-2+b1_i386.deb 4.3.1 i386 Debian Main
ktorrent - - -

Requires

Name Value
kde-runtime >> 4:4.10
ktorrent-data = 4.3.1-2
libc6 >= 2.14
libgcc1 >= 1:4.1.1
libgeoip1 -
libkcmutils4 >= 4:4.7
libkdecore5 >= 4:4.7
libkdeui5 >= 4:4.7
libkdewebkit5 >= 4:4.7
libkdnssd4 >= 4:4.7
libkio5 >= 4:4.7
libknotifyconfig4 >= 4:4.7
libkparts4 >= 4:4.7
libkrosscore4 >= 4:4.7
libktorrent-l10n -
libktorrent5 >= 1.3.1
libkworkspace4abi2 >= 4:4.9.3
libnepomuk4 >= 4:4.7
libnepomukutils4 >= 4:4.5.85
libphonon4 >= 4:4.3.0
libqt4-dbus >= 4:4.7
libqt4-network >= 4:4.7
libqt4-qt3support >= 4:4.7
libqt4-script >= 4:4.7
libqt4-sql >= 4:4.7
libqt4-svg >= 4:4.7
libqt4-xml >= 4:4.7
libqtcore4 >= 4:4.8.0
libqtgui4 >= 4:4.8.0
libqtwebkit4 >= 2.1.0~2011week13
libsolid4 >= 4:4.7
libsoprano4 >= 2.1.1
libstdc++6 >= 4.9
libsyndication4 >= 4:4.7
libtag1c2a >= 1.5
phonon -

Download

Type URL
Binary Package ktorrent_4.3.1-2+b1_amd64.deb
Source Package ktorrent

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ktorrent deb package:
    # sudo apt-get install ktorrent

Files

Path
/usr/bin/ktmagnetdownloader
/usr/bin/ktorrent
/usr/bin/ktupnptest
/usr/lib/libktcore.so.15
/usr/lib/libktcore.so.15.0.0
/usr/lib/kde4/ktbwschedulerplugin.so
/usr/lib/kde4/ktdownloadorderplugin.so
/usr/lib/kde4/ktinfowidgetplugin.so
/usr/lib/kde4/ktipfilterplugin.so
/usr/lib/kde4/ktlogviewerplugin.so
/usr/lib/kde4/ktmagnetgeneratorplugin.so
/usr/lib/kde4/ktmediaplayerplugin.so
/usr/lib/kde4/ktscanfolderplugin.so
/usr/lib/kde4/ktscriptingplugin.so
/usr/lib/kde4/ktsearchplugin.so
/usr/lib/kde4/ktshutdownplugin.so
/usr/lib/kde4/ktstatsplugin.so
/usr/lib/kde4/ktsyndicationplugin.so
/usr/lib/kde4/ktupnpplugin.so
/usr/lib/kde4/ktwebinterfaceplugin.so
/usr/lib/kde4/ktzeroconfplugin.so
/usr/share/applications/kde4/ktorrent.desktop
/usr/share/doc/ktorrent/NEWS.Debian.gz
/usr/share/doc/ktorrent/README.Debian
/usr/share/doc/ktorrent/changelog.Debian.amd64.gz
/usr/share/doc/ktorrent/changelog.Debian.gz
/usr/share/doc/ktorrent/changelog.gz
/usr/share/doc/ktorrent/copyright
/usr/share/kde4/services/ktbwschedulerplugin.desktop
/usr/share/kde4/services/ktdownloadorderplugin.desktop
/usr/share/kde4/services/ktinfowidgetplugin.desktop
/usr/share/kde4/services/ktipfilterplugin.desktop
/usr/share/kde4/services/ktlogviewerplugin.desktop
/usr/share/kde4/services/ktmagnetgeneratorplugin.desktop
/usr/share/kde4/services/ktmediaplayerplugin.desktop
/usr/share/kde4/services/ktscanfolderplugin.desktop
/usr/share/kde4/services/ktscriptingplugin.desktop
/usr/share/kde4/services/ktsearchplugin.desktop
/usr/share/kde4/services/ktshutdownplugin.desktop
/usr/share/kde4/services/ktstatsplugin.desktop
/usr/share/kde4/services/ktsyndicationplugin.desktop
/usr/share/kde4/services/ktupnpplugin.desktop
/usr/share/kde4/services/ktwebinterfaceplugin.desktop
/usr/share/kde4/services/ktzeroconfplugin.desktop
/usr/share/kde4/servicetypes/ktorrentplugin.desktop
/usr/share/lintian/overrides/ktorrent
/usr/share/man/man1/ktorrent.1.gz
/usr/share/man/man1/ktupnptest.1.gz
/usr/share/menu/ktorrent

Changelog

2013-11-05 - Modestas Vainius <modax@debian.org>
ktorrent (4.3.1-2) unstable; urgency=low
* Do not build tests like before KDE 4.10. Fixes FTBFS (Closes: #722628)
* Do not link with deprecated kutils library. (Closes: #717010)
Patch: dont_link_with_kutils.patch
* Build with hardening flags. (Closes: #663524)
* Bump Standards-Version to 3.9.5: no further changes needed.
* Update Vcs URLs to canonical ones.
* Upload to unstable. (Closes: #721049)
* Disable KIO Magnet. It is considered obsolete (and might be buggy).
* Require nepomuk-core-dev for KDE 4.9 or above (requirement of
kdepimlibs).
2013-01-27 - Modestas Vainius <modax@debian.org>
ktorrent (4.3.1-1) experimental; urgency=low
* New upstream release.
* Bump dependency on libktorrent to 1.3.1.
2012-09-30 - Modestas Vainius <modax@debian.org>
ktorrent (4.3.0-1) experimental; urgency=low
* New upstream release.
* Require libktorrent 1.3.0 for building.
* Require Qt 4.7 and KDE Platform 4.7 for building.
* Bump Standards-Version to 3.9.4: no changes needed.
2012-06-21 - Modestas Vainius <modax@debian.org>
ktorrent (4.2.1-1) unstable; urgency=low
* New upstream release.
* Require libktorrent 1.2.1 for building.
* Drop unused override menu-icon-missing.
2012-03-10 - Modestas Vainius <modax@debian.org>
ktorrent (4.2.0-1) unstable; urgency=low
* New upstream release.
* Bump Standards-Version to 3.9.3: no changes needed.
* Require libktorrent 1.2.0 to build.
* Build depend on debhelper 9 as lintian insists.
* Enable kio-magnet (pass -DENABLE_KIO_MAGNET=1 to cmake).
2011-12-06 - Modestas Vainius <modax@debian.org>
ktorrent (4.1.3-1) unstable; urgency=low
* New upstream release.
* Bump debhelper compat level to 9 and require debhelper 8.9.0 in order to
gain transparent support for dpkg-buildflags in dh/dh_auto_*.
* Reorder dh options in compat=8 compatible way.
2011-08-18 - Modestas Vainius <modax@debian.org>
ktorrent (4.1.2-1) unstable; urgency=low
* New upstream release.
* Add krosspython to ktorrent Suggests.
* Require libktorrent-dev 1.1.2.
2011-05-28 - Modestas Vainius <modax@debian.org>
ktorrent (4.1.1-2) unstable; urgency=low
* Add kdebase-workspace-dev (<< 4:4.6) to Build-Conflicts temporary. Needed
for KDE SC 4.6 transition.
* Upload to unstable.
2011-05-03 - Modestas Vainius <modax@debian.org>
ktorrent (4.1.1-1) experimental; urgency=low
* New upstream release.
* Require libktorrent-dev 1.1.1.
* Bump Standards-Version to 3.9.2: no changes needed.
* Correct menu-icon-missing override.
2011-03-23 - Modestas Vainius <modax@debian.org>
ktorrent (4.1.0-1) experimental; urgency=low
* New upstream release.
* Require libktorrent-dev 1.1.0.
* Drop upstream_kde4.4_compat.diff patch, merged upstream.
* Build depend on libqtwebkit-dev | libqt4-dev (<< 4:4.7.0).

See Also

Package Description
ktouch-data_4.14.2-1_all.deb data files for ktouch
ktouch_4.14.2-1_amd64.deb touch typing tutor for KDE
ktouchpadenabler_4.11.13-2_amd64.deb kded daemon to enable/disable touchpad
ktron_4.14.0-1_amd64.deb Tron-like snakerace game
kttsd_4.14.2-1_all.deb transitional package for jovie
ktuberling_4.14.0-1_amd64.deb stamp drawing toy
kturtle_4.14.1-1_amd64.deb educational programming environment
ktux_4.12.2-2_amd64.deb Tux screensaver for KScreenSaver
kubrick_4.12.2-2_amd64.deb game based on Rubik's Cube
kuipc_20061220+dfsg3-4.1_amd64.deb CERNLIB data analysis suite - KUIP compiler
kuiviewer_4.12.2-2_amd64.deb viewer for Qt Designer user interface files
kumofs_0.4.13-6.1_amd64.deb simple and fast distributed key-value store
kunststoff_2.0.2-5_all.deb suite of skins for different applications
kup-client_0.3.2-2_all.deb kernel.org upload tool
kup-server_0.3.2-2_all.deb kernel.org upload server
Advertisement
Advertisement