krossruby_4.13.1-1_amd64.deb


Advertisement

Description

krossruby - Ruby module for Kross

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: krossruby
Package version: 4.13.1
Package release: 1
Package architecture: amd64
Package type: deb
Installed size: 178 B
Download size: 46.20 KB
Official Mirror: ftp.br.debian.org
Kross is a scripting framework to enable scripting in various languages in all kinds of KDE applications. Kross itself is a part of KDELibs, this package contains the Kross Ruby plugin.

Alternatives

Replaces

  • libkde4-ruby1.8 << 4:4.2.60

    Download

    Source package: kross-interpreters

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install krossruby deb package:
      # sudo apt-get install krossruby

    Files

    • /usr/lib/kde4/krossruby.so
    • /usr/share/doc/krossruby/changelog.Debian.gz
    • /usr/share/doc/krossruby/copyright

    Changelog

    2014-05-22 - Maximiliano Curia <maxy@debian.org> kross-interpreters (4:4.13.1-1) unstable; urgency=medium * New upstream release. * Remove upstream patch: upstream_ruby-do-not-reject-ruby-versions- greater-than-1.9.patch

    2014-04-28 - Maximiliano Curia <maxy@debian.org> kross-interpreters (4:4.12.2-2) unstable; urgency=medium [ Pino Toscano ] * Merge changes from the 4:4.11.5-3 upload. [ Maximiliano Curia ]

    2014-02-10 - Maximiliano Curia <maxy@debian.org> kross-interpreters (4:4.12.2-1) experimental; urgency=medium * New upstream release. * Remove upstream patch: upstream_ruby-fix-rb_raise-calls-with- arguments.patch. * Bump kde-sc-dev-latest build dependency.

    2014-04-12 - Pino Toscano <pino@debian.org> kross-interpreters (4:4.11.5-3) unstable; urgency=medium * Team upload. * Fix krossruby build with ruby > 1.9: (Closes: #739128) - bump the cmake build dependency to 2.8.12.1-1.2, since that version fixes FindRuby.cmake for ruby 2.x versions - backport upstream commit 7f919486919fb083670f66b5d9054a1c5e2179d0 to accept ruby versions greater than 1.9; patch upstream_ruby-do-not-reject-ruby-versions-greater-than-1.9.patch

    2014-01-28 - Maximiliano Curia <maxy@debian.org> kross-interpreters (4:4.11.5-2) unstable; urgency=medium * Merge previous upload.

    2014-01-28 - Maximiliano Curia <maxy@debian.org> kross-interpreters (4:4.11.5-1) unstable; urgency=low * New upstream release. * Bump Standards-Version to 3.9.5, no changes needed.

    2014-01-10 - Pino Toscano <pino@debian.org> kross-interpreters (4:4.11.3-2) unstable; urgency=low * Team upload. * Add krossruby back: (Closes: #693533) - copy control snippet and krossruby.install from the old kdebindings packaging - add the ruby and ruby-dev build dependencies - backport upstream commit cc551d8feeed74ee923c53587ee08859560c3300 to fix build of krossruby with -Werror=format-security; patch upstream_ruby-fix-rb_raise-calls-with-arguments.patch. * Bump Standards-Version to 3.9.5, no changes required.

    2013-11-09 - Maximiliano Curia <maxy@debian.org> kross-interpreters (4:4.11.3-1) unstable; urgency=low * New upstream release. * Update build dependencies.

    2013-10-09 - Maximiliano Curia <maxy@debian.org> kross-interpreters (4:4.11.2-1) experimental; urgency=low * New upstream release.

    2013-07-12 - Maximiliano Curia <maxy@debian.org> kross-interpreters (4:4.10.5-1) unstable; urgency=low * New upstream release.

    Advertisement
    Advertisement