krosspython_4.13.1-1_amd64.deb


Advertisement

Description

krosspython - Python module for Kross

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name krosspython
Package version 4.13.1
Package release 1
Package architecture amd64
Package type deb
Installed size 415 B
Download size 119.15 KB
Official Mirror ftp.br.debian.org
Kross is a scripting framework to enable scripting in various languages in all
kinds of KDE applications.
Kross itself is a part of KDELibs, this package contains the Kross Python
plugin.

Alternatives

Package Version Architecture Repository
krosspython_4.13.1-1_i386.deb 4.13.1 i386 Debian Main
krosspython - - -

Requires

Name Value
libc6 >= 2.14
libgcc1 >= 1:4.1.1
libkrosscore4 >= 4:4.11
libpython2.7 >= 2.7
libqtcore4 >= 4:4.7.0~beta1
libqtgui4 >= 4:4.5.3
libstdc++6 >= 4.2.1

Replaces

Name Value
python-kde4 << 4:4.2.60

Download

Type URL
Binary Package krosspython_4.13.1-1_amd64.deb
Source Package kross-interpreters

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install krosspython deb package:
    # sudo apt-get install krosspython

Files

Path
/usr/lib/kde4/krosspython.so
/usr/share/doc/krosspython/changelog.Debian.gz
/usr/share/doc/krosspython/copyright

Changelog

2014-05-22 - Maximiliano Curia <maxy@debian.org>
kross-interpreters (4:4.13.1-1) unstable; urgency=medium
* New upstream release.
* Remove upstream patch: upstream_ruby-do-not-reject-ruby-versions-
greater-than-1.9.patch
2014-04-28 - Maximiliano Curia <maxy@debian.org>
kross-interpreters (4:4.12.2-2) unstable; urgency=medium
[ Pino Toscano ]
* Merge changes from the 4:4.11.5-3 upload.
[ Maximiliano Curia ]
2014-02-10 - Maximiliano Curia <maxy@debian.org>
kross-interpreters (4:4.12.2-1) experimental; urgency=medium
* New upstream release.
* Remove upstream patch: upstream_ruby-fix-rb_raise-calls-with-
arguments.patch.
* Bump kde-sc-dev-latest build dependency.
2014-04-12 - Pino Toscano <pino@debian.org>
kross-interpreters (4:4.11.5-3) unstable; urgency=medium
* Team upload.
* Fix krossruby build with ruby > 1.9: (Closes: #739128)
- bump the cmake build dependency to 2.8.12.1-1.2, since that version fixes
FindRuby.cmake for ruby 2.x versions
- backport upstream commit 7f919486919fb083670f66b5d9054a1c5e2179d0 to
accept ruby versions greater than 1.9; patch
upstream_ruby-do-not-reject-ruby-versions-greater-than-1.9.patch
2014-01-28 - Maximiliano Curia <maxy@debian.org>
kross-interpreters (4:4.11.5-2) unstable; urgency=medium
* Merge previous upload.
2014-01-28 - Maximiliano Curia <maxy@debian.org>
kross-interpreters (4:4.11.5-1) unstable; urgency=low
* New upstream release.
* Bump Standards-Version to 3.9.5, no changes needed.
2014-01-10 - Pino Toscano <pino@debian.org>
kross-interpreters (4:4.11.3-2) unstable; urgency=low
* Team upload.
* Add krossruby back: (Closes: #693533)
- copy control snippet and krossruby.install from the old kdebindings
packaging
- add the ruby and ruby-dev build dependencies
- backport upstream commit cc551d8feeed74ee923c53587ee08859560c3300 to fix
build of krossruby with -Werror=format-security; patch
upstream_ruby-fix-rb_raise-calls-with-arguments.patch.
* Bump Standards-Version to 3.9.5, no changes required.
2013-11-09 - Maximiliano Curia <maxy@debian.org>
kross-interpreters (4:4.11.3-1) unstable; urgency=low
* New upstream release.
* Update build dependencies.
2013-10-09 - Maximiliano Curia <maxy@debian.org>
kross-interpreters (4:4.11.2-1) experimental; urgency=low
* New upstream release.
2013-07-12 - Maximiliano Curia <maxy@debian.org>
kross-interpreters (4:4.10.5-1) unstable; urgency=low
* New upstream release.

See Also

Package Description
krossruby_4.13.1-1_amd64.deb Ruby module for Kross
kruler_4.12.3-2_amd64.deb screen ruler
krusader_2.4.0~beta3-2_amd64.deb twin-panel (commander-style) file manager
ksaneplugin_4.11.3-2_amd64.deb KScan plugin for scanning through libksane
kscd_4.13.3-1_amd64.deb audio CD player
kscope_1.9.4-2+b2_amd64.deb source browsing and editing environment
kscreen_1.0.2.1-1_amd64.deb KDE monitor hotplug and screen handling
kscreensaver-xsavers-webcollage_4.14.2-1_all.deb webcollage screensaver support for KScreenSaver
kscreensaver-xsavers_4.14.2-1_amd64.deb XScreenSaver support for KScreenSaver
kscreensaver_4.14.2-1_amd64.deb additional screensavers for KScreenSaver
ksh_93u+20120801-1_amd64.deb Real, AT&T version of the Korn shell
kshisen_4.13.1-1_amd64.deb Shisen-Sho solitaire game
kshutdown_3.2-1_amd64.deb advanced shut down utility for KDE
ksirk_4.14.0-1_amd64.deb Risk strategy game
ksnapshot_4.12.2-2_amd64.deb screen capture tool
Advertisement
Advertisement