kpart-webkit_1.3.4-2_amd64.deb


Advertisement

Description

kpart-webkit - WebKit KPart

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: kpart-webkit
Package version: 1.3.4
Package release: 2
Package architecture: amd64
Package type: deb
Installed size: 452 B
Download size: 155.26 KB
Official Mirror: ftp.br.debian.org
This package contains a plug-In for alowing the Konqueror web browser and other KDE applications to use the WebKit HTML renderer instead of the traditional KHTML.

Alternatives

Provides

  • libkwebkit1

Conflicts

  • libkwebkit-dev
  • libkwebkit1

Replaces

  • libkwebkit1

    Download

    Source package: webkitkde

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install kpart-webkit deb package:
      # sudo apt-get install kpart-webkit

    Files

    • /usr/lib/kde4/kwebkitpart.so
    • /usr/share/doc/kpart-webkit/README
    • /usr/share/doc/kpart-webkit/changelog.Debian.gz
    • /usr/share/doc/kpart-webkit/copyright
    • /usr/share/icons/hicolor/128x128/apps/webkit.png
    • /usr/share/icons/hicolor/16x16/apps/webkit.png
    • /usr/share/icons/hicolor/22x22/apps/webkit.png
    • /usr/share/icons/hicolor/32x32/apps/webkit.png
    • /usr/share/icons/hicolor/48x48/apps/webkit.png
    • /usr/share/icons/hicolor/64x64/apps/webkit.png
    • /usr/share/kde4/apps/kwebkitpart/error.html
    • /usr/share/kde4/apps/kwebkitpart/kwebkitpart.rc
    • /usr/share/kde4/services/kwebkitpart.desktop

    Changelog

    2014-12-10 - Adrien Grellier <perso@adrieng.fr> webkitkde (1.3.4-2) unstable; urgency=medium * Team upload. [ Adrien Grellier ] * SECURITY UPDATE: Insufficient Input Validation By IO Slaves and Webkit Part - Add upstream_cve-2014-8600.diff to escape protocol twice: once for i18n, and once for HTML - https://www.kde.org/info/security/advisory-20141113-1.txt - CVE-2014-8600 - LP: #1393479 Thanks to the Ubuntu Team!

    2014-07-22 - Adrien Grellier <perso@adrieng.fr> webkitkde (1.3.4-1) unstable; urgency=medium * New upstream release 1.3.4 * Change my email addresse in debian/control

    2014-03-22 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org> webkitkde (1.3.2-2) unstable; urgency=low * Team upload. [ Adrien Grellier ] * use canonical URI for VCS-* fields (lintian: vcs-field-not-canonical) [ Lisandro Damián Nicanor Pérez Meyer ] * Update Standards-Version to 3.9.5, no changes required. * Upload to unstable.

    2013-04-07 - Adrien Grellier <adrien.grellier@laposte.net> webkitkde (1.3.2-1) experimental; urgency=low [ Lisandro Damián Nicanor Pérez Meyer ] * Bump Build-Depends on kdelibs to 4:4.8.3. Thanks Nobuhiro for noticing! (Closes: #684436). [ Adrien Grellier ] * New upstream release (Closes: #687992) * Update to Debian policy 3.9.4, no changes needed.

    2012-06-29 - Adrien Grellier <adrien.grellier@laposte.net> webkitkde (1.3~git20120518.9a111005-2) unstable; urgency=low * fix dh: Unknown sequence build-stamp (Closes: #679472)

    2012-06-27 - Raúl Sánchez Siles <rasasi78@gmail.com> webkitkde (1.3~git20120518.9a111005-1) unstable; urgency=low [ Adrien Grellier ] * New Maintainer (Closes: #624448) * Correct lintian warnings * build with hardening flags * Update copyright file. [ Raúl Sánchez Siles ] * New upstream pre 1.3. - Fix "konqueror with webkit and rekonq both crashes in acid3 test at about 73/100" (Closes: #629986) * Update packaging to debhelper8. * Provide debug package. * Setting Debian KDE Extras Team as maintainer and adding Adrien and myself as uploaders. Thanks Adrian! * Update homepage. * Improved package description as per Michael Meskes suggestion. * Replacing obsolete libkwebkit packages. [ Adrian von Bidder ] * Drop library package, there's only the kpart anymore; conflict with the old libkwebkit-dev (FindKWebKitPart.cmake)

    2011-03-13 - Adrian von Bidder <cmot@debian.org> webkitkde (0.9.6svn1187649-1) experimental; urgency=low * New upstream version. - Switch to the stable branch in subversion; trunk requires KDE 4.6 * Drop the libkwebkit0.9.5 name, new versions will change ABI anyway. * Drop mention of very old (used in sid only) package names * Build-Dependencies: QtWebkit is not in qt anymore. (Closes: #618133)

    2010-09-28 - Adrian von Bidder <cmot@debian.org> webkitkde (0.9.6svn1180498-1) unstable; urgency=low * New upstream version. - last version that can be built with KDE < 4.5.69 * debian/rules: Don't ignore build problems due to ABI changes anymore.

    2010-09-05 - Adrian von Bidder <cmot@debian.org> webkitkde (0.9.6svn1170614-1) unstable; urgency=low * New upstream version. - History fixes. * Merge NMU and adjust README.Debian to match the new reality * Convert symbol file to C++ * Update to Policy 3.9.1

    2010-09-01 - Sune Vuorela <sune@debian.org> webkitkde (0.9.6svn1158036-2.1) unstable; urgency=low * Non-maintainer upload, acked by maintainer. * Revert the changes to upstream regarding priorities of plugins.

    Advertisement
    Advertisement