kmod_18-3_amd64.deb


Advertisement

Description

kmod - tools for managing Linux kernel modules

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name kmod
Package version 18
Package release 3
Package architecture amd64
Package type deb
Installed size 274 B
Download size 84.21 KB
Official Mirror ftp.br.debian.org
This package contains a set of programs for loading, inserting, and
removing kernel modules for Linux.
It replaces module-init-tools.

Alternatives

Package Version Architecture Repository
kmod_18-3_i386.deb 18 i386 Debian Main
kmod - - -

Requires

Name Value
libc6 >= 2.17
libkmod2 = 18-3
lsb-base >= 3.0-6

Replaces

Name Value
module-init-tools << 4

Download

Type URL
Binary Package kmod_18-3_amd64.deb
Source Package kmod

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install kmod deb package:
    # sudo apt-get install kmod

Files

Path
/bin/kmod
/bin/lsmod
/etc/init.d/kmod
/lib/modprobe.d/aliases.conf
/sbin/depmod
/sbin/insmod
/sbin/lsmod
/sbin/modinfo
/sbin/modprobe
/sbin/rmmod
/usr/share/bash-completion/completions/kmod
/usr/share/doc/kmod
/usr/share/doc/libkmod2/README
/usr/share/doc/libkmod2/TODO
/usr/share/initramfs-tools/hooks/kmod
/usr/share/man/fr/man5/modules.5.gz
/usr/share/man/man5/depmod.d.5.gz
/usr/share/man/man5/modprobe.d.5.gz
/usr/share/man/man5/modules.5.gz
/usr/share/man/man5/modules.dep.5.gz
/usr/share/man/man5/modules.dep.bin.5.gz
/usr/share/man/man8/depmod.8.gz
/usr/share/man/man8/insmod.8.gz
/usr/share/man/man8/kmod.8.gz
/usr/share/man/man8/lsmod.8.gz
/usr/share/man/man8/modinfo.8.gz
/usr/share/man/man8/modprobe.8.gz
/usr/share/man/man8/rmmod.8.gz

Changelog

2014-09-27 - Marco d'Itri <md@linux.it>
kmod (18-3) unstable; urgency=high
* postinst: do not use autodie. (Closes: #762974)
* postinst: do not create an empty etc-modules-parameters.conf.
2014-09-17 - Marco d'Itri <md@linux.it>
kmod (18-2) unstable; urgency=medium
* postinst: move any modules parameters from /etc/modules to a new
/etc/modprobe.d/etc-modules-parameters.conf file. (Closes: #627949)
* initramfs-hook: do not fail if /lib/modprobe.d/ is empty.
* Add the man page for kmod(8). (Closes: #665873)
* Document depmod --show in depmod(8). (Closes: #687435)
2014-06-21 - Marco d'Itri <md@linux.it>
kmod (18-1) unstable; urgency=medium
* New upstream release.
2014-05-04 - Marco d'Itri <md@linux.it>
kmod (17-2) unstable; urgency=medium
* Build-Depend on gtk-doc-tools. (Closes: #747005)
2014-05-01 - Marco d'Itri <md@linux.it>
kmod (17-1) unstable; urgency=medium
* New upstream release.
* Declared that kmod Breaks oss-compat 4. (Closes: #736748)
* Merged the few useful directives from the alsa-base package and added
a versioned Breaks to force it to be unistalled.
2014-01-02 - Marco d'Itri <md@linux.it>
kmod (16-2) unstable; urgency=medium
* Always Build-Depend on xsltproc. (Closes: #733760)
2013-12-31 - Marco d'Itri <md@linux.it>
kmod (16-1) unstable; urgency=low
* New upstream release. (Closes: #716739)
+ Improves error messages. (Closes: #676387)
+ Fixes modprobe -f. (Closes: #720599)
* Added an example to modules(5), patch by Regid Ichira. (Closes: #711468)
2013-04-07 - Marco d'Itri <md@linux.it>
kmod (9-3) unstable; urgency=low
* Added backported patch dot_kcmdline: correctly parse kcmdline parameters 
containing a dot. (Closes: #689872)
* Added backported patch bad_alias_assertion: stop modprobe from aborting 
from an assertion because of some invalid but common configuration
directives. (Closes: #674110)
* Removed the nfs4 alias from aliases.conf as requested by the kernel 
team. (Closes: #683972)
* Removed the unnecessary build-dependency on perl. (Closes: #697750)
2012-08-27 - Marco d'Itri <md@linux.it>
kmod (9-2) unstable; urgency=low
* Backported upstream fixes to make modprobe work like in module-init-tools
and not load a blacklisted module even if modprobe is invoked with one of
its aliases.
* Report an error when some .bin files do not exist. (Closes: #684901)
* Really build the udeb with -Os -fomit-frame-pointer.
2012-06-25 - Marco d'Itri <md@linux.it>
kmod (9-1) unstable; urgency=medium
* New upstream release.

See Also

Package Description
kmousetool_4.12.2-1_amd64.deb mouse manipulation tool for the disabled
kmouth_4.14.0-1_amd64.deb type-and-say frontend for speech synthesizers
kmplayer_0.11.3d-2_amd64.deb media player for KDE
kmplot_4.14.2-1_amd64.deb mathematical function plotter for KDE
kmtrace_4.12.2-2_amd64.deb memory leak tracer
kmymoney-common_4.6.6-1_all.deb KMyMoney architecture independent files
kmymoney-dev_4.6.6-1+b1_amd64.deb KMyMoney development files
kmymoney_4.6.6-1+b1_amd64.deb personal finance manager for KDE
knavalbattle_4.13.3-1_amd64.deb battleship board game
knemo_0.7.6-2_amd64.deb network interfaces monitor for KDE's systray
knetwalk_4.12.4-1_amd64.deb wire puzzle game
knews_1.0b.1-29+b2_amd64.deb Graphical threaded news reader
knights_2.5.0-1+b1_amd64.deb chess interface for the KDE Platform
knockd_0.5-3_amd64.deb small port-knock daemon
knocker_0.7.1-4_amd64.deb Simple and easy to use TCP security port scanner
Advertisement
Advertisement