kimwitu_4.6.1-7.1_amd64.deb


Advertisement

Description

kimwitu - Compiler development tool, complementary to lex and yacc

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name kimwitu
Package version 4.6.1
Package release 7.1
Package architecture amd64
Package type deb
Installed size 1.05 KB
Download size 256.52 KB
Official Mirror ftp.br.debian.org
Kimwitu (pronounced kee'mweetoo) is a system that supports
the construction of programs that use trees or terms as
their main data structure. It is a ‘meta-tool’ in the
development process of tools.
It can easily be interfaced with Yacc and Lex – the idea
is that yacc and lex are used to do the parsing, and
Kimwitu routines are used to built and manipulate the
parse tree.
There is also Kimwitu++ (also packaged for Debian) which interfaces
with C++ instead of C.

Alternatives

Package Version Architecture Repository
kimwitu_4.6.1-7.1_i386.deb 4.6.1 i386 Debian Main
kimwitu - - -

Requires

Name Value
libc6 >= 2.7-1

Download

Type URL
Binary Package kimwitu_4.6.1-7.1_amd64.deb
Source Package kimwitu

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install kimwitu deb package:
    # sudo apt-get install kimwitu

Files

Path
/usr/bin/kc
/usr/share/doc/kimwitu/AUTHORS
/usr/share/doc/kimwitu/INCOMPATBLE_CHANGE
/usr/share/doc/kimwitu/README
/usr/share/doc/kimwitu/README.Debian
/usr/share/doc/kimwitu/README.doc
/usr/share/doc/kimwitu/about-kimwitu
/usr/share/doc/kimwitu/changelog.Debian.gz
/usr/share/doc/kimwitu/copyright
/usr/share/man/man1/kc.1.gz

Changelog

2008-04-06 - Michael Meskes <meskes@debian.org>
kimwitu (4.6.1-7.1) unstable; urgency=high
* Non-maintainer upload.
* Made package compile twice in a row, closes: #424456
2006-05-08 - Michael Piefel <piefel@debian.org>
kimwitu (4.6.1-7) unstable; urgency=low
* Avoid mktemp and work with Bison of the 3rd millenium
2006-04-28 - Michael Piefel <piefel@debian.org>
kimwitu (4.6.1-6) unstable; urgency=low
* Finally: /usr/doc transition (closes: #359439)
2001-02-16 - Michael Piefel <piefel@debian.org>
kimwitu (4.6.1-5) unstable; urgency=low
* Changed the perl script errmsg.pl (which shouldn't have been called
anyway) so it produces correct output with modern bison. (closes: #86161)
* Makefile now touches two file so that abovementioned script is not called.
2001-02-09 - Michael Piefel <piefel@debian.org>
kimwitu (4.6.1-4) unstable; urgency=low
* New maintainer
2000-08-29 - W. Borgert <debacle@debian.org>
kimwitu (4.6.1-3) unstable; urgency=low
* Could not be build w/o fakeroot.  Fixed bug#70423,
thanks to Roman Hodek <roman@caldera.de>.
2000-08-20 - W. Borgert <debacle@debian.org>
kimwitu (4.6.1-2) unstable; urgency=low
* Fixed a lintian warning.
2000-04-15 - W. Borgert <debacle@debian.org>
kimwitu (4.6.1-1) unstable; urgency=low
* Initial Release.

See Also

Package Description
kindleclip_0.5-1_all.deb User interface for managing Amazon Kindle's "My Clippings" file
kinfocenter_4.11.13-2_amd64.deb system information viewer
king_2.21.120420+dfsg-1_all.deb interactive system for three-dimensional vector graphics
kino_1.3.4-2.1+b1_amd64.deb Non-linear editor for Digital Video data
kinput2-canna-wnn_3.1-12_amd64.deb An input server for X11 applications that want Japanese text input
kinput2-canna_3.1-12_amd64.deb An input server for X11 applications that want Japanese text input
kinput2-common_3.1-12_all.deb Files shared among kinput2 packages
kinput2-wnn_3.1-12_amd64.deb An input server for X11 applications that want Japanese text input
kio-audiocd-dev_4.14.2-1_amd64.deb development files for the audio CD KIO plugin
kio-audiocd_4.14.2-1_amd64.deb transparent audio CD access for applications using the KDE Platform
kio-ftps_0.2+dfsg-2+b1_amd64.deb an ftps KIO slave for KDE 4
kio-gopher_0.1.4-1_amd64.deb gopher KIO slave for KDE4
kio-mtp_0.75+git20140304-1_amd64.deb access to MTP devices for applications using the KDE Platform
kipi-plugins-common_4.4.0-1.1_all.deb kipi-plugins architecture-independent data
kipi-plugins_4.4.0-1.1_amd64.deb image manipulation/handling plugins for KIPI aware programs
Advertisement
Advertisement