kildclient_3.0.0-2_amd64.deb


Advertisement

Description

kildclient - powerful MUD client with a built-in Perl interpreter

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: kildclient
Package version: 3.0.0
Package release: 2
Package architecture: amd64
Package type: deb
Installed size: 1.45 KB
Download size: 261.07 KB
Official Mirror: ftp.br.debian.org
KildClient is a MUD Client written with the GTK+ windowing toolkit. It supports many common features of other clients, such as triggers, gags, aliases, macros, timers, and much more. But its main feature is the built-in Perl interpreter. You can at any moment execute Perl statements and functions to do things much more powerful than simply sending text the mud. Perl statements can also be run, for example, as the action of a trigger, allowing you to do complex things. Some built-in functions of KildClient allow interaction with the world, such as sending commands to it. KildClient's ANSI support is extensive: it supports not only the common 16 colors, but also support underlined text (singly and doubly), text in italics, text striked through, reverse video and "hidden" text. It also supports vt100's line-drawing characters, and xterm's escape sequences for a 256-color mode. All these features make KildClient one of the clients with the most features for displaying the mud output. Kildclient supports the MCCP (Mud Client Compression Protocol) protocol, versions 1 and 2, to reduce the necessary bandwidth. KildClient allows connection through SOCKS4/5 and HTTP proxy servers. KildClient supports the GMCP (also called ATCP2) and MSDP protocols for out-of-band communications between server and client. This package contains the main program. Install the kildclient-doc package to access the HTML manual.

Alternatives

    Download

    Source package: kildclient

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install kildclient deb package:
      # sudo apt-get install kildclient

    Files

    • /usr/games/kildclient
    • /usr/share/applications/kildclient.desktop
    • /usr/share/doc/kildclient/AUTHORS
    • /usr/share/doc/kildclient/NEWS.Debian.gz
    • /usr/share/doc/kildclient/NEWS.gz
    • /usr/share/doc/kildclient/README
    • /usr/share/doc/kildclient/changelog.Debian.gz
    • /usr/share/doc/kildclient/copyright
    • /usr/share/kildclient/MSDP.pm
    • /usr/share/kildclient/dlgAbout.ui
    • /usr/share/kildclient/dlgCmdHistory.ui
    • /usr/share/kildclient/dlgEditWorld.ui
    • /usr/share/kildclient/dlgMLSend.ui
    • /usr/share/kildclient/dlgPreferences.ui
    • /usr/share/kildclient/dlgSelectWorld.ui
    • /usr/share/kildclient/dlgStatistics.ui
    • /usr/share/kildclient/dlgTestTriggers.ui
    • /usr/share/kildclient/kcworld.dtd
    • /usr/share/kildclient/kildclient.hlp
    • /usr/share/kildclient/kildclient.pl
    • /usr/share/kildclient/kildclient.ui
    • /usr/share/kildclient/mnuPopupURL.ui
    • /usr/share/kildclient/wndmain.ui
    • /usr/share/kildclient/plugins/KCWin.pl
    • /usr/share/kildclient/plugins/channels.pl
    • /usr/share/kildclient/plugins/chat.pl
    • /usr/share/kildclient/plugins/easypath.pl
    • /usr/share/kildclient/plugins/kc256.pl
    • /usr/share/kildclient/plugins/keypad.pl
    • /usr/share/kildclient/plugins/notes.pl
    • /usr/share/kildclient/plugins/serverdatadumper.pl
    • /usr/share/locale/de/LC_MESSAGES/kildclient.mo
    • /usr/share/locale/eo/LC_MESSAGES/kildclient.mo
    • /usr/share/locale/es/LC_MESSAGES/kildclient.mo
    • /usr/share/locale/pt_BR/LC_MESSAGES/kildclient.mo
    • /usr/share/locale/sv/LC_MESSAGES/kildclient.mo
    • /usr/share/man/man6/kildclient.6.gz
    • /usr/share/menu/kildclient
    • /usr/share/pixmaps/kildclient.png
    • /usr/share/pixmaps/kildclient.xpm

    Changelog

    2014-12-08 - Eduardo M Kalinowski <eduardo@kalinowski.com.br> kildclient (3.0.0-2) unstable; urgency=medium * Added work-around to enable scroll-to-end feature to work with GTK+ >= 3.13. Closes: #772096

    2014-09-06 - Eduardo M Kalinowski <eduardo@kalinowski.com.br> kildclient (3.0.0-1) unstable; urgency=low * New upstream version: 3.0.0. * Acknowledge NMU. Thanks for Andreas Metzler. * control: Updated VCS urls. * control: Reintroduced Homepage field that was lost and made it point to the new URL. * copyright: Point to new homepage. * control: New dependency: libjson-perl * control: glib >= 2.32.0, gtk+3 >= 3.10.0 and gtkspell3 are now required. gtk3-perl is suggested instead of gtk2-perl. * control: Use debhelper 9 and dh-autoreconf. * control: Mentioned HTTP proxies in description. * control: Updated Vcs fields to point to new git repository. * control: Updated policy compliance to 3.9.5; no changes were necessary. * rules: Rewritten using dh. Added hardening flags. dh-autoreconf is now used instead of autotools-dev. Enabled parallel build. * copyright: Change URL of Format: line to point to Version 1.0 of the machine-readable format. * copyright: util_cursor.h is no longer used, so it has been removed.

    2014-08-08 - Andreas Metzler <ametzler@debian.org> kildclient (2.11.1-1.1) unstable; urgency=medium * Non-maintainer upload. * Rebuild against GnuTLS v3. Closes: #753101

    2011-05-28 - Eduardo M Kalinowski <eduardo@kalinowski.com.br> kildclient (2.11.1-1) unstable; urgency=low * New upstream version: 2.11.1: - Removed call to deprecated gnutls functions. (Closes: #624039) * copyright: Changed to DEP-5 format, added license information for share/plugins/channels.pl. * Switch to dpkg-source 3.0 (quilt) format. * control: mininum required version of gnutls-dev is set to 2.2.0 because of the function used to fix the aforementioned bug. * control: Require glib >= 2.14.0, gtk >= 2.18.0, but libglade is not necessary anymore. * control: Added ${misc:Depends} dependency to kildclient-doc package. * debhelper 8 is now used. * rules, control: call dh_autotools-dev_updateconfig on package configuration and dh_autotools-dev_restoreconfig on clean. Added autotools-dev as a build dependency. * rules: Removed dh_desktop call. * rules: cleaned some comments. * control: short description starts in lowercase.

    2011-05-13 - Eduardo M Kalinowski <eduardo@kalinowski.com.br> kildclient (2.9.0-2) unstable; urgency=low * Added missing -lz flag to linker, and listed zlib1g-dev as Build-Depends. (Closes: #555000, #623726) * Updated policy complicance to 3.9.2; no changes were necessary.

    2009-05-23 - Eduardo M Kalinowski <eduardo@kalinowski.com.br> kildclient (2.9.0-1) unstable; urgency=low * New upstram version: 2.9.0. - The way the presence of gnutls is checked has been changed to use pkg-config. (Closes: #529905). * control: Updated policy compliance to 3.8.1; no changes were necessary in the packaging. * changelog: Do not use the symlinks /GPL and /LGPL anymore, explicit versions are used.

    2009-01-29 - Eduardo M Kalinowski <eduardo@kalinowski.com.br> kildclient (2.8.1-1) experimental; urgency=low * New upstream version: 2.8.1. * HTML manual is now split into separate package kildclient-doc. * Changed section to games, and menu section to "Games/Adventure". The binary is now installed in /usr/games (Policy, section 11.11) by the rules file.

    Advertisement
    Advertisement