kiki_0.5.6-8.1_all.deb


Advertisement

Description

kiki - tool for python regular expression testing

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: kiki
Package version: 0.5.6
Package release: 8.1
Package architecture: all
Package type: deb
Installed size: 175 B
Download size: 30.08 KB
Official Mirror: ftp.br.debian.org
A free environment for regular expression testing (ferret). It allows you to write regexes and test them against a sample text, providing extensive output about the results. It is useful for several purposes: - exploring and understanding the structure of match objects generated by the re module, making Kiki a valuable tool for people new to regexes. - testing regexes on sample text before deploying them in code. Kiki can function on its own or as plugin for the Spe Python editor.

Alternatives

    Download

    Binary package: kiki_0.5.6-8.1_all.deb
    Source package: kiki

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install kiki deb package:
      # sudo apt-get install kiki

    Files

    • /usr/bin/kiki
    • /usr/lib/python2.7/dist-packages/kiki-0.5.6.egg-info
    • /usr/lib/python2.7/dist-packages/kiki.py
    • /usr/share/applications/kiki.desktop
    • /usr/share/doc-base/kiki
    • /usr/share/doc/kiki/about.html
    • /usr/share/doc/kiki/changelog.Debian.gz
    • /usr/share/doc/kiki/changelog.gz
    • /usr/share/doc/kiki/copyright
    • /usr/share/doc/kiki/index.html
    • /usr/share/doc/kiki/kiki.wxg.gz
    • /usr/share/doc/kiki/re.html
    • /usr/share/doc/kiki/readme.txt
    • /usr/share/man/man6/kiki.6.gz
    • /usr/share/menu/kiki
    • /usr/share/pixmaps/kiki.xpm

    Changelog

    2014-09-07 - Olly Betts <olly@survex.com> kiki (0.5.6-8.1) unstable; urgency=medium * Non-maintainer upload. * Update to use wxPython 3.0 (Closes: #758714): + New patch: 04_wxpy3.0-compat.patch

    2011-11-25 - Ignace Mouzannar <mouzannar@gmail.com> kiki (0.5.6-8) unstable; urgency=low * debian/patch: - 03_setup.py.diff: patched this file to correct the serious bug it introduced after migrating to dh_python2. (Closes: 649869)

    2011-11-19 - Ignace Mouzannar <mouzannar@gmail.com> kiki (0.5.6-7) unstable; urgency=low [ Olly Betts ] * Update to use python-wxgtk2.8. + New patch 02_remove_wx.NotebookSizer.diff to fix compatibility issue. + Update 01_path_changes.diff to load kiki.xpm (which is in the package) rather than kiki.ico (which isn't). Seems 2.6 never tries to load the icon, but 2.8 does. (Closes: 645755) [ Ignace Mouzannar ] * Mirated from python-support to dh_python2. * debian/control: - Removed dependency on python-support. - Bumped minimum required python dependency to 2.6.6-3~. - Updated XS-Python-Version to X-Python-Version. * debian/rules: - Added python2 to dh's --with argument. * debian/pyversions: - Deleted the file.

    2011-06-05 - Ignace Mouzannar <mouzannar@gmail.com> kiki (0.5.6-6) unstable; urgency=low * debian/patches: - Removed 02_init.py.diff patch that created the __init__.py file as it is no longer needed. (Closes: 629345)

    2011-06-04 - Ignace Mouzannar <mouzannar@gmail.com> kiki (0.5.6-5) unstable; urgency=low * debian/control: - Bumped Standards-Version to 3.9.2. - Set the DM-Upload-Allowed field to 'yes'. * debian/kiki.docs: - Added the kiki.wxg file. * debian/patches: - 03_setup.py.diff: Added setup.py to remove the strict dependency on python2.5 as it is not supported by python-support anymore. (Closes: #627948)

    2010-05-04 - Ignace Mouzannar <mouzannar@gmail.com> kiki (0.5.6-4) unstable; urgency=low * New maintainer. (Closes: #579371) * debian/control: - Updated Maintainer field. - Bumped Standards-Version to 3.8.4. - Updated dependency on debhelper to (>= 7.0.50~) in order to use dh7 features. - Corrected the formatting of the long Description. (Closes: #480326) - Now uses python-support instead of python-central. - Added dependency on ${misc:Depends}. - Changed build dependency on python-all-dev to python-all. - Added Homepage, even though it is currently unavailable. * debian/rules: - Updated to use dh7 features. * debian/kiki.install, debian/kiki.docs and debian/kiki.dirs: - List files to install. Previously, it was done in the rules files. * source/format: - Updated packaging format to "3.0 (quilt)". * debian/custom: - Moved custom files (debian/kiki.sgml & debian/kiki.xpm) files to this directory. - Added files that were created without a patch system. - Corrected shebang in /usr/bin/kiki. * debian/patches: - 01_path_changes.diff: This patch was originally applied directly on the the source tree in the diff.gz. It corrects path values. - 02_init.py.diff: This patch was originally applied directly on the source tree in the diff.gz. It corrects the empty __init__.py file. * debian/copyright: - Updated the copyright format and information. * debian/pyversion: - As the package was switched to use python-support, compatible Python versions are now stated in this file. * Removed file debian/pycompat. * debian/watch: - Added file mentioning that upstream URL is dead. * debian/kiki.menu: - Changed "Apps" to "Applications" as per the Debian Menu System. * debian/kiki.doc-base: - Added doc-base information, as html files are provided by upstream. * debian/custom/kiki.desktop: - Added Desktop file. Thank you Stefan Lesicnik <stefan@lsd.co.za> for providing the patch. (Closes: #495695)

    Advertisement
    Advertisement