kfreebsd-source-10.1_10.1~svn274115-4_all.deb


Advertisement

Description

kfreebsd-source-10.1 - source code for kernel of FreeBSD 10.1 with Debian patches

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name kfreebsd-source-10.1
Package version 10.1~svn274115
Package release 4
Package architecture all
Package type deb
Installed size 25.39 KB
Download size 25.29 MB
Official Mirror ftp.br.debian.org
This package provides the source code for kernel of FreeBSD 10.1, base of
a GNU/kFreeBSD system.

Alternatives

Package Version Architecture Repository
kfreebsd-source-10.1_10.1~svn274115-4_all.deb 10.1~svn274115 all Debian Main
kfreebsd-source-10.1 - - -

Provides

Name Value
kfreebsd-source -
kfreebsd-source-10 -

Download

Type URL
Binary Package kfreebsd-source-10.1_10.1~svn274115-4_all.deb
Source Package kfreebsd-10

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install kfreebsd-source-10.1 deb package:
    # sudo apt-get install kfreebsd-source-10.1

Files

Path
/usr/share/doc/kfreebsd-source-10.1/NEWS.Debian.gz
/usr/share/doc/kfreebsd-source-10.1/changelog.Debian.gz
/usr/share/doc/kfreebsd-source-10.1/copyright
/usr/src/kfreebsd-source-10.1.tar.xz

Changelog

2015-04-07 - Steven Chamberlain <steven@pyro.eu.org>
kfreebsd-10 (10.1~svn274115-4) unstable; urgency=high
* Pick SVN r281232 from FreeBSD 10.1-RELEASE to fix:
- SA-15:04: integer overflow in IGMP protocol (CVE-2015-1414)
updated patch from advisory revision 1.1 (Closes: #779195)
- SA-15:09: Denial of Service with IPv6 Router Advertisements
(CVE-2015-2923) (Closes: #782107)
2015-02-25 - Steven Chamberlain <steven@pyro.eu.org>
kfreebsd-10 (10.1~svn274115-3) unstable; urgency=high
* Pick SVN r279264 from FreeBSD 10.1-RELEASE to fix:
- SA-15:04: integer overflow in IGMP protocol (CVE-2015-1414)
(Closes: #779195)
- EN-15:01: vt(4) crash with improper ioctl parameters
(CVE-2014-0998) (Closes: #779194)
2015-01-27 - Steven Chamberlain <steven@pyro.eu.org>
kfreebsd-10 (10.1~svn274115-2) unstable; urgency=high
* Pick SVN r277808 from FreeBSD 10.1-RELEASE to fix:
- SA-15:02: SCTP SCTP_SS_VALUE kernel memory corruption and
disclosure vulnerability (CVE-2014-8612) (Closes: #776415)
- SA-15:03: SCTP stream reset vulnerability (CVE-2014-8613)
(Closes: #776416)
* Build kernel images only on kfreebsd-any arches, so that any
security or other RC-severity kernel bugs will not affect the
official jessie release
2014-12-28 - Christoph Egger <christoph@debian.org>
kfreebsd-10 (10.1~svn274115-1) unstable; urgency=medium
[ Steven Chamberlain ]
* New upstream snapshot of 10.1-RC4+
- Fix kernel stack disclosure in setlogin(2) / getlogin(2). [SA-14:25]
(CVE-2014-8476) (Closes: #768108)
* Replace non-DFSG-free ar9300_devid.h with a 3-clause BSD substitute
derived from Linux ath9k driver (Closes: #767583)
[ Christoph Egger ]
* Upload to unstable
2014-10-30 - Steven Chamberlain <steven@pyro.eu.org>
kfreebsd-10 (10.1~svn273874-1) unstable; urgency=medium
* Upload to unstable
* New upstream snapshot of 10.1-RC4
2014-10-21 - Steven Chamberlain <steven@pyro.eu.org>
kfreebsd-10 (10.1~svn273581-1) experimental; urgency=high
* New upstream snapshot of 10.1-RC3+
- Fix memory leak in sandboxed namei lookup. [SA-14:22]
(CVE-2014-3711) (Closes: #766278)
* Symlink to drm2.ko as provider of drmn.ko dependency, for *kms
modules (Closes: #731182)
* NEWS: advise to reboot after upgrading kernel and userland tools
from wheezy (Closes: #765588)
2014-10-17 - Steven Chamberlain <steven@pyro.eu.org>
kfreebsd-10 (10.1~svn273304-1) unstable; urgency=medium
* New upstream snapshot of 10.1-RC3~
* Actually apply changes to debian/control meant to happen in the
previous upload (changes to Breaks: and Uploaders:)
2014-09-20 - Steven Chamberlain <steven@pyro.eu.org>
kfreebsd-10 (10.1~svn272463-1) unstable; urgency=low
[ Steven Chamberlain ]
* New upstream snapshot of 10.1-RC1
* Set a Breaks: on freebsd-net-tools (<< 10.0~) due to an ABI change
listing or modifying network interfaces
* Set a Breaks: on freebsd-smbfs (<< 10.0~) due to an ABI change
mounting an SMB filesystem
* Set a Breaks: on pf (<< 10.1~) due to an ABI change listing or
modifying firewall rules
* Set a Breaks: on grub-common (<< 2.02~) because GRUB 2.02 or later
is needed to boot from a ZFS pool having the LZ4 compression
feature enabled
* In get-orig-source, svn export with --ignore-keywords so that
revision tags do not fuzzy the patches
* Add myself to Uploaders
[ Petr Salinger ]
* Refresh patches
- aicasm-parallel-build-dependencies.diff
- userland.diff
- 001_misc.diff
- 999_config.diff
[ Christoph Egger ]
* Upload to unstable
2014-09-18 - Christoph Egger <christoph@debian.org>
kfreebsd-10 (10.1~svn271306-2) experimental; urgency=medium
* build-depend on clang-3.4 (>= 1:3.4.2-9~exp2) for #759303 fixes
* Add myself to uploaders
* Wrap control fields nicely

See Also

Package Description
kftpgrabber_0.8.99~svn1214766-1_amd64.deb ftp client for KDE
kgamma_4.14.2-1_amd64.deb monitor calibration panel for KDE
kgb-bot_1.33-2_all.deb IRC collaboration bot
kgb-client_1.33-2_all.deb client for KGB (IRC collaboration bot)
kgb_1.0b4+ds-13.2_amd64.deb Archiver for .kgb files
kgeography-data_4.14.0-1_all.deb data files for KGeography
kgeography_4.14.0-1_amd64.deb geography learning aid for KDE
kget_4.14.0+dfsg-1_amd64.deb download manager
kgoldrunner_4.12.2-2_amd64.deb Lode Runner arcade game
kgpg_4.14.2-1_amd64.deb graphical front end for GNU Privacy Guard
khangman_4.14.1-1_amd64.deb Hangman word puzzle
khelpcenter4_4.14.2-2_amd64.deb help center
khmerconverter_1.4-1_all.deb converts between legacy Khmer encodings and Unicode
kicad-common_0.20140622+bzr4027-3_all.deb Common files used by kicad
kicad-doc-de_0.20140622+bzr4027-3_all.deb Kicad help files (German)
Advertisement
Advertisement