kaptain_0.73-2_amd64.deb


Advertisement

Description

kaptain - universal graphical front-end for command line programs

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: kaptain
Package version: 0.73
Package release: 2
Package architecture: amd64
Package type: deb
Installed size: 636 B
Download size: 323.20 KB
Official Mirror: ftp.br.debian.org
Kaptain is a universal graphical front-end (Qt) based on context-free grammars. The program reads a file containing grammatical rules for generating text. It builds a dialog from the grammar and generates the text according to the user's settings.

Alternatives

    Download

    Binary package: kaptain_0.73-2_amd64.deb
    Source package: kaptain

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install kaptain deb package:
      # sudo apt-get install kaptain

    Files

    • /usr/bin/kaptain
    • /usr/share/doc-base/kaptain
    • /usr/share/doc/kaptain/changelog.Debian.gz
    • /usr/share/doc/kaptain/changelog.gz
    • /usr/share/doc/kaptain/copyright
    • /usr/share/doc/kaptain/examples/arping.kaptn
    • /usr/share/doc/kaptain/examples/budget.kaptn
    • /usr/share/doc/kaptain/examples/crypt.kaptn
    • /usr/share/doc/kaptain/examples/curl.kaptn.gz
    • /usr/share/doc/kaptain/examples/dia2code.kaptn
    • /usr/share/doc/kaptain/examples/emboss.tgz
    • /usr/share/doc/kaptain/examples/enscript.kaptn.gz
    • /usr/share/doc/kaptain/examples/find.kaptn
    • /usr/share/doc/kaptain/examples/finger.kaptn
    • /usr/share/doc/kaptain/examples/grep.kaptn
    • /usr/share/doc/kaptain/examples/indent.kaptn.gz
    • /usr/share/doc/kaptain/examples/lameGUI.kaptn.gz
    • /usr/share/doc/kaptain/examples/ls.kaptn
    • /usr/share/doc/kaptain/examples/mpage.kaptn.gz
    • /usr/share/doc/kaptain/examples/nslookup.kaptn
    • /usr/share/doc/kaptain/examples/open.kaptn
    • /usr/share/doc/kaptain/examples/ping.kaptn
    • /usr/share/doc/kaptain/examples/povray.kaptn
    • /usr/share/doc/kaptain/examples/procmail.kaptn.gz
    • /usr/share/doc/kaptain/examples/puf.tgz
    • /usr/share/doc/kaptain/examples/search.kaptn
    • /usr/share/doc/kaptain/examples/tar.kaptn
    • /usr/share/doc/kaptain/examples/weblint.kaptn
    • /usr/share/doc/kaptain/examples/wget.kaptn
    • /usr/share/doc/kaptain/examples/whois.kaptn
    • /usr/share/doc/kaptain/examples/zangband.kaptn
    • /usr/share/doc/kaptain/manual/crypt.gif
    • /usr/share/doc/kaptain/manual/database.tgz
    • /usr/share/doc/kaptain/manual/fig1.png
    • /usr/share/doc/kaptain/manual/kaptain.html
    • /usr/share/doc/kaptain/manual/record.gif
    • /usr/share/doc/kaptain/manual/tar.gif
    • /usr/share/doc/kaptain/tutorial/index.html
    • /usr/share/doc/kaptain/tutorial/specials.html
    • /usr/share/doc/kaptain/tutorial/images/enscript1.gif
    • /usr/share/doc/kaptain/tutorial/images/enscript1_thumbnail.jpg
    • /usr/share/doc/kaptain/tutorial/images/enscript3.gif
    • /usr/share/doc/kaptain/tutorial/images/mpage.gif
    • /usr/share/doc/kaptain/tutorial/images/playmessage.gif
    • /usr/share/doc/kaptain/tutorial/images/voxpak.gif
    • /usr/share/doc/kaptain/tutorial/text/mpage.kaptn
    • /usr/share/doc/kaptain/tutorial/text/playmessage
    • /usr/share/doc/kaptain/tutorial/text/voxpak
    • /usr/share/info/kaptain.info.gz
    • /usr/share/man/man1/kaptain.1.gz

    Changelog

    2014-10-24 - Tobias Quathamer <toddy@debian.org> kaptain (1:0.73-2) unstable; urgency=medium * Use debhelper v9 * Remove obsolete hardening-wrapper from Build-Depends * Add VCS information to debian/control * Use DEP-5 copyright format * Remove Depends: on dpkg (>= 1.15.4) | install-info * Update to Standards-Version 3.9.6

    2011-02-28 - Tobias Quathamer <toddy@debian.org> kaptain (1:0.73-1) unstable; urgency=low * New upstream version - Source converted to use Qt4. Closes: #604492 - Adapt Build-Depends for Qt4 * Depend on dpkg (>= 1.15.4) | install-info for partial upgrades from lenny * Switch to debhelper v8 * Use dpkg source format 3.0 (quilt) * Update to Standards-Version 3.9.1, no changes needed

    2009-02-18 - Tobias Quathamer <toddy@debian.org> kaptain (1:0.72-3) unstable; urgency=low * Change maintainer name * debian/copyright: update year, use "©" instead of "(C)", and make link to GPL-2 explicit * Update to Standards-Version 3.8.0, no changes needed * Switch to debhelper v7 and reduce debian/rules * Add ${misc:Depends} to debian/control to fix a Lintian warning

    2008-05-30 - Tobias Toedter <toddy@debian.org> kaptain (1:0.72-2) unstable; urgency=low * Use hardening-wrapper on m68k as well * Remove DM upload rights * Change maintainer e-mail address

    2008-03-10 - Tobias Toedter <t.toedter@gmx.net> kaptain (1:0.72-1) unstable; urgency=low * New upstream version. Closes: #374191 * New maintainer, using DM upload. Closes: #467000 * Acknowledge NMUs: - Thanks to LaMont Jones (1.1) - Thanks to Luk Claes (1.2, 1.3) - Thanks to Steinar H. Gunderson (1.4, 1.5). Closes: #375262, #375354 - Thanks to James Vega (1.6). Closes: #470189 * Update debhelper compatibility level to 5 * Fix formatting in debian/changelog * Add homepage to debian/control * Rephrase short description * Add watch file * Rewrite debian/copyright and convert to UTF-8 * Convert debian/kaptain.doc-base to UTF-8, update Section and current file path * Remove unnecessary Build-Depends - Remove libqt3-compat-headers. Closes: #464472 * Use "-Wl,--as-needed" in LD_FLAGS to trim down list of unneeded library dependencies * Add autotools-dev to Build-Depends * Add hardening-wrapper to Build-Depends and use it on every architecture except m68k * Remove Replaces: captain and Conflicts: captain, as that package is not available in Debian since at least sarge * Remove usr/sbin from debian/dirs * Remove TODO from debian/docs, it's an empty file. Closes: #387733 * Remove debian/README.Debian, the information given is no longer true * Rewrite debian/rules * Install example scripts in correct location * Install tutorial * Do not install upstream's changelog, as it is an empty file * Correct typos in manpage. Thanks to A. Costa. Closes: #394814 * Fix FTBFS with GCC 4.3: missing #includes. Thanks to Martin Michlmayr for the patch. Closes: #417267 * Fix FTBFS on slow architectures due to timestamp issues. Thanks to Roman Zippel for the patch. Closes: #394575 * After all those changes, update Standards-Version to 3.7.3

    2008-03-09 - James Vega <jamessan@debian.org> kaptain (1:0.71-1.6) unstable; urgency=low * Non-maintainer upload. * Explicitly include required headers to fix FTBFS with gcc-4.3. (Closes: #417267) * Fix the path for upstream's documentation so that it's actually installed in the Debian package. (Closes: #387733) * Build without libqt3-compat-headers. (Closes: #464472)

    Advertisement
    Advertisement