js2-mode_0~20140114-1_all.deb


Advertisement

Description

js2-mode - Emacs mode for editing Javascript programs

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: js2-mode
Package version: 0~20140114
Package release: 1
Package architecture: all
Package type: deb
Installed size: 516 B
Download size: 90.11 KB
Official Mirror: ftp.br.debian.org
This JavaScript editing mode supports: - the full JavaScript language through version 1.7 - support for most Rhino and SpiderMonkey extensions from 1.5 to 1.7 - accurate syntax highlighting using a recursive-descent parser - syntax-error and strict-mode warning reporting - "bouncing" line indentation to choose among alternate indentation points - smart line-wrapping within comments and strings - code folding: - show some or all function bodies as {...} - show some or all block comments as /*...*/ - context-sensitive menu bar and popup menus - code browsing using the imenu' package - typing helpers (e.g. inserting matching braces/parens) - many customization options

Alternatives

    Download

    Source package: js2-mode

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install js2-mode deb package:
      # sudo apt-get install js2-mode

    Files

    • /etc/emacs/site-start.d/50js2-mode.el
    • /usr/lib/emacsen-common/packages/install/js2-mode
    • /usr/lib/emacsen-common/packages/remove/js2-mode
    • /usr/share/doc/js2-mode/changelog.Debian.gz
    • /usr/share/doc/js2-mode/copyright
    • /usr/share/emacs/site-lisp/js2-mode/js2-imenu-extras.el
    • /usr/share/emacs/site-lisp/js2-mode/js2-mode.el

    Changelog

    2014-05-08 - Vincent Bernat <bernat@debian.org> js2-mode (0~20140114-1) unstable; urgency=medium * New upstream release. + Use fork from mooz. + Update homepage in debian/control. + Remove patch for local variables, not needed anymore. * Depends on emacs-common >= 2.0.7. This should fix any post installation problem. * Only works with Emacs 24 since it needs prog-mode. Closes: #744905. * Bump Standards-Version to 3.9.5.

    2013-11-09 - Vincent Bernat <bernat@debian.org> js2-mode (0~20120726-4) unstable; urgency=low * Fix Emacs startup file. Closes: #728693. Patch from Michal Sojka.

    2013-07-28 - Vincent Bernat <bernat@debian.org> js2-mode (0~20120726-3) unstable; urgency=low * Make comment-start buffer local. Closes: #714228.

    2013-07-22 - Vincent Bernat <bernat@debian.org> js2-mode (0~20120726-2) unstable; urgency=low * Don't build for emacs21. Closes: #717530.

    2013-07-18 - Vincent Bernat <bernat@debian.org> js2-mode (0~20120726-1) unstable; urgency=low * New upstream version. + We keep the original upstream. Closes: #632757. * Update debian/copyright. * Remove debian/watch: we don't have version to watch anymore. * Drop safe-local patch: applied upstream. * Bump Standards-Version. * Update Vcs-* fields in debian/control. * Update startup file.

    2012-05-05 - Vincent Bernat <bernat@debian.org> js2-mode (0~20090723b-2) unstable; urgency=low * Add a link to js2.el in emacs23/site-lisp/js2-mode to be able to access source code from help. Closes: #671576. * Bump Standards-Version.

    2011-05-18 - Vincent Bernat <bernat@debian.org> js2-mode (0~20090723b-1) unstable; urgency=low * Apply a patch from Dmitry Gutov to make some local variables safe. Closes: #607110. * Switch to 3.0 quilt format. * Acknowledge NMU from Hilko Bengen. * Bump Standards-Version to 3.9.2.

    2010-06-10 - Hilko Bengen <bengen@debian.org> js2-mode (0~20090723b-0.1) unstable; urgency=low * Non-maintainer upload * New upstream version (Closes: #583797) * Fixed watch file * Bumped Standards-Version as suggested by Lintian * Added ${misc:Depends} as suggested by Lintian

    2008-08-16 - Vincent Bernat <bernat@debian.org> js2-mode (0~20080616a-1) unstable; urgency=low * Initial release (Closes: #495213)

    Advertisement
    Advertisement