john_1.8.0-2_amd64.deb


Advertisement

Description

john - active password cracking tool

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: john
Package version: 1.8.0
Package release: 2
Package architecture: amd64
Package type: deb
Installed size: 448 B
Download size: 194.85 KB
Official Mirror: ftp.br.debian.org
John the Ripper is a tool designed to help systems administrators to find weak (easy to guess or crack through brute force) passwords, and even automatically mail users warning them about it, if it is desired. Besides several crypt(3) password hash types most commonly found on various Unix flavors, supported out of the box are Kerberos AFS and Windows NT/2000/XP/2003 LM hashes, plus several more with contributed patches.

Alternatives

    Download

    Binary package: john_1.8.0-2_amd64.deb
    Source package: john

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install john deb package:
      # sudo apt-get install john

    Files

    • /etc/cron.d/john
    • /etc/john/john-mail.conf
    • /etc/john/john-mail.msg
    • /etc/john/john.conf
    • /usr/sbin/john
    • /usr/sbin/mailer
    • /usr/sbin/unafs
    • /usr/sbin/unique
    • /usr/sbin/unshadow
    • /usr/share/doc/john/CONFIG.gz
    • /usr/share/doc/john/CREDITS
    • /usr/share/doc/john/EXAMPLES.gz
    • /usr/share/doc/john/EXTERNAL
    • /usr/share/doc/john/FAQ.gz
    • /usr/share/doc/john/MODES.gz
    • /usr/share/doc/john/OPTIONS.gz
    • /usr/share/doc/john/README.Debian
    • /usr/share/doc/john/README.gz
    • /usr/share/doc/john/RULES.gz
    • /usr/share/doc/john/changelog.Debian.gz
    • /usr/share/doc/john/changelog.gz
    • /usr/share/doc/john/copyright
    • /usr/share/john/cronjob
    • /usr/share/man/man8/john.8.gz
    • /usr/share/man/man8/mailer.8.gz
    • /usr/share/man/man8/unafs.8.gz
    • /usr/share/man/man8/unique.8.gz
    • /usr/share/man/man8/unshadow.8.gz

    Changelog

    2014-03-19 - Julián Moreno Patiño <julian@debian.org> john (1.8.0-2) unstable; urgency=medium * Add myself to Uploaders. Thanks to Ruben Molina for the permission. * Add missing hardening fortify functions export. * Bump Standards-Version to 3.9.5. (no changes). * Add support to check upstream gpg signature. * Add myself to debian copyright.

    2012-11-26 - Ruben Molina <rmolina@udea.edu.co> john (1.8.0-1) unstable; urgency=low * New upstream release (Closes: #670582) * Fixing $PIDDIR logic in crontab (Closes: #660822). Thanks Phil. * Reefreshing patches * Updating to Standards-Version 3.9.4 (no changes) * Updating install scripts * Updating debian/copyright for machine-readable format, version 1.0 * Updating compatibility level to 9 * Adding versioned Build-Depends on dpkg-dev (>= 1.16.1~)

    2011-07-04 - Ruben Molina <rmolina@udea.edu.co> john (1.7.8-1) unstable; urgency=low * New upstream release (Fix: CVE-2011-2483, LP: #805258) * Fix john's manpage for debian file locations (Closes: #592401)

    2011-06-15 - Ruben Molina <rmolina@udea.edu.co> john (1.7.7-2) unstable; urgency=low * Forcing the 'generic' target for hurd * Adding new escaping rules in order to solve FTBFS in armel, mips, mipsel, and s390 (all using the 'generic' target) * Updating copyright dates to 2011 * Removing unused patch: single-have_words-fix-1.diff

    2011-06-07 - Ruben Molina <rmolina@udea.edu.co> john (1.7.7-1) unstable; urgency=low * New upstream release (Closes: #585464, #563698, LP: #586544) * Standards-Version bumped to 3.9.2 (no changes) * Fully reworked debian/rules (Closes: #583367) + New targets: *-kfreebsd, ia64, ppc* + Generate optimized binaries (Closes: #629517) + 64bits (amd64, kfreebsd-amd64) + 32bits + sse2 (i386, kfreebsd-i386) + Use CPU fallbacks (i386, freebsd-i386): sse2 → mmx → any Delete debian/extra/john → no longer needed with CPU fallbacks * Remove third-party patches (??-add_*.patches), making easier to test new rules. Patches can be re-added later as needed. * Remove some patches. Testing if they are still needed. Some regresions are expectable: #420980, #460697, #415738. Patches will be re-added as needed. * Fix a spelling-error-in-manpage for john.8 * Update debian/watch in order to exclude jumbo patches.

    Advertisement
    Advertisement