jekyll_2.2.0+dfsg-2_all.deb


Advertisement

Description

jekyll - Simple, blog aware, static site generator

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: jekyll
Package version: 2.2.0+dfsg
Package release: 2
Package architecture: all
Package type: deb
Installed size: 317 B
Download size: 71.02 KB
Official Mirror: ftp.br.debian.org
Jekyll is a simple, blog aware, static site generator. It takes a template directory (representing the raw form of a website), runs it through Textile or Markdown and Liquid converters, and spits out a complete, static website suitable for serving with Apache or your favorite web server. This is also the engine behind GitHub Pages(http://pages.github.com), which you can use to host your project's page or blog right here from GitHub.

Alternatives

    Download

    Source package: jekyll

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install jekyll deb package:
      # sudo apt-get install jekyll

    Files

    • /usr/bin/jekyll
    • /usr/lib/ruby/vendor_ruby/jekyll.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/cleaner.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/collection.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/command.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/configuration.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/converter.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/convertible.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/deprecator.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/document.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/draft.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/entry_filter.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/errors.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/excerpt.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/filters.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/frontmatter_defaults.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/generator.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/layout.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/layout_reader.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/liquid_extensions.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/log_adapter.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/mime.types
    • /usr/lib/ruby/vendor_ruby/jekyll/page.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/plugin.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/plugin_manager.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/post.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/publisher.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/related_posts.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/renderer.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/site.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/static_file.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/stevenson.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/url.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/utils.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/version.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/commands/build.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/commands/docs.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/commands/doctor.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/commands/new.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/commands/serve.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/converters/identity.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/converters/markdown.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/converters/textile.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/converters/markdown/kramdown_parser.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/converters/markdown/maruku_parser.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/converters/markdown/rdiscount_parser.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/converters/markdown/redcarpet_parser.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/tags/highlight.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/tags/include.rb
    • /usr/lib/ruby/vendor_ruby/jekyll/tags/post_url.rb
    • /usr/lib/ruby/vendor_ruby/site_template/_config.yml
    • /usr/lib/ruby/vendor_ruby/site_template/about.md
    • /usr/lib/ruby/vendor_ruby/site_template/feed.xml
    • /usr/lib/ruby/vendor_ruby/site_template/index.html
    • /usr/lib/ruby/vendor_ruby/site_template/_includes/footer.html
    • /usr/lib/ruby/vendor_ruby/site_template/_includes/head.html
    • /usr/lib/ruby/vendor_ruby/site_template/_includes/header.html
    • /usr/lib/ruby/vendor_ruby/site_template/_layouts/default.html
    • /usr/lib/ruby/vendor_ruby/site_template/_layouts/page.html
    • /usr/lib/ruby/vendor_ruby/site_template/_layouts/post.html
    • /usr/lib/ruby/vendor_ruby/site_template/_posts/0000-00-00-welcome-to-jekyll.markdown.erb
    • /usr/lib/ruby/vendor_ruby/site_template/css/main.css
    • /usr/share/doc/jekyll/README.Debian
    • /usr/share/doc/jekyll/changelog.Debian.gz
    • /usr/share/doc/jekyll/changelog.gz
    • /usr/share/doc/jekyll/copyright
    • /usr/share/man/man1/jekyll.1.gz
    • /usr/share/rubygems-integration/all/specifications/jekyll-2.2.0.gemspec

    Changelog

    2014-11-09 - Christian Hofstaedtler <zeha@debian.org> jekyll (2.2.0+dfsg-2) unstable; urgency=medium * Team upload. * Update Build-Depends ruby-activesupport-3.2 to ruby-activesupport, which is the 4.0 version that we're going to ship in jessie. Thanks to Lucas Nussbaum <lucas@lucas-nussbaum.net> (Closes: #768697) * Build-Depend on ruby-test-unit to fix test runner failure

    2014-07-30 - Youhei SASAKI <uwabami@gfd-dennou.org> jekyll (2.2.0+dfsg-1) unstable; urgency=medium * Imported Upstream version 2.2.0+dfsg * Refresh patches * Update Depends/Build-Depends + add ruby-jekyll-{paginate,gist,watch}

    2014-06-03 - Youhei SASAKI <uwabami@gfd-dennou.org> jekyll (2.0.3+dfsg-1) unstable; urgency=low [Harlan Lieberman-Berg] * New upstream version. * Add new files to d/copyright. * New versions of jekyll don't use modernizr. * Install the upstream changelog. * Refresh patches for newer upstream version. [Youhei SASAKI] * Prepare d/changelog for upload * Disable some tests during build process * Update d/control: Refresh Depends and Build Depends + add ruby-rouge * Update d/rules: + add auto_build/auto_clean rules + add pre/post hook for test: create symlink for test + add original test files provided Gem * Add patches: + Remove newline for Maruku(=> 0.7.1), coffee-script + Fix relative LOAD_PATH in test_redcloth + Update test_rdiscount for newer RDiscount >= 2.0

    2014-05-05 - Dominique Dumont <dod@debian.org> jekyll (1.5.1+dfsg1-2) unstable; urgency=medium [ Youhei SASAKI ] * Refresh patches, Drop obsolete patch (Closes: #746607) [ Dominique Dumont ] * control: added Depends on ruby-kramdows, ruby-rdiscount, ruby-redcloth (Closes: #712952) * forgot in last version: (Closes: #712954) * remove convenience copy of libjs-modernizr: * copyright file exludes libjs-moderniz.min.js + depends on libjs-modernizr + added a symlink using Debian's libjs-moderniz.min.js * watch file mangles version to add dfsg * updated copyright * added README.Debian

    2014-04-29 - Dominique Dumont <dod@debian.org> jekyll (1.5.1-1) unstable; urgency=medium [ Cédric Boutillier ] * debian/control: remove obsolete DM-Upload-Allowed flag * use canonical URI in Vcs-* fields * debian/copyright: use DEP5 copyright-format/1.0 official URL for Format field [ Dominique Dumont ] * Imported Upstream version 1.5.1 * control: * updated with cme, removed bogus dep on ruby-marku (is maruku) * actual dep is on version 3.2 of ruby-activesupport * updated patch headers for DEP-3 * refreshed patch * removed dependency on launchy and use xdg-open instead * removed debian/jekyll.doc (README.textile is gone) * debian/ruby-tests.rake: disable failing (well, all) tests

    2012-05-08 - Youhei SASAKI <uwabami@gfd-dennou.org> jekyll (0.11.2-1) unstable; urgency=low * Initial release (Closes: #672509)

    Advertisement
    Advertisement