jardiff_0.2-4_all.deb


Advertisement

Description

jardiff - tool to visualise API differences between two JAR files

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name jardiff
Package version 0.2
Package release 4
Package architecture all
Package type deb
Installed size 94 B
Download size 50.30 KB
Official Mirror ftp.br.debian.org
Jardiff is a tool to help visualise API differences between two different
versions of a project.
Jardiff takes two jar files and outputs all the public API changes as
xml, html or plain text.
It can be used from command line or via an Apache Ant task.
It requires Java >= 1.4 to run.

Alternatives

Package Version Architecture Repository
jardiff_0.2-4_all.deb 0.2 all Debian Main
jardiff - - -

Requires

Name Value
default-jre-headless -
java-wrappers -
java2-runtime-headless -
libasm4-java -
libcommons-cli-java -

Download

Type URL
Binary Package jardiff_0.2-4_all.deb
Source Package jardiff

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install jardiff deb package:
    # sudo apt-get install jardiff

Files

Path
/usr/bin/jardiff
/usr/share/doc/jardiff/changelog.Debian.gz
/usr/share/doc/jardiff/copyright
/usr/share/java/jardiff.jar
/usr/share/man/man1/jardiff.1.gz

Changelog

2014-09-15 - Emmanuel Bourg <ebourg@apache.org>
jardiff (0.2-4) unstable; urgency=medium
* Team upload.
* Generate Java 5 compatible bytecode
* debian/control:
- Standards-Version updated to 3.9.5 (no changes)
- Depend on libasm4-java instead of libasm3-java
- Use canonical URLs for the Vcs-* fields
* Switch to debhelper level 9
* debian/copyright: Updated to the Copyright Format 1.0
2010-06-14 - Onkar Shinde <onkarshinde@ubuntu.com>
jardiff (0.2-3) unstable; urgency=low
* Team upload.
* asm2 -> asm3 migration
* Convert to 3.0 source format.
* Update standards version to 3.8.4.
2009-09-26 - Damien Raude-Morvan <drazzib@debian.org>
jardiff (0.2-2) unstable; urgency=low
* Use default-jdk:
- Build-Depend on default-jdk instead of java-gcj-compat-dev
- Depends on default-jre-headless
- Use default-java from default-jdk as JAVA_HOME
* Bump Standards-Version to 3.8.3:
- Add ${misc:Depends} in Depends field for debhelper
- Move to "java" section of archive
* Set Maintainer field to Debian Java Team
* Update Vcs-* fields
* Add myself as Uploaders
* Update my email address
2008-10-13 - Damien Raude-Morvan <drazzib@drazzib.com>
jardiff (0.2-1) unstable; urgency=low
* Initial release (Closes: #495998)

See Also

Package Description
jargon-text_4.4.7-4_all.deb definitive compendium of hacker slang
jargon_4.0.0-5.1_all.deb the definitive compendium of hacker slang
jarwrapper_0.48+deb8u1_all.deb Run executable Java .jar files
jasmin-sable_2.4.0-4_all.deb Java class (.class) file assembler
java-common_0.52_all.deb Base of all Java packages
java-propose-classpath_0.48+deb8u1_all.deb Helper script to suggest a classpath for jar files
java-wrappers_0.1.28_all.deb wrappers for java executables
java2html_0.9.2-4_amd64.deb Highlight Java and C++ sources for WWW presentation
java3ds-fileloader_1.2+dfsg-1_all.deb Java3D 3DS File Loader
javacc-doc_5.0-5_all.deb Documentation for the JavaCC Parser Generator
javacc_5.0-5_all.deb Parser generator for use with Java
javahelp2-doc_2.0.05.ds1-7_all.deb Java based help system - contains Javadoc API documentation
javahelp2_2.0.05.ds1-7_all.deb Java based help system
javahelper_0.48+deb8u1_all.deb Helper scripts for packaging Java programs
javamorph_0.0.20100201-1.3_all.deb Java morphing film-make program for pixel picture-input
Advertisement
Advertisement