ivy_2.3.0-4_all.deb


Advertisement

Description

ivy - agile dependency manager

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name ivy
Package version 2.3.0
Package release 4
Package architecture all
Package type deb
Installed size 1.25 KB
Download size 1.07 MB
Official Mirror ftp.br.debian.org
Ivy is a very powerful dependency manager oriented toward Java
dependency management, even though it could be used to manage
dependencies of any kind.

Alternatives

Package Version Architecture Repository
ivy_2.3.0-4_all.deb 2.3.0 all Debian Main
ivy - - -

Requires

Name Value
default-jre-headless -
java2-runtime-headless -

Download

Type URL
Binary Package ivy_2.3.0-4_all.deb
Source Package ivy

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ivy deb package:
    # sudo apt-get install ivy

Files

Path
/usr/share/doc/ivy/README
/usr/share/doc/ivy/README.Debian
/usr/share/doc/ivy/changelog.Debian.gz
/usr/share/doc/ivy/changelog.gz
/usr/share/doc/ivy/copyright
/usr/share/java/ivy-2.3.0.jar
/usr/share/java/ivy.jar
/usr/share/maven-repo/org/apache/ivy/ivy/2.3.0/ivy-2.3.0.jar
/usr/share/maven-repo/org/apache/ivy/ivy/2.3.0/ivy-2.3.0.pom
/usr/share/maven-repo/org/apache/ivy/ivy/debian/ivy-debian.jar
/usr/share/maven-repo/org/apache/ivy/ivy/debian/ivy-debian.pom

Changelog

2014-12-24 - Emmanuel Bourg <ebourg@apache.org>
ivy (2.3.0-4) unstable; urgency=medium
* Team upload.
* Added the missing pom.template file in ivy.jar (Closes: #762108)
* Standards-Version updated to 3.9.6 (no changes)
2013-09-09 - Emmanuel Bourg <ebourg@apache.org>
ivy (2.3.0-3) unstable; urgency=low
* Team upload.
* Use canonical URLs for the Vcs-* fields
* Switched the dependency on Commons Collections to 3.x
2013-05-15 - tony mancill <tmancill@debian.org>
ivy (2.3.0-2) unstable; urgency=low
* Team upload.
* Upload to unstable.
2013-03-31 - Miguel Landaeta <miguel@miguel.cc>
ivy (2.3.0-1) experimental; urgency=low
[ Miguel Landaeta ]
* New upstream release. 
* Bump Standards-Version to 3.9.4. No changes were required.
* Fix minor lintian warning regarding package description.
[ Damien Raude-Morvan ]
* d/maven.rules: Replace commons-vfs by commons-vfs2,
use 3.x version of commons-httpclient and add mapping
for bouncycastle.
2011-09-11 - Damien Raude-Morvan <drazzib@debian.org>
ivy (2.2.0-2) unstable; urgency=low
* Team upload.
* Fix for commons-vfs2.
* Bump Standards-Version to 3.9.2: no changes needed.
2011-02-06 - Miguel Landaeta <miguel@miguel.cc>
ivy (2.2.0-1) unstable; urgency=low
* New upstream release.
* Update pom.xml to the latest version.
* Add Build-Depends and Suggests on libbcprov-java and libbcpg-java.
* Add mh_clean call in clean target.
* Bump Standards-Version to 3.9.1. No changes were required.
* Add myself to Uploaders.
2010-02-11 - Varun Hiremath <varun@debian.org>
ivy (2.1.0-1) unstable; urgency=low
[ Thierry Carrez ]
* debian/build.xml: Build java2-code to match runtime dependency
[ Varun Hiremath ]
* New upstream release
* Update pom.xml to the latest version
* (Build)-Depend on default-jdk-doc (Closes: #567274)
* Switch to source format 3.0
2009-10-01 - Varun Hiremath <varun@debian.org>
ivy (2.1.0~rc2-3) unstable; urgency=low
* Update pom.xml file to latest 2.1.0~rc2 version (Closes: #548310)
* Include the MANIFEST.MF file in the jar (Closes: #548311)
* Add debian/README.Debian listing reasons for not creating symlink to
ivy.jar in ant's lib directory and solutions (Closes: #547969)
* Switch to default-jdk
* Bump Standards-Version to 3.8.3 (no changes)
2009-08-09 - Torsten Werner <twerner@debian.org>
ivy (2.1.0~rc2-2) unstable; urgency=low
* Upload to unstable.
2009-07-26 - Ludovic Claude <ludovic.claude@laposte.net>
ivy (2.1.0~rc2-1) experimental; urgency=low
* New upstream version
* Add myself to Uploaders
* Bump Standards-Version to 3.8.2
* Change section to java
* Add the Maven POM to the package
* Add a Build-Depends-Indep dependency on maven-repo-helper
* Depend on the headless Java runtimes as Ivy does not use any GUI
or graphics most of the time
* move default-jre | java2-runtime to Suggests for the rare case
when Swing is used (to ask the user for credentials when they
are missing)
* Move api documentation to /usr/share/doc/ivy/api

See Also

Package Description
iw_3.17-1_amd64.deb tool for configuring Linux wireless devices
iwatch_0.2.2-3_all.deb realtime filesystem monitoring program using inotify
iwidgets4-doc_4.0.1-6_all.deb [incr Widgets] Tk-based widget collection - man pages
iwidgets4_4.0.1-6_all.deb [incr Widgets] Tk-based widget collection - run-time files
iwyu_3.4-1_amd64.deb Analyze #includes in C and C++ source files
jaaa_0.8.4-1_amd64.deb audio signal generator and spectrum analyser
jabber-muc_0.8-4_amd64.deb Multi User Conference component for the Jabber IM server
jabber-querybot_0.1.0-1_all.deb Modular xmpp/jabber bot
jablicator_1.0.1_all.deb Share a set of package choices
jabref-plugin-oo_2.10+ds-3_all.deb LibreOffice plugin for JabRef (transitional dummy package)
jabref_2.10+ds-3_all.deb graphical frontend to manage BibTeX databases
jacal_1b9-5_all.deb Interactive symbolic math system
jack-capture_0.9.71-1_amd64.deb program for recording soundfiles with jack
jack-keyboard_2.7.1-1_amd64.deb Virtual MIDI keyboard for JACK MIDI
jack-midi-clock_0.4.1-1_amd64.deb JACK client that sends MIDI beat clock pulses
Advertisement
Advertisement