irssi-plugin-otr - Off-the-Record Messaging Plugin for Irssi

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: irssi-plugin-otr
Package version: 1.0.0
Package release: 1+b2
Package architecture: amd64
Package type: deb
Installed size: 103 B
Download size: 22.46 KB
Official Mirror:
Off-the-Record (OTR) Messaging Plugin for the Irssi Chat Client This plugin adds Off-the-Record messaging support for the irssi IRC client. Although primarily designed for use with the bitlbee IRC2IM gateway, it works within any query window, provided that the conversation partner's IRC client supports OTR. OTR allows you to have private conversations over IM by providing: - Encryption - No one else can read your instant messages. - Authentication - You are assured the correspondent is who you think it is. - Deniability - The messages you send do _not_ have digital signatures that are checkable by a third party. Anyone can forge messages after a conversation to make them look like they came from you. However, _during_ a conversation, your correspondent is assured the messages he sees are authentic and unmodified. - Perfect forward secrecy - If you lose control of your private keys, no previous conversation is compromised.



    Source package: irssi-plugin-otr

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install irssi-plugin-otr deb package:
      # sudo apt-get install irssi-plugin-otr


    • /usr/lib/irssi/modules/
    • /usr/share/doc/irssi-plugin-otr/changelog.Debian.amd64.gz
    • /usr/share/doc/irssi-plugin-otr/changelog.Debian.gz
    • /usr/share/doc/irssi-plugin-otr/changelog.gz
    • /usr/share/doc/irssi-plugin-otr/copyright
    • /usr/share/irssi/help/otr


    2014-02-22 - Antoine Beaupré <> irssi-plugin-otr (1.0.0-1) unstable; urgency=medium * Put the package under the umbrella of the Debian OTR Team. Huge thanks to David Spreen <> for having maintained this package for many years! (Closes: #738930). * Package new 1.0.0 upstream version (Closes: #739106). * Get rid of patch merged upstream (gmodule-nolink.patch). * Update to standards 3.9.5, no change. * Use upstream tags to build tarball. * Ship updated watch file. * Keep build verbose to remove W-compiler-flags-hidden warnings.

    2013-05-10 - Antoine Beaupré <> irssi-plugin-otr (1.0.0~alpha2-1) unstable; urgency=low * Ship a second binary package, with debugging symbols. * New upstream patch: gmodule-nolink.patch to remove extra linking. * Upload to unstable now that libotr5 is usable there. * Restore the libotr5-4.0.0-2.1 dependency to make sure this is usuable.

    2013-05-10 - Antoine Beaupré <> irssi-plugin-otr (1.0.0~alpha2-1~exp0) experimental; urgency=low * New upstream release. * Remove destdir_support.patch, accepted upstream. * Remove python build dependency. * Use dh-autoreconf instead of manual bootstrap code. * Add missing dependencies. * Upload to experimental (Closes: #695150, #569506, #576696, #499229). * Add myself to maintainers. * Change dependency on libotr5 so we don't have to wait for the experimental release to build. We still upload to experimental to avoid shipping a broken version in sid. Once libotr5-4.0.0-2.1 hits unstable, this can be uploaded to unstable too.

    2013-05-08 - Antoine Beaupré <> irssi-plugin-otr (1.0.0~alpha1-0.1) experimental; urgency=low * Non-maintainer upload. * Upload the revamped version to experimental (Closes: #695150). * Remove support for xchat. * Fix information leak in /me (Closes: #569506) * Fix numerous segfaults (Closes: #576696, #499229) * Remove patch/01_remove_buildfor_variable.patch - irrelevant * Change control and copyright files to mention new upstream. * Remove old copyright notices refering to missing code. * Update to standards 3.9.4.

    2009-08-09 - David Spreen <> irssi-plugin-otr (0.3-2) unstable; urgency=low * Rebuild. Irssi patch for Debian Bug 531357 broke old irssi-otr. Fixed by rebuilding against 0.8.14. (Closes: #533655) * debian/control: Depend on irssi >= 0.8.14.

    2009-02-16 - David Spreen <> irssi-plugin-otr (0.3-1) unstable; urgency=low * New upstream release. * First upload to unstable after 0.2. Introduces xchat-otr to unstable.

    2009-02-06 - David Spreen <> irssi-plugin-otr (0.2+20090206-1) experimental; urgency=low * New git snapshot. * debian/patches/01_fix_irssisbar_h.patch: Removed (fixed upstream). * debian/patches/02_remove_irssi_reference_from_keygen.patch: Removed (patch adopted by upstream). * debian/patches/01_remove_buildfor_variable.patch: Added patch to keep building xchat and irssi targets from the same source.

    2009-01-29 - David Spreen <> irssi-plugin-otr (0.2+20090128-1) experimental; urgency=low * New git snapshot now with X-Chat support! * debian/control: Added X-Chat binary package including build-dependency on xchat-common. * debian/rules: Manually installing README.xchat * debian/*.install: Added install files for irssi and xchat plugin packages. * debian/patch/01_fix_irssisbar_h.patch: Fixed check for local copy of irssi statusbar headers. * debian/patch/02_remove_irssi_reference_from_keygen.patch: Removed irssi reference from keygen message.

    2009-01-19 - David Spreen <> irssi-plugin-otr (0.2+20090119-1) experimental; urgency=low * New git snapshot. (Closes: #498502, 498401) * debian/rules: Changed build-system to cdbs. * debian/control: Added cdbs build-dependency.