gwenhywfar-tools_4.12.0beta-3+b1_amd64.deb


Advertisement

Description

gwenhywfar-tools - helper applications for Gwenhywfar library

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name gwenhywfar-tools
Package version 4.12.0beta
Package release 3+b1
Package architecture amd64
Package type deb
Installed size 449 B
Download size 114.62 KB
Official Mirror ftp.br.debian.org
This package contains some helper tools provided by Gwenhywfar and
useful for applications making use of Gwenhywfar: mklistdoc,
gct-tool, xmlmerge and typemaker.
Gwenhywfar allows porting of your software to different operating
systems like Linux, *BSD, Windows etc. It also provides some often
needed modules such as configuration file handling, simple XML file
parsing, IPC etc.

Alternatives

Package Version Architecture Repository
gwenhywfar-tools_4.12.0beta-3+b1_i386.deb 4.12.0beta i386 Debian Main
gwenhywfar-tools - - -

Requires

Name Value
libc6 >= 2.14
libgwenhywfar60 >= 4.6.0beta

Replaces

Name Value
libgwenhywfar47-dev << 3.99.5beta-1

Download

Type URL
Binary Package gwenhywfar-tools_4.12.0beta-3+b1_amd64.deb
Source Package libgwenhywfar

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gwenhywfar-tools deb package:
    # sudo apt-get install gwenhywfar-tools

Files

Path
/usr/bin/gct-tool
/usr/bin/mklistdoc
/usr/bin/typemaker
/usr/bin/typemaker2
/usr/bin/xmlmerge
/usr/include/gwenhywfar4/gwenhywfar/list1.tmpl
/usr/include/gwenhywfar4/gwenhywfar/list2.tmpl
/usr/share/doc/gwenhywfar-tools/changelog.Debian.amd64.gz
/usr/share/doc/gwenhywfar-tools/changelog.Debian.gz
/usr/share/doc/gwenhywfar-tools/changelog.gz
/usr/share/doc/gwenhywfar-tools/copyright
/usr/share/lintian/overrides/gwenhywfar-tools
/usr/share/man/man1/gct-tool.1.gz
/usr/share/man/man1/xmlmerge.1.gz

Changelog

2014-08-22 - Micha Lenk <micha@debian.org>
libgwenhywfar (4.12.0beta-3) unstable; urgency=medium
* Drop upstream's CA bundle and replace it by a symlink to the CA bundle
provided by the package ca-certificates (closes: #748955). This also makes
a dependency on the package ca-certificate necessary.
* Re-enable running the unit tests after build that were disabled because of
Debian bug #503181, after I just found out that it is possible to disable
tests that require network connectivity.
2014-07-19 - Micha Lenk <micha@debian.org>
libgwenhywfar (4.12.0beta-2) experimental; urgency=medium
* Update build dependencies to use libgnutls28-dev instead of libgnutls-dev
to build against GNU-TLS library 3.2.x (closes: #753111). 
2014-04-19 - Micha Lenk <micha@debian.org>
libgwenhywfar (4.12.0beta-1) unstable; urgency=medium
* New upstream release
* Added new symbol GWEN_Url_toUiShortString to debian/libgwenhywfar60.symbols
2014-03-11 - Micha Lenk <micha@debian.org>
libgwenhywfar (4.11.0beta-1) unstable; urgency=low
* New upstream release
* Added new symbol GWEN_Gui_StdPrintf to debian/libgwenhywfar60.symbols
2014-01-26 - Micha Lenk <micha@debian.org>
libgwenhywfar (4.10.0beta-1) unstable; urgency=low
* New upstream release
* Added new symbols GWEN_PathManager_InsertRelPath and
GWEN_PluginManager_InsertRelPath to debian/libgwenhywfar60.symbols.
2014-01-08 - Micha Lenk <micha@debian.org>
libgwenhywfar (4.9.0beta-1) unstable; urgency=low
* New upstream release
* streamline debian/rules with current debhelper standards by using overrides
instead of --before and --after options.
* simplify debian/rules by only generating standard documentation instead of
full API documentation. This should reduce the documentation to essential
information.
* fix building twice in a row caused by unnoticed renaming of temporary build
directory.
* Use dh-autoreconf instead of autotools-dev to fix FTBFS on ppc64el
(closes: #734541).
* Package is compliant to Debian Policy 3.9.5 (no changes needed).
2013-10-24 - Micha Lenk <micha@debian.org>
libgwenhywfar (4.8.0beta-1) unstable; urgency=low
* New upstream release
* Updated debian/libgwenhywfar60.symbols.
* Added build-dependency on autotools-dev and use its config.sub and
config.guess during build.
2013-08-21 - Micha Lenk <micha@debian.org>
libgwenhywfar (4.7.0beta-1) unstable; urgency=low
* New upstream release
* Updated debian/libgwenhywfar60.symbols.
* Add build-dep on libgpg-error-dev to fix a build log warning about indirect
linkage to libgpg-error.so.
2013-05-26 - Micha Lenk <micha@debian.org>
libgwenhywfar (4.6.0beta-1) unstable; urgency=low
* New upstream release
* Updated debian/libgwenhywfar60.symbols.
* Add package libgwengui-cpp0 to package new upstream library.
2013-05-25 - Micha Lenk <micha@debian.org>
libgwenhywfar (4.5.0beta-2) unstable; urgency=low
* First upload to 'unstable' after the release of Debian 'wheezy'.
* Package is compliant to Debian Policy 3.9.4 (no changes needed).

See Also

Package Description
gwenview_4.14.2-1_amd64.deb image viewer
gwhois_20120626-1_all.deb generic Whois Client / Server
gworkspace-apps-wrappers_0.8.8-1.2_all.deb Application wrappers for GWorkspace
gworkspace.app_0.8.8-1.2+b1_amd64.deb GNUstep Workspace Manager
gworldclock_1.4.4-9_amd64.deb Displays time and date in specified time zones
gwsetup_6.05.1-1_amd64.deb utilities to configure and manipulate Geneweb databases
gwtp_6.05.1-1_amd64.deb web interface interacting with Geneweb databases
gwyddion-common_2.38-2_all.deb architecture-independent files for Gwyddion SPM analysis tool
gwyddion-plugins_2.38-2_amd64.deb plugins for Gwyddion SPM analysis tool
gwyddion_2.38-2_amd64.deb Scanning Probe Microscopy visualization and analysis tool
gxine_0.5.908-3.1_amd64.deb the xine video player, GTK+/Gnome user interface
gxineplugin_0.5.908-3.1_amd64.deb the xine video player, GTK+/Gnome; launcher plugin for Mozilla
gxkb_0.7.2-1_amd64.deb X11 keyboard indicator and switcher
gxmessage_2.20.0-1_amd64.deb xmessage clone based on GTK+
gxmms2_0.7.1-3_amd64.deb XMMS2 client for the GNOME desktop
Advertisement
Advertisement