gir1.2-socialweb-client-0.25_0.25.20-6_amd64.deb


Advertisement

Description

gir1.2-socialweb-client-0.25 - client library to access socialweb server (introspection files)

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name gir1.2-socialweb-client-0.25
Package version 0.25.20
Package release 6
Package architecture amd64
Package type deb
Installed size 15 B
Download size 8.18 KB
Official Mirror ftp.br.debian.org
This library allows programmatic access to information available from the
socialweb social data server.
This package contains introspection data.
It can be used by packages using the GIRepository format to generate dynamic
bindings.

Alternatives

Package Version Architecture Repository
gir1.2-socialweb-client-0.25_0.25.20-6_i386.deb 0.25.20 i386 Debian Main
gir1.2-socialweb-client-0.25 - - -

Requires

Name Value
gir1.2-glib-2.0 -
libsocialweb-client2 >= 0.25.17

Replaces

Name Value
gir1.2-socialweb-client << 0.25.20-3

Download

Type URL
Binary Package gir1.2-socialweb-client-0.25_0.25.20-6_amd64.deb
Source Package libsocialweb

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gir1.2-socialweb-client-0.25 deb package:
    # sudo apt-get install gir1.2-socialweb-client-0.25

Files

Path
/usr/lib/girepository-1.0/SocialWebClient-0.25.typelib
/usr/share/doc/gir1.2-socialweb-client-0.25/AUTHORS
/usr/share/doc/gir1.2-socialweb-client-0.25/README.gz
/usr/share/doc/gir1.2-socialweb-client-0.25/TODO
/usr/share/doc/gir1.2-socialweb-client-0.25/changelog.Debian.gz
/usr/share/doc/gir1.2-socialweb-client-0.25/copyright

Changelog

2013-06-25 - Ying-Chun Liu (PaulLiu) <paulliu@debian.org>
libsocialweb (0.25.20-6) unstable; urgency=low
* debian/control: Remove Build-Depends to libvala-0.16-dev (Closes: #714000)
* Bump Standards-Version to 3.9.4: nothing needs to be changed.
2013-06-02 - Ying-Chun Liu (PaulLiu) <paulliu@debian.org>
libsocialweb (0.25.20-5) unstable; urgency=low
* debian/control: Build-Depends on valac (>= 0.20) to fix FTBFS on amd64.
(Closes: #707404)
2013-04-10 - Ying-Chun Liu (PaulLiu) <paulliu@debian.org>
libsocialweb (0.25.20-4) unstable; urgency=low
* debian/control: modify the version constraints in Break+Replace for package
gir1.2-socialweb-client-0.25 to make upgrading from current testing
(0.25.20-2.1) to unstable (>= 0.25.20-3) smooth. (Closes: #704582)
2013-03-25 - Hideki Yamane <henrich@debian.org>
libsocialweb (0.25.20-3.2) unstable; urgency=low
* Non-maintainer upload.
* debian/patches
- add format-argument.patch
Thanks to Daniel T Chen <seven.steps@gmail.com>
2013-03-02 - Hideki Yamane <henrich@debian.org>
libsocialweb (0.25.20-3.1) unstable; urgency=medium
* Non-maintainer upload.
* debian/patches
- add CVE-2012-4511.patch: cherry picking from upstream to solve
CVE-2012-4511 as its name (Closes: #690675)
2012-09-20 - Ying-Chun Liu (PaulLiu) <paulliu@debian.org>
libsocialweb (0.25.20-3) unstable; urgency=low
* Rename gir1.2-socialweb-client to gir1.2-socialweb-client-0.25
(Closes: #680299)
* Add vala bindings for libsocialweb-client.
* Fix FTBFS. Cherry pick two patches from upstream:
- Fix namespacing of introspection annotations
c1791e96182815449781fcda6007b69cd88cf7bf.patch
- Fix underlinking detected by gold linker
e928f75ca45df8fb170230c95860f1a0fb3ae4e9.patch
2012-06-22 - Ying-Chun Liu (PaulLiu) <paulliu@debian.org>
libsocialweb (0.25.20-2) unstable; urgency=low
* MultiArch support
- Bump debhelper compat to 9
- Split -common and -service package
* Bump Standards-Version to 3.9.3
- Update debian/copyright to latest 1.0 format
2011-11-21 - Ying-Chun Liu (PaulLiu) <paulliu@debian.org>
libsocialweb (0.25.20-1) unstable; urgency=low
* New upstream release
* Fix typo in package description (Closes: #636120)
2011-07-25 - Ying-Chun Liu (PaulLiu) <paulliu@debian.org>
libsocialweb (0.25.19-1) unstable; urgency=low
* New upstream release
* Don't use hardcoded non-Linux arch list in Build-Depends. (Closes: #634708)
2011-07-02 - Ying-Chun Liu (PaulLiu) <paulliu@debian.org>
libsocialweb (0.25.18-1) unstable; urgency=low
* New upstream release

See Also

Package Description
gir1.2-soup-2.4_2.48.0-1+deb8u1_amd64.deb GObject introspection data for the libsoup HTTP library
gir1.2-spice-client-glib-2.0_0.25-1+b1_amd64.deb GObject for communicating with Spice servers (GObject-Introspection)
gir1.2-spice-client-gtk-2.0_0.25-1+b1_amd64.deb GTK2 widget for SPICE clients (GObject-Introspection)
gir1.2-spice-client-gtk-3.0_0.25-1+b1_amd64.deb GTK3 widget for SPICE clients (GObject-Introspection)
gir1.2-telepathyglib-0.12_0.24.1-1_amd64.deb GLib Telepathy connection manager library (GObject-Introspection)
gir1.2-telepathylogger-0.2_0.8.1-1_amd64.deb Telepathy logger service - introspection
gir1.2-totem-1.0_3.14.0-2_amd64.deb GObject introspection data for Totem media player
gir1.2-totem-plparser-1.0_3.10.3-1_amd64.deb GObject introspection data for the Totem Playlist Parser library
gir1.2-tracker-1.0_1.2.4-2_amd64.deb GObject introspection data for Tracker
gir1.2-udisks-2.0_2.1.3-5_amd64.deb GObject based library to access udisks2 - introspection data
gir1.2-uhm-0.0_0.3.1-1_amd64.deb HTTP web service mocking - development files
gir1.2-umockdev-1.0_0.8.8-2_amd64.deb introspection data for umockdev library
gir1.2-upowerglib-1.0_0.99.1-3.2_amd64.deb GObject introspection data for upower
gir1.2-urfkill-glib0_0.5.0-1_amd64.deb GObject introspection data for the urfkill library
gir1.2-vte-2.90_0.36.3-1_amd64.deb GObject introspection data for the VTE library
Advertisement
Advertisement