ca-certificates-java_20140324_all.deb


Advertisement

Description

ca-certificates-java - Common CA certificates (JKS keystore)

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name ca-certificates-java
Package version 20140324
Package architecture all
Package type deb
Installed size 74 B
Download size 13.38 KB
Official Mirror ftp.br.debian.org
This package uses the hooks of the ca-certificates package to update the
cacerts JKS keystore used for many java runtimes.

Alternatives

Package Version Architecture Repository
ca-certificates-java_20140324_all.deb 20140324 all Debian Main
ca-certificates-java - - -

Requires

Name Value
ca-certificates >= 20121114
java6-runtime-headless -
libnss3 >= 3.12.10-2~
openjdk-6-jre-headless >= 6b16-1.6.1-2

Download

Type URL
Binary Package ca-certificates-java_20140324_all.deb
Source Package ca-certificates-java

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ca-certificates-java deb package:
    # sudo apt-get install ca-certificates-java

Files

Path
/etc/ca-certificates/update.d/jks-keystore
/etc/default/cacerts
/usr/share/ca-certificates-java/ca-certificates-java.jar
/usr/share/doc/ca-certificates-java/NEWS.Debian.gz
/usr/share/doc/ca-certificates-java/README.Debian
/usr/share/doc/ca-certificates-java/changelog.gz
/usr/share/doc/ca-certificates-java/copyright

Changelog

2014-03-24 - Emmanuel Bourg <ebourg@apache.org>
ca-certificates-java (20140324) unstable; urgency=medium
* Team upload.
* Fixed a test failure caused by the removal of the CAcert.org root
certificate from the ca-certificates package (Closes: #741755)
* Limit the memory used by java to 64M when updating the certificates
(Closes: #576453)
* Mavenized the project
* Code refactoring
* d/control: Standards-Version updated to 3.9.5 (no changes)
* Switch to debhelper level 9
2013-08-15 - Damien Raude-Morvan <drazzib@debian.org>
ca-certificates-java (20130815) unstable; urgency=low
* Acknowledge NMU done by Don Armstrong and Andreas Beckmann.
* Fix tests to works with new cacert certificates names (Closes:
#713138).
* d/control: Use canonical value for Vcs-* fields.
* d/control: Remove deprecated DMUA flag.
* d/control: Bump Standards-Version to 3.9.4 (no changes needed).
2013-01-27 - Andreas Beckmann <anbe@debian.org>
ca-certificates-java (20121112+nmu2) unstable; urgency=medium
* Non-maintainer upload.
* postinst, jks-keystore.hook: Do not fail if nss.cfg does not (yet) exist,
i.e. if openjdk-?-jre-headless is unpacked but not yet configured.
(Closes: #694888)
* Set urgency to medium for RC bugfix.
2012-11-12 - Don Armstrong <don@debian.org>
ca-certificates-java (20121112+nmu1) unstable; urgency=low
* Non-maintainer upload
* Fix test for dpkg-query in postinst; there was an extraneous --version
here. [Probably don't even need to bother to check for dpkg-query, but
why not.] (Closes: #690204)
* Library path for softokn3pkg and nsspkg is potentially wrong if there
are multiple different paths; fix it.
* Do not run the hook if ca-certificates-java has been removed but not
purged.
* Use the new trigger support provided by ca-certificates (>=20121114).
2012-07-21 - Damien Raude-Morvan <drazzib@debian.org>
ca-certificates-java (20120721) unstable; urgency=low
* Fix jks-keystore and postinst to work on multi-arch system.
Use dpkg-query -L package:arch. (Closes: #680618).
* As libnss3-1d is a transitional package on both Debian and Ubuntu,
upgrade Depends to use libnss3.
2012-06-08 - James Page <james.page@ubuntu.com>
ca-certificates-java (20120608) unstable; urgency=low
[ James Page ]
* Switch primary JRE dependency from openjdk-6 to openjdk-7 to support
demotion of openjdk-6 to universe in Ubuntu:
- d/control, rules: Generate primary JRE dependency at build time to
allow differentiation between Ubuntu and Debian.
* Added myself to uploaders.
[ Damien Raude-Morvan ]
* Update to unstable.
* Set DMUA flag for James Page.
2012-06-03 - Damien Raude-Morvan <drazzib@debian.org>
ca-certificates-java (20120603) unstable; urgency=low
* Use javahelper as buildsystem:
- d/control: Add Build-Depends on javahelper.
- d/rules: Use jh_build to call javac.
* Create a testsuite for this package:
- Refactor UpdateCertificates code to send exceptions instead of
System.exit(1).
- New testsuite: UpdateCertificatesTest.
- d/control: Build-Depends on junit4.
- d/rules: Launch junit after build and handle "nocheck" option in
DEB_BUILD_OPTIONS.

See Also

Package Description
ca-certificates_20141019+deb8u3_all.deb Common CA certificates
cabal-debian_4.17.4-1_amd64.deb Create a debianization for a cabal package
cabal-install_1.20.0.3-1_amd64.deb command-line interface for Cabal and Hackage
cabextract_1.4-5_amd64.deb Microsoft Cabinet file unpacker
cableswig_0.1.0+cvs20111009-1.1_amd64.deb Generate wrappers for Python and Tcl from C++ code
caca-utils_0.99.beta19-2_amd64.deb text mode graphics utilities
cachefilesd_0.10.5-1_amd64.deb support fscache on already mounted filesystem
cacti-spine_0.8.8b-1_amd64.deb Multi-Threading poller for cacti
cacti_0.8.8b+dfsg-8+deb8u6_all.deb web interface for graphing of monitoring systems
cadabra_1.39-0.2_amd64.deb field-theory motivated computer algebra system
cadaver_0.23.3-2+b2_amd64.deb command-line WebDAV client
cadubi_1.3-2_all.deb Creative ASCII Drawing Utility By Ian
cafeobj_1.5.2-2_amd64.deb new generation algebraic specification and programming language
cain-examples_1.9-8_all.deb simulations of chemical reactions
cain-solvers_1.9-8_amd64.deb simulations of chemical reactions
Advertisement
Advertisement