bundler_1.7.4-1_all.deb


Advertisement

Description

bundler - Manage Ruby application dependencies

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name bundler
Package version 1.7.4
Package release 1
Package architecture all
Package type deb
Installed size 634 B
Download size 145.69 KB
Official Mirror ftp.br.debian.org
Bundler manages a Ruby application's dependencies through its entire
life, across many machines, systematically and repeatably.
Bundler is most useful for developers of applications.

Alternatives

Package Version Architecture Repository
bundler_1.7.4-1_all.deb 1.7.4 all Debian Main
bundler - - -

Requires

Name Value
ruby -
ruby-interpreter -
ruby-net-http-persistent >= 2.7-1
ruby-thor >= 0.18.1~
rubygems-integration -

Download

Type URL
Binary Package bundler_1.7.4-1_all.deb
Source Package bundler

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install bundler deb package:
    # sudo apt-get install bundler

Files

Path
/usr/bin/bundle
/usr/bin/bundle_ruby
/usr/bin/bundler
/usr/lib/ruby/vendor_ruby/bundler.rb
/usr/lib/ruby/vendor_ruby/bundler/capistrano.rb
/usr/lib/ruby/vendor_ruby/bundler/cli.rb
/usr/lib/ruby/vendor_ruby/bundler/constants.rb
/usr/lib/ruby/vendor_ruby/bundler/current_ruby.rb
/usr/lib/ruby/vendor_ruby/bundler/definition.rb
/usr/lib/ruby/vendor_ruby/bundler/dep_proxy.rb
/usr/lib/ruby/vendor_ruby/bundler/dependency.rb
/usr/lib/ruby/vendor_ruby/bundler/deployment.rb
/usr/lib/ruby/vendor_ruby/bundler/deprecate.rb
/usr/lib/ruby/vendor_ruby/bundler/dsl.rb
/usr/lib/ruby/vendor_ruby/bundler/endpoint_specification.rb
/usr/lib/ruby/vendor_ruby/bundler/env.rb
/usr/lib/ruby/vendor_ruby/bundler/environment.rb
/usr/lib/ruby/vendor_ruby/bundler/fetcher.rb
/usr/lib/ruby/vendor_ruby/bundler/friendly_errors.rb
/usr/lib/ruby/vendor_ruby/bundler/gem_helper.rb
/usr/lib/ruby/vendor_ruby/bundler/gem_helpers.rb
/usr/lib/ruby/vendor_ruby/bundler/gem_installer.rb
/usr/lib/ruby/vendor_ruby/bundler/gem_path_manipulation.rb
/usr/lib/ruby/vendor_ruby/bundler/gem_tasks.rb
/usr/lib/ruby/vendor_ruby/bundler/graph.rb
/usr/lib/ruby/vendor_ruby/bundler/index.rb
/usr/lib/ruby/vendor_ruby/bundler/injector.rb
/usr/lib/ruby/vendor_ruby/bundler/installer.rb
/usr/lib/ruby/vendor_ruby/bundler/lazy_specification.rb
/usr/lib/ruby/vendor_ruby/bundler/lockfile_parser.rb
/usr/lib/ruby/vendor_ruby/bundler/match_platform.rb
/usr/lib/ruby/vendor_ruby/bundler/parallel_workers.rb
/usr/lib/ruby/vendor_ruby/bundler/psyched_yaml.rb
/usr/lib/ruby/vendor_ruby/bundler/remote_specification.rb
/usr/lib/ruby/vendor_ruby/bundler/resolver.rb
/usr/lib/ruby/vendor_ruby/bundler/retry.rb
/usr/lib/ruby/vendor_ruby/bundler/ruby_dsl.rb
/usr/lib/ruby/vendor_ruby/bundler/ruby_version.rb
/usr/lib/ruby/vendor_ruby/bundler/rubygems_ext.rb
/usr/lib/ruby/vendor_ruby/bundler/rubygems_integration.rb
/usr/lib/ruby/vendor_ruby/bundler/runtime.rb
/usr/lib/ruby/vendor_ruby/bundler/settings.rb
/usr/lib/ruby/vendor_ruby/bundler/setup.rb
/usr/lib/ruby/vendor_ruby/bundler/shared_helpers.rb
/usr/lib/ruby/vendor_ruby/bundler/similarity_detector.rb
/usr/lib/ruby/vendor_ruby/bundler/source.rb
/usr/lib/ruby/vendor_ruby/bundler/source_list.rb
/usr/lib/ruby/vendor_ruby/bundler/spec_set.rb
/usr/lib/ruby/vendor_ruby/bundler/ui.rb
/usr/lib/ruby/vendor_ruby/bundler/vendored_persistent.rb
/usr/lib/ruby/vendor_ruby/bundler/vendored_thor.rb
/usr/lib/ruby/vendor_ruby/bundler/version.rb
/usr/lib/ruby/vendor_ruby/bundler/vlad.rb
/usr/lib/ruby/vendor_ruby/bundler/cli/binstubs.rb
/usr/lib/ruby/vendor_ruby/bundler/cli/cache.rb
/usr/lib/ruby/vendor_ruby/bundler/cli/check.rb
/usr/lib/ruby/vendor_ruby/bundler/cli/clean.rb
/usr/lib/ruby/vendor_ruby/bundler/cli/common.rb
/usr/lib/ruby/vendor_ruby/bundler/cli/config.rb
/usr/lib/ruby/vendor_ruby/bundler/cli/console.rb
/usr/lib/ruby/vendor_ruby/bundler/cli/exec.rb
/usr/lib/ruby/vendor_ruby/bundler/cli/gem.rb
/usr/lib/ruby/vendor_ruby/bundler/cli/init.rb
/usr/lib/ruby/vendor_ruby/bundler/cli/inject.rb
/usr/lib/ruby/vendor_ruby/bundler/cli/install.rb
/usr/lib/ruby/vendor_ruby/bundler/cli/open.rb
/usr/lib/ruby/vendor_ruby/bundler/cli/outdated.rb
/usr/lib/ruby/vendor_ruby/bundler/cli/package.rb
/usr/lib/ruby/vendor_ruby/bundler/cli/platform.rb
/usr/lib/ruby/vendor_ruby/bundler/cli/show.rb
/usr/lib/ruby/vendor_ruby/bundler/cli/update.rb
/usr/lib/ruby/vendor_ruby/bundler/cli/viz.rb
/usr/lib/ruby/vendor_ruby/bundler/man/bundle
/usr/lib/ruby/vendor_ruby/bundler/man/bundle-config
/usr/lib/ruby/vendor_ruby/bundler/man/bundle-config.txt
/usr/lib/ruby/vendor_ruby/bundler/man/bundle-exec
/usr/lib/ruby/vendor_ruby/bundler/man/bundle-exec.txt
/usr/lib/ruby/vendor_ruby/bundler/man/bundle-install
/usr/lib/ruby/vendor_ruby/bundler/man/bundle-install.txt
/usr/lib/ruby/vendor_ruby/bundler/man/bundle-package
/usr/lib/ruby/vendor_ruby/bundler/man/bundle-package.txt
/usr/lib/ruby/vendor_ruby/bundler/man/bundle-platform
/usr/lib/ruby/vendor_ruby/bundler/man/bundle-platform.txt
/usr/lib/ruby/vendor_ruby/bundler/man/bundle-update
/usr/lib/ruby/vendor_ruby/bundler/man/bundle-update.txt
/usr/lib/ruby/vendor_ruby/bundler/man/bundle.txt
/usr/lib/ruby/vendor_ruby/bundler/man/gemfile.5
/usr/lib/ruby/vendor_ruby/bundler/man/gemfile.5.txt
/usr/lib/ruby/vendor_ruby/bundler/parallel_workers/thread_worker.rb
/usr/lib/ruby/vendor_ruby/bundler/parallel_workers/unix_worker.rb
/usr/lib/ruby/vendor_ruby/bundler/parallel_workers/worker.rb
/usr/lib/ruby/vendor_ruby/bundler/source/git.rb
/usr/lib/ruby/vendor_ruby/bundler/source/path.rb
/usr/lib/ruby/vendor_ruby/bundler/source/rubygems.rb
/usr/lib/ruby/vendor_ruby/bundler/source/git/git_proxy.rb
/usr/lib/ruby/vendor_ruby/bundler/source/path/installer.rb
/usr/lib/ruby/vendor_ruby/bundler/ssl_certs/Class3PublicPrimaryCertificationAuthority.pem
/usr/lib/ruby/vendor_ruby/bundler/ssl_certs/DigiCertHighAssuranceEVRootCA.pem
/usr/lib/ruby/vendor_ruby/bundler/ssl_certs/EntrustnetSecureServerCertificationAuthority.pem
/usr/lib/ruby/vendor_ruby/bundler/ssl_certs/GeoTrustGlobalCA.pem
/usr/lib/ruby/vendor_ruby/bundler/ssl_certs/certificate_manager.rb
/usr/lib/ruby/vendor_ruby/bundler/templates/Executable
/usr/lib/ruby/vendor_ruby/bundler/templates/Executable.standalone
/usr/lib/ruby/vendor_ruby/bundler/templates/Gemfile
/usr/lib/ruby/vendor_ruby/bundler/templates/newgem/Gemfile.tt
/usr/lib/ruby/vendor_ruby/bundler/templates/newgem/LICENSE.txt.tt
/usr/lib/ruby/vendor_ruby/bundler/templates/newgem/README.md.tt
/usr/lib/ruby/vendor_ruby/bundler/templates/newgem/Rakefile.tt
/usr/lib/ruby/vendor_ruby/bundler/templates/newgem/gitignore.tt
/usr/lib/ruby/vendor_ruby/bundler/templates/newgem/newgem.gemspec.tt
/usr/lib/ruby/vendor_ruby/bundler/templates/newgem/rspec.tt
/usr/lib/ruby/vendor_ruby/bundler/templates/newgem/bin/newgem.tt
/usr/lib/ruby/vendor_ruby/bundler/templates/newgem/ext/newgem/extconf.rb.tt
/usr/lib/ruby/vendor_ruby/bundler/templates/newgem/ext/newgem/newgem.c.tt
/usr/lib/ruby/vendor_ruby/bundler/templates/newgem/ext/newgem/newgem.h.tt
/usr/lib/ruby/vendor_ruby/bundler/templates/newgem/lib/newgem.rb.tt
/usr/lib/ruby/vendor_ruby/bundler/templates/newgem/lib/newgem/version.rb.tt
/usr/lib/ruby/vendor_ruby/bundler/templates/newgem/spec/newgem_spec.rb.tt
/usr/lib/ruby/vendor_ruby/bundler/templates/newgem/spec/spec_helper.rb.tt
/usr/lib/ruby/vendor_ruby/bundler/templates/newgem/test/minitest_helper.rb.tt
/usr/lib/ruby/vendor_ruby/bundler/templates/newgem/test/test_newgem.rb.tt
/usr/lib/ruby/vendor_ruby/bundler/ui/rg_proxy.rb
/usr/lib/ruby/vendor_ruby/bundler/ui/shell.rb
/usr/lib/ruby/vendor_ruby/bundler/ui/silent.rb
/usr/share/doc/bundler/ISSUES.md.gz
/usr/share/doc/bundler/README.Debian
/usr/share/doc/bundler/README.md
/usr/share/doc/bundler/changelog.Debian.gz
/usr/share/doc/bundler/changelog.gz
/usr/share/doc/bundler/copyright
/usr/share/lintian/overrides/bundler
/usr/share/man/man1/bundle-config.1.gz
/usr/share/man/man1/bundle-exec.1.gz
/usr/share/man/man1/bundle-install.1.gz
/usr/share/man/man1/bundle-package.1.gz
/usr/share/man/man1/bundle-update.1.gz
/usr/share/man/man1/bundle.1.gz
/usr/share/man/man5/gemfile.5.gz
/usr/share/rubygems-integration/all/specifications/bundler-1.7.4.gemspec

Changelog

2014-10-21 - Christian Hofstaedtler <zeha@debian.org>
bundler (1.7.4-1) unstable; urgency=medium
[ Antonio Terceiro ]
* small test script improvements
[ Christian Hofstaedtler ]
* Imported Upstream version 1.7.4
* Bump Standards-Version to 3.9.6 (no further changes)
2014-08-28 - Christian Hofstaedtler <zeha@debian.org>
bundler (1.7.2-2) unstable; urgency=medium
* Testsuite: don't write into global directories
2014-08-25 - Christian Hofstaedtler <zeha@debian.org>
bundler (1.7.2-1) unstable; urgency=medium
* Imported Upstream version 1.7.2
* Expand testsuite to actually install a gem
2014-06-20 - Christian Hofstaedtler <zeha@debian.org>
bundler (1.6.3-1) unstable; urgency=medium
* Imported Upstream version 1.6.3
2014-05-31 - Christian Hofstaedtler <zeha@debian.org>
bundler (1.6.2-1) unstable; urgency=medium
* Imported Upstream version 1.6.2
* Drop dfsg prefix and README.source.
We stopped modifying the source tarball, and just remove files in
debian/rules.
2014-04-03 - Christian Hofstaedtler <zeha@debian.org>
bundler (1.6.1+dfsg-1) unstable; urgency=medium
* New upstream version.
2014-04-02 - Christian Hofstaedtler <zeha@debian.org>
bundler (1.6.0+dfsg-1) unstable; urgency=medium
* Imported Upstream version 1.6.0+dfsg
* Promote rubygems-integration to dependency
* Add DEP-8 smoke test
* Update require-rubygems.overrides
2014-03-29 - Antonio Terceiro <terceiro@debian.org>
bundler (1.5.3+dfsg-2) unstable; urgency=medium
* Add myself to Uploaders
* Remove /var/lib/gems/1.8/ as support for Ruby 1.8 is gone already
* Add support for new interpreter versions:
- /var/lib/gems/2.0.0/
- /var/lib/gems/2.1.0/
2014-02-07 - Christian Hofstaedtler <zeha@debian.org>
bundler (1.5.3+dfsg-1) unstable; urgency=medium
* Imported Upstream version 1.5.3+dfsg
* Remove upstream applied patch "revert-0d15cef"
2014-01-16 - Christian Hofstaedtler <zeha@debian.org>
bundler (1.5.2+dfsg-1) unstable; urgency=medium
* Imported Upstream version 1.5.2+dfsg
* Revert upstream 0d15cef: don't require gem_full_path to be present
for all gems.

See Also

Package Description
bup-doc_0.25-1_all.deb highly efficient file backup system based on git (documentation)
bup_0.25-1_amd64.deb highly efficient file backup system based on git
burgerspace_1.9.2-1_amd64.deb Avoid evil foodstuffs and make burgers
burn_0.4.6-2_all.deb command-line tool for writing optical media
burp_1.3.48-4.1_amd64.deb Simple cross-platform network BackUp and Restore Program
busybox-static_1.22.0-9+deb8u1_amd64.deb Standalone rescue shell with tons of builtin utilities
busybox-syslogd_1.22.0-9+deb8u1_all.deb Provides syslogd and klogd using busybox
busybox_1.22.0-9+deb8u1_amd64.deb Tiny utilities for small and embedded systems
buthead_1.1-4_amd64.deb copy all but the first few lines
buxon_0.0.5-4_all.deb SIOC forums browser
bvi_1.3.2-2_amd64.deb binary file editor
bwa_0.7.10-1_amd64.deb Burrows-Wheeler Aligner
bwbar_1.2.3-2_amd64.deb generates text and graphical readout of current bandwidth use
bwbasic_2.20pl2-11_amd64.deb Bywater BASIC Interpreter
bwctl-client_1.4.1~rc2-1_amd64.deb bandwidth test controller (client)
Advertisement
Advertisement