bumblebee_3.2.1-7_amd64.deb


Advertisement

Description

bumblebee - NVIDIA Optimus support for Linux

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name bumblebee
Package version 3.2.1
Package release 7
Package architecture amd64
Package type deb
Installed size 238 B
Download size 45.77 KB
Official Mirror ftp.br.debian.org
Bumblebee is an effort to make NVIDIA Optimus enabled laptops work in
GNU/Linux systems. These laptops are built in such a way that the NVIDIA
graphics card can be used on demand so that battery life is improved and
temperature is kept low.
It disables the discrete graphics card if no client is detected, and start
an X server making use of NVIDIA card if requested then let software GL
implementations (such as VirtualGL) copy frames to the visible display that
runs on the intergrated graphics. The ability to use discrete graphics
depends on the driver: open source nouveau and proprietary nvidia.

Alternatives

Package Version Architecture Repository
bumblebee_3.2.1-7_i386.deb 3.2.1 i386 Debian Main
bumblebee - - -

Requires

Name Value
bbswitch-dkms -
bbswitch-source -
dpkg >= 1.15.7.2
init-system-helpers >= 1.18~
libbsd0 >= 0.2.0
libc6 >= 2.15
libglib2.0-0 >= 2.12.0
libx11-6 -

Download

Type URL
Binary Package bumblebee_3.2.1-7_amd64.deb
Source Package bumblebee

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install bumblebee deb package:
    # sudo apt-get install bumblebee

Files

Path
/etc/bash_completion.d/bumblebee
/etc/bumblebee/bumblebee.conf
/etc/bumblebee/xorg.conf.nouveau
/etc/bumblebee/xorg.conf.nvidia
/etc/bumblebee/xorg.conf.d/10-dummy.conf
/etc/init/bumblebeed.conf
/etc/init.d/bumblebeed
/lib/systemd/system/bumblebeed.service
/lib/udev/rules.d/99-bumblebee-nvidia-dev.rules
/usr/bin/bumblebee-bugreport
/usr/bin/optirun
/usr/sbin/bumblebeed
/usr/share/bumblebee/default-conf/bumblebee.conf
/usr/share/bumblebee/default-conf/xorg.conf.nouveau
/usr/share/bumblebee/default-conf/xorg.conf.nvidia
/usr/share/bumblebee/default-conf/xorg.conf.d/10-dummy.conf
/usr/share/doc/bumblebee/README.Debian
/usr/share/doc/bumblebee/README.markdown
/usr/share/doc/bumblebee/RELEASE_NOTES_3_2_1
/usr/share/doc/bumblebee/changelog.Debian.gz
/usr/share/doc/bumblebee/copyright
/usr/share/man/man1/bumblebeed.1.gz
/usr/share/man/man1/optirun.1.gz

Changelog

2014-10-25 - Vincent Cheng <vcheng@debian.org>
bumblebee (3.2.1-7) unstable; urgency=medium
* Move conffile handling introduced in 3.2.1-6 from bumblebee-nvidia
to bumblebee.
2014-10-25 - Vincent Cheng <vcheng@debian.org>
bumblebee (3.2.1-6) unstable; urgency=medium
* Build with CONF_DRIVER_MODULE_NVIDIA=nvidia-current instead of nvidia.
* Stop treating /etc/modprobe.d/bumblebee.conf as a conffile and remove it
when removing bumblebee, not just when purging it. (LP: #1242785)
- Pre-Depends on dpkg >= 1.15.7.2 for dpkg-maintscript-helper rm_conffile.
* Add patches: fix-device-detection.patch, ignore-error-on-X-shutdown.patch,
cherry-picked from upstream git.
* Allow more nvidia flavours to satisfy bumblebee-nvidia's dependencies
(relevant only for Ubuntu).
* Update debian/README.Debian.
* Update email address.
* Update Standards version to 3.9.6, no changes required.
2014-01-06 - Vincent Cheng <Vincentc1208@gmail.com>
bumblebee (3.2.1-5) unstable; urgency=medium
* Allow more nvidia flavours to satisfy bumblebee-nvidia's dependencies
(relevant only for Ubuntu). (LP: #1261180)
* Update Standards version to 3.9.5, no changes required.
2013-08-20 - Vincent Cheng <Vincentc1208@gmail.com>
bumblebee (3.2.1-4) unstable; urgency=low
* Use dh-systemd (for systemd-specific additions to maintscripts).
(Closes: #715270)
* Add bumblebee group as system group (gid in between 100-999) instead
of a regular group in postinst. (Closes: #718772)
2013-07-11 - Vincent Cheng <Vincentc1208@gmail.com>
bumblebee (3.2.1-3) unstable; urgency=low
* Append /usr/lib/primus to CONF_PRIMUS_LD_PATH in d/rules to ease
pre-multiarch backports. (Closes: #712665)
* Have bumblebee depend on bbswitch-dkms | bbswitch-source, and
bumblebee-nvidia depend on all possible m-a built nvidia modules.
* Add support for nvidia-325 packaged in Ubuntu (not relevant for Debian).
2013-05-29 - Vincent Cheng <Vincentc1208@gmail.com>
bumblebee (3.2.1-2) unstable; urgency=low
* Allow more nvidia flavours to satisfy bumblebee-nvidia's dependencies
(relevant for Ubuntu).
2013-05-03 - Vincent Cheng <Vincentc1208@gmail.com>
bumblebee (3.2.1-1) unstable; urgency=low
[ Aron Xu ]
* Initial release (Closes: #659440).
* Thanks to Peter Lekensteyn and Bruno Pagani, most stuff taken from the
packaging for Ubuntu PPA.
[ Vincent Cheng ]
* Thanks to Igor Urazov for lots of the Debian-specific portions of the
packaging.

See Also

Package Description
bumprace-data_1.5.4-2_all.deb data files for bumprace
bumprace_1.5.4-2+b1_amd64.deb 1 or 2 players race through a multi-level maze
bundler_1.7.4-1_all.deb Manage Ruby application dependencies
bup-doc_0.25-1_all.deb highly efficient file backup system based on git (documentation)
bup_0.25-1_amd64.deb highly efficient file backup system based on git
burgerspace_1.9.2-1_amd64.deb Avoid evil foodstuffs and make burgers
burn_0.4.6-2_all.deb command-line tool for writing optical media
burp_1.3.48-4.1_amd64.deb Simple cross-platform network BackUp and Restore Program
busybox-static_1.22.0-9+deb8u1_amd64.deb Standalone rescue shell with tons of builtin utilities
busybox-syslogd_1.22.0-9+deb8u1_all.deb Provides syslogd and klogd using busybox
busybox_1.22.0-9+deb8u1_amd64.deb Tiny utilities for small and embedded systems
buthead_1.1-4_amd64.deb copy all but the first few lines
buxon_0.0.5-4_all.deb SIOC forums browser
bvi_1.3.2-2_amd64.deb binary file editor
bwa_0.7.10-1_amd64.deb Burrows-Wheeler Aligner
Advertisement
Advertisement