bnd_1.50.0-8_all.deb


Advertisement

Description

bnd - tool to create and diagnose OSGi R4 bundles

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name bnd
Package version 1.50.0
Package release 8
Package architecture all
Package type deb
Installed size 2.25 KB
Download size 1.18 MB
Official Mirror ftp.br.debian.org
The bnd tool helps you create and diagnose OSGi R4 bundles.
The key functions are:
* Show the manifest and JAR contents of a bundle
* Wrap a JAR so that it becomes a bundle
* Create a Bundle from a specification and a class path
* Verify the validity of the manifest entries
The tool is capable of acting as:
* Command line tool
* Eclipse Plugin
* Maven Plugin
* Ant Plugin

Alternatives

Package Version Architecture Repository
bnd_1.50.0-8_all.deb 1.50.0 all Debian Main
bnd - - -

Requires

Name Value
default-jre-headless -
java-wrappers -
java5-runtime-headless -
libosgi-compendium-java >= 4.3.0
libosgi-core-java >= 4.3.0

Download

Type URL
Binary Package bnd_1.50.0-8_all.deb
Source Package bnd

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install bnd deb package:
    # sudo apt-get install bnd

Files

Path
/usr/bin/bnd
/usr/share/doc/bnd/README
/usr/share/doc/bnd/changelog.Debian.gz
/usr/share/doc/bnd/copyright
/usr/share/java/bnd-1.50.0.jar
/usr/share/java/bnd.annotation-1.50.0.jar
/usr/share/java/bnd.annotation.jar
/usr/share/java/bnd.jar
/usr/share/java/bnd.junit-1.50.0.jar
/usr/share/java/bnd.junit.jar
/usr/share/java/bnd.launcher-1.50.0.jar
/usr/share/java/bnd.launcher.jar
/usr/share/java/bndlib-1.50.0.jar
/usr/share/java/bndlib.jar
/usr/share/man/man1/bnd.1.gz
/usr/share/maven-repo/biz/aQute/annotation/1.50.0/annotation-1.50.0.jar
/usr/share/maven-repo/biz/aQute/annotation/1.50.0/annotation-1.50.0.pom
/usr/share/maven-repo/biz/aQute/annotation/debian/annotation-debian.jar
/usr/share/maven-repo/biz/aQute/annotation/debian/annotation-debian.pom
/usr/share/maven-repo/biz/aQute/bnd/1.50.0/bnd-1.50.0.jar
/usr/share/maven-repo/biz/aQute/bnd/1.50.0/bnd-1.50.0.pom
/usr/share/maven-repo/biz/aQute/bnd/debian/bnd-debian.jar
/usr/share/maven-repo/biz/aQute/bnd/debian/bnd-debian.pom
/usr/share/maven-repo/biz/aQute/bndlib/1.50.0/bndlib-1.50.0.jar
/usr/share/maven-repo/biz/aQute/bndlib/1.50.0/bndlib-1.50.0.pom
/usr/share/maven-repo/biz/aQute/bndlib/debian/bndlib-debian.jar
/usr/share/maven-repo/biz/aQute/bndlib/debian/bndlib-debian.pom

Changelog

2014-04-29 - Emmanuel Bourg <ebourg@apache.org>
bnd (1.50.0-8) unstable; urgency=medium
* Added a patch to fix the compilation errors with Java 8
* debian/control:
- Removed the dependency on openjdk-6-jdk
- Standards-Version updated to 3.9.5 (no changes)
* Switch to debhelper level 9
2013-10-17 - Emmanuel Bourg <ebourg@apache.org>
bnd (1.50.0-7) unstable; urgency=low
* Install the Maven artifacts biz.aQute:annotation and biz.aQute:bnd
2013-07-26 - Emmanuel Bourg <ebourg@apache.org>
bnd (1.50.0-6) unstable; urgency=low
[ Emmanuel Bourg ]
* Added a patch to compile with Ant 1.9 (Closes: #712343)
* Fixed the unmappable character errors during the compilation
* debian/watch: Updated to catch the recent releases on Github
* debian/control:
- Updated Standards-Version to 3.9.4 (no changes)
- Use canonical URLs for the Vcs-* fields
* debian/rules: Improved the clean target
* Updated the Maven pom
[ Damien Raude-Morvan ]
* d/rules: Don't fail clean target if there is no things to delete.
* Upload to unstable.
2012-07-25 - Damien Raude-Morvan <drazzib@debian.org>
bnd (1.50.0-5) unstable; urgency=low
* d/rules: Fix FTBFS after update to eclipse 3.8.0~rc4-1 (Closes: #682647).
* d/copyright: Update to copyright format 1.0.
2012-04-30 - Jakub Adam <jakub.adam@ktknet.cz>
bnd (1.50.0-4) unstable; urgency=low
* Fix FTBFS after update to eclipse 3.7.2-1 (Closes: #669533).
* Add Jakub Adam to Uploaders.
* Bump Standards-Version to 3.9.3: no changes needed.
2012-01-17 - Damien Raude-Morvan <drazzib@debian.org>
bnd (1.50.0-3) unstable; urgency=low
* d/rules: Fix broken link with Eclipse JDT during build. (Closes: #655548).
* d/patches/display_bsn_on_missing_bundle.diff: Improve error message when
some bundle is missing.
2011-12-08 - Miguel Landaeta <miguel@miguel.cc>
bnd (1.50.0-2) unstable; urgency=low
[ Miguel Landaeta ]
* Team upload.
[ James Page ]
* Fix FTBFS with OpenJDK 7 (LP: #888926) (Closes: #651389):
- d/ant.properties: Set default source/target to 1.5 to ensure
backwards compatibility and avoid Java 7 encoding errors.
2011-11-09 - Damien Raude-Morvan <drazzib@debian.org>
bnd (1.50.0-1) unstable; urgency=low
* New upstream release.
* d/control: Add Build-Depends on libbindex-java.
* d/{bootstrap,rules}: Add bindex.jar to classpath.
* d/patches/no_git_during_build.diff: Don't try to use GIT during build.
* d/patches/osgi43_fixes.diff: Some fixes for libosgi-core-java >= 4.3.
* d/patches/no_felix.diff: Drop dependency on felix-framework (to remove
dependency cycle).
2011-10-26 - Damien Raude-Morvan <drazzib@debian.org>
bnd (1.44.0-1) unstable; urgency=low
* New upstream version.
* Bump Standards-Version to 3.9.2: no changes needed.
* d/copyright: Upgrade to latest DEP-5 version.
* Use upstream build system:
- d/orig-tar.sh: Rework to use github (Closes: #640839).
- d/build.xml, d/build.properties: Drop.
- d/bootstrap.xml: Build a small bnd.jar just for its own bootstrap.
- Rename d/svn-transform.sh to d/git-transform.sh and remove unneeded bits.
* Enable full OSGi and Eclipse modules (Closes: #565749) :
- d/control: Add Build-Depends on libswt-gtk-3-java, eclipse-rcp,
eclipse-jdt and libosgi-core-java
- d/control: Only Suggests: eclipse-rcp, eclipse-jdt
2011-08-30 - Torsten Werner <twerner@debian.org>
bnd (0.0.384-2) unstable; urgency=low
* Team upload.
* Switch to source format 3.0.
* Update Standards-Version: 3.9.1.

See Also

Package Description
bnfc_2.6.0.3-2_amd64.deb Compiler front-end generator based on Labelled BNF
boa-constructor_0.6.1-13_all.deb RAD tool for Python and wxWindows application
boats_201307-1_amd64.deb race scenario drawing tool
bochs-doc_2.6-2_all.deb Bochs upstream documentation
bochs-sdl_2.6-2_amd64.deb SDL plugin for Bochs
bochs-term_2.6-2_amd64.deb Terminal (ncurses-based) plugin for Bochs
bochs-wx_2.6-2_amd64.deb WxWindows plugin for Bochs
bochs-x_2.6-2_amd64.deb X11 plugin for Bochs
bochs_2.6-2_amd64.deb IA-32 PC emulator
bochsbios_2.6-2_all.deb BIOS for the Bochs emulator
bodr_10-1_all.deb Blue Obelisk Data Repository
bogl-bterm_0.1.18-9_amd64.deb Ben's Own Graphics Library - graphical terminal
bognor-regis_0.6.12+git20101007.02c25268-9_amd64.deb Media daemon and play queue manager
bogofilter-bdb_1.2.4+dfsg1-3+deb8u1_amd64.deb fast Bayesian spam filter (Berkeley DB)
bogofilter-common_1.2.4+dfsg1-3+deb8u1_all.deb fast Bayesian spam filter (common files)
Advertisement
Advertisement