blogofile_0.8b1-1_all.deb


Advertisement

Description

blogofile - static website compiler and blog engine

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name blogofile
Package version 0.8b1
Package release 1
Package architecture all
Package type deb
Installed size 97 B
Download size 27.73 KB
Official Mirror ftp.br.debian.org
Blogofile is a static website compiler, primarily (though not
exclusively) designed to be a simple blogging engine. It requires no
database and no special hosting environment. You customize a set of
templates with Mako, create posts in a markup language of your choice
(Markdown, Textile, reStructuredText or plain old HTML) and Blogofile
renders your entire website as static HTML and Atom/RSS feeds which
you can then upload to any old web server you like.

Alternatives

Package Version Architecture Repository
blogofile_0.8b1-1_all.deb 0.8b1 all Debian Main
blogofile - - -

Requires

Name Value
python << 2.8
python >= 2.7
python-docutils -
python-jinja2 -
python-mako -
python-markdown -
python-markupsafe -
python-pkg-resources -
python-pygments -
python-six -
python-textile -
python-tz -
python-unidecode -
python-yaml -

Download

Type URL
Binary Package blogofile_0.8b1-1_all.deb
Source Package blogofile

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install blogofile deb package:
    # sudo apt-get install blogofile

Files

Path
/usr/bin/blogofile
/usr/lib/python2.7/dist-packages/Blogofile-0.8b1.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/Blogofile-0.8b1.egg-info/SOURCES.txt
/usr/lib/python2.7/dist-packages/Blogofile-0.8b1.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/Blogofile-0.8b1.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/Blogofile-0.8b1.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/Blogofile-0.8b1.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/Blogofile-0.8b1.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/blogofile/__init__.py
/usr/lib/python2.7/dist-packages/blogofile/cache.py
/usr/lib/python2.7/dist-packages/blogofile/config.py
/usr/lib/python2.7/dist-packages/blogofile/controller.py
/usr/lib/python2.7/dist-packages/blogofile/default_config.py
/usr/lib/python2.7/dist-packages/blogofile/exception.py
/usr/lib/python2.7/dist-packages/blogofile/filter.py
/usr/lib/python2.7/dist-packages/blogofile/main.py
/usr/lib/python2.7/dist-packages/blogofile/plugin.py
/usr/lib/python2.7/dist-packages/blogofile/server.py
/usr/lib/python2.7/dist-packages/blogofile/template.py
/usr/lib/python2.7/dist-packages/blogofile/util.py
/usr/lib/python2.7/dist-packages/blogofile/writer.py
/usr/share/doc/blogofile/LICENSE.txt
/usr/share/doc/blogofile/README.rst
/usr/share/doc/blogofile/changelog.Debian.gz
/usr/share/doc/blogofile/changelog.gz
/usr/share/doc/blogofile/copyright
/usr/share/lintian/overrides/blogofile
/usr/share/man/man1/blogofile.1.gz
/usr/share/pyshared/Blogofile-0.8b1.egg-info/PKG-INFO
/usr/share/pyshared/Blogofile-0.8b1.egg-info/SOURCES.txt
/usr/share/pyshared/Blogofile-0.8b1.egg-info/dependency_links.txt
/usr/share/pyshared/Blogofile-0.8b1.egg-info/entry_points.txt
/usr/share/pyshared/Blogofile-0.8b1.egg-info/not-zip-safe
/usr/share/pyshared/Blogofile-0.8b1.egg-info/requires.txt
/usr/share/pyshared/Blogofile-0.8b1.egg-info/top_level.txt
/usr/share/pyshared/blogofile/__init__.py
/usr/share/pyshared/blogofile/cache.py
/usr/share/pyshared/blogofile/config.py
/usr/share/pyshared/blogofile/controller.py
/usr/share/pyshared/blogofile/default_config.py
/usr/share/pyshared/blogofile/exception.py
/usr/share/pyshared/blogofile/filter.py
/usr/share/pyshared/blogofile/main.py
/usr/share/pyshared/blogofile/plugin.py
/usr/share/pyshared/blogofile/server.py
/usr/share/pyshared/blogofile/template.py
/usr/share/pyshared/blogofile/util.py
/usr/share/pyshared/blogofile/writer.py

Changelog

2013-09-13 - Jakob Haufe <sur5r@sur5r.net>
blogofile (0.8b1-1) unstable; urgency=low
* New upstream version
* debian/rules: Fix override_dh_auto_clean
* debian/docs: README is now ReStructured Text instead of Markdown
* Bump Standards-Version (no changes needed)
* Change B-D from python to python-all according to python-policy
* Remove unneeded lintian override: no-upstream-changelog
* Cherry-pick patches from upstream:
- 0001-Remove-version-pinning-as-much-as-possible.patch
(35c6d58acf01645895bbc46547c9fd41d1a1c4b7)
- 0002-Add-allow_reuse_address-to-server-stop-occasional-Ad.patch
(f2d678d73c33fa1d098d2518cd2f8484a16d1e16)
* Add missing dependency: python-pkg-resources
* Set myself as maintainer
* Canonicalize VCS urls to make lintian happy
2011-10-21 - Andreas Rütten <AndreasRuetten@gmx.de>
blogofile (0.7.1-1) unstable; urgency=low
* Initial release (Closes: #644433)
* Add debian/blogofile.1 manpage
* Add debian/wordpress2blogofile manpage

See Also

Package Description
blop_0.2.8-6_amd64.deb Bandlimited wavetable-based oscillator plugins for LADSPA hosts
blosxom_2.1.2-1_all.deb light, feature-packed weblog app with plugin extensibility
blt-demo_2.5.3+dfsg-1_all.deb graphics extension library for Tcl/Tk - demos and examples
blt-dev_2.5.3+dfsg-1_amd64.deb graphics extension library for Tcl/Tk - development files
blt_2.5.3+dfsg-1_amd64.deb graphics extension library for Tcl/Tk - run-time
bluedevil_2.0~rc1-44-gb7697a7-3_amd64.deb KDE Bluetooth stack
bluefish-data_2.2.6-2_all.deb advanced Gtk+ text editor (data)
bluefish-plugins_2.2.6-2_amd64.deb advanced Gtk+ text editor (plugins)
bluefish_2.2.6-2_amd64.deb advanced Gtk+ text editor for web and software development
blueman_1.99~alpha1-1+deb8u1_amd64.deb Graphical bluetooth manager
bluemindo_0.3-4_all.deb simple yet powerful audio player
bluemon_1.4-6_amd64.deb Activate or deactivate programs based on Bluetooth link quality
blueproximity_1.2.5-6_all.deb locks/unlocks your desktop tracking a bluetooth device
bluetooth_5.23-2+deb8u1_all.deb Bluetooth support
bluez-cups_5.23-2+deb8u1_amd64.deb Bluetooth printer driver for CUPS
Advertisement
Advertisement