blacs-test-common_1.1-33_all.deb


Advertisement

Description

blacs-test-common - Test data for BLACS testers

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name blacs-test-common
Package version 1.1
Package release 33
Package architecture all
Package type deb
Installed size 41 B
Download size 7.11 KB
Official Mirror ftp.br.debian.org
The BLACS project is an ongoing investigation whose purpose is to
create a linear algebra oriented message passing interface that may be
implemented efficiently and uniformly across a large range of
distributed memory platforms.
You can choose between an implementation based on MPI or PVM. This package
provides test data for all BLACS packages (MPI and PVM versions).
Most users do not need to install this package directly because it is
installed when installing the test programs for any BLACS package.

Alternatives

Package Version Architecture Repository
blacs-test-common_1.1-33_all.deb 1.1 all Debian Main
blacs-test-common - - -

Download

Type URL
Binary Package blacs-test-common_1.1-33_all.deb
Source Package blacs-mpi

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install blacs-test-common deb package:
    # sudo apt-get install blacs-test-common

Files

Path
/usr/lib/blacs/bsbr.dat
/usr/lib/blacs/bt.dat
/usr/lib/blacs/comb.dat
/usr/lib/blacs/sdrv.dat
/usr/share/doc/blacs-test-common/README
/usr/share/doc/blacs-test-common/changelog.Debian.gz
/usr/share/doc/blacs-test-common/copyright

Changelog

2014-10-17 - Muammar El Khatib <muammar@debian.org>
blacs-mpi (1.1-33) unstable; urgency=medium
* Moving arm64 from MPICH_ARCHS to OPENMPI_ARCHS. In this way, the package
builds correctly in arm64. Thanks to Edmund Grimley Evans. (Closes: #765328)
2014-09-23 - Muammar El Khatib <muammar@debian.org>
blacs-mpi (1.1-32) unstable; urgency=medium
* mips64 and mips64el were marked as openmpi archs. (Closes: #761946)
2014-08-06 - Matthias Klose <doko@debian.org>
blacs-mpi (1.1-31.4) unstable; urgency=medium
* Non-maintainer upload.
* Add arm64, ppc64 and ppc64el to the openmpi architectures.
* Build OpenMPI with -DUseMpi2. Closes: #714583.
* debian/rules: declare library dependencies correctly. Closes: #660214.
2014-04-23 - Sébastien Villemot <sebastien@debian.org>
blacs-mpi (1.1-31.3) unstable; urgency=medium
* Non-maintainer upload.
* Drop transitional package libblacs-mpi1: it breaks reverse
dependencies on mpich archs, because of the mpich2->mpich transition.
2014-04-03 - Sébastien Villemot <sebastien@debian.org>
blacs-mpi (1.1-31.2) unstable; urgency=medium
* Non-maintainer upload.
* No longer silently change the SONAME of the MPI blacs shared
library when the default MPI implementation changes on a given arch.
(Closes: #740764)
+ Create two new binary packages libblacs-openmpi1 and
libblacs-mpich1, corresponding to the two possible SONAMES.
+ The architecture list for each binary package is stored in debian/rules,
and debian/control is now generated from debian/control.in by the clean
rule.
+ Keep a transitional package for libblacs-mpi1.
+ Make sure that the package FTBFS if the default MPI implementation
changes on a given arch (instead of silently changing the SONAME or
creating an empty package).
2013-12-22 - Sébastien Villemot <sebastien@debian.org>
blacs-mpi (1.1-31.1) unstable; urgency=medium
* Non-maintainer upload.
* Support MPICH3 which is now simply called MPICH. (Closes: #731225)
2011-12-23 - Muammar El Khatib <muammar@debian.org>
blacs-mpi (1.1-31) unstable; urgency=low
* Rebuilding with mpi-default-dev >=1.0 (Closes: #652312)
2011-08-15 - Nicholas Breen <nbreen@ofb.net>
blacs-mpi (1.1-30.1) unstable; urgency=low
* Non-maintainer upload.
* Add support for ARCH_DEFAULT_MPI_IMPL from mpi-default-dev.
* Add support for MPICH2.  Rename debian/blacs-openmpi.patch to the more
general blacs-mpi-implementations.patch.  (Closes: #626336)
2011-04-02 - Muammar El Khatib <muammar@debian.org>
blacs-mpi (1.1-30) unstable; urgency=low
* blacs-mpi source does not Build-Depends on libopenmpi-dev anymore. With
this change it is possible to prevent BLACS from building on architectures
without OpenMPI such as: armel, hppa, mips[el] and s390. (Closes: #620393).
* Thanks to Adam C Powell IV for reporting this bug, and providing a patch.
2011-03-27 - Muammar El Khatib <muammar@debian.org>
blacs-mpi (1.1-29) unstable; urgency=low
* Fixed FTBFS because of a dpkg-shlibdeps error that was not able to find
the library libmpi_f77.so.0. (Closes: #614528)
* Maintainer's mail has been changed.
* Bump Standards-Version to 3.9.1. No changes were needed.
* Moved to debhelper 7.

See Also

Package Description
blacs1-pvm_1.1-21_amd64.deb Basic Linear Algebra Comm. Subprograms - Shared libs. for PVM
bladerf_0.2014.09~rc2-5_amd64.deb nuand bladeRF software-defined radio device (tools)
blahtexml_0.9-1.1_amd64.deb Converts TeX equations into MathML
blam_1.8.9-4_all.deb simple RSS aggregator for GNOME
blast2_2.2.26.20120620-8_amd64.deb Basic Local Alignment Search Tool
blazeblogger_1.2.0-3_all.deb simple to use, command line based, content management system
blcr-testsuite_0.8.5-2.2_amd64.deb Userspace tools to Checkpoint and Restart Linux processes
blcr-util_0.8.5-2.2_amd64.deb Userspace tools to Checkpoint and Restart Linux processes
bld-postfix_0.3.4.1-4_amd64.deb Postfix tools for the Black List Daemon
bld-tools_0.3.4.1-4_amd64.deb Generic tools for Black List Daemon
bld_0.3.4.1-4_amd64.deb Black List Daemon, automatically build blacklists
bleachbit_1.4-1_all.deb delete unnecessary files from the system
blender-data_2.72.b+dfsg0-3_all.deb Very fast and versatile 3D modeller/renderer - data package
blender-ogrexml-1.8_1.8.0+dfsg1-7_all.deb Blender Exporter for OGRE
blender-ogrexml-1.9_1.9.0+dfsg1-4_all.deb Blender Exporter for OGRE
Advertisement
Advertisement