barnowl_1.9-1+b2_amd64.deb


Advertisement

Description

barnowl - A curses-based tty Jabber, IRC, AIM and Zephyr client

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name barnowl
Package version 1.9
Package release 1+b2
Package architecture amd64
Package type deb
Installed size 1.07 KB
Download size 563.56 KB
Official Mirror ftp.br.debian.org
A curses-based instant-messaging client supporting the Jabber, IRC, AIM
and Zephyr  protocols.  Much of the functionality is written in
Perl, which is supported as an extension language.
This is a fork of ktools software's owl Zephyr/AIM client.

Alternatives

Package Version Architecture Repository
barnowl_1.9-1+b2_i386.deb 1.9 i386 Debian Main
barnowl - - -

Requires

Name Value
libanyevent-irc-perl -
libauthen-sasl-perl -
libc6 >= 2.16
libclass-accessor-perl -
libcomerr2 >= 1.01
libdatetime-format-strptime-perl -
libdatetime-perl -
libglib-perl -
libglib2.0-0 >= 2.41.1
libgssapi-perl -
libio-socket-ssl-perl -
libmime-base64-urlsafe-perl -
libncursesw5 >= 5.6+20070908
libnet-dns-perl -
libpar-perl -
libperl5.20 >= 5.20.1
libssl1.0.0 >= 1.0.0
libtext-autoformat-perl -
libtinfo5 -
libzephyr4 -

Provides

Name Value
barnowl-irc -

Conflicts

Name Value
barnowl-irc -

Replaces

Name Value
barnowl-irc -

Download

Type URL
Binary Package barnowl_1.9-1+b2_amd64.deb
Source Package barnowl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install barnowl deb package:
    # sudo apt-get install barnowl

Files

Path
/usr/bin/barnowl
/usr/bin/zcrypt
/usr/share/barnowl/lib/BarnOwl.pm
/usr/share/barnowl/lib/BarnOwl/Completion.pm
/usr/share/barnowl/lib/BarnOwl/Editwin.pm
/usr/share/barnowl/lib/BarnOwl/Help.pm
/usr/share/barnowl/lib/BarnOwl/Hook.pm
/usr/share/barnowl/lib/BarnOwl/Hooks.pm
/usr/share/barnowl/lib/BarnOwl/MainLoopCompatHook.pm
/usr/share/barnowl/lib/BarnOwl/Message.pm
/usr/share/barnowl/lib/BarnOwl/ModuleLoader.pm
/usr/share/barnowl/lib/BarnOwl/Parse.pm
/usr/share/barnowl/lib/BarnOwl/Style.pm
/usr/share/barnowl/lib/BarnOwl/Timer.pm
/usr/share/barnowl/lib/BarnOwl/Zephyr.pm
/usr/share/barnowl/lib/BarnOwl/Complete/AIM.pm
/usr/share/barnowl/lib/BarnOwl/Complete/Client.pm
/usr/share/barnowl/lib/BarnOwl/Complete/Filter.pm
/usr/share/barnowl/lib/BarnOwl/Complete/Zephyr.pm
/usr/share/barnowl/lib/BarnOwl/Completion/Context.pm
/usr/share/barnowl/lib/BarnOwl/Completion/Util.pm
/usr/share/barnowl/lib/BarnOwl/Message/AIM.pm
/usr/share/barnowl/lib/BarnOwl/Message/Admin.pm
/usr/share/barnowl/lib/BarnOwl/Message/Generic.pm
/usr/share/barnowl/lib/BarnOwl/Message/Loopback.pm
/usr/share/barnowl/lib/BarnOwl/Message/Zephyr.pm
/usr/share/barnowl/lib/BarnOwl/Style/Basic.pm
/usr/share/barnowl/lib/BarnOwl/Style/Default.pm
/usr/share/barnowl/lib/BarnOwl/Style/Legacy.pm
/usr/share/barnowl/lib/BarnOwl/Style/OneLine.pm
/usr/share/barnowl/lib/Module/Install/BarnOwl.pm
/usr/share/barnowl/modules/Facebook.par
/usr/share/barnowl/modules/IRC.par
/usr/share/barnowl/modules/Jabber.par
/usr/share/barnowl/modules/Twitter.par
/usr/share/barnowl/modules/WordWrap.par
/usr/share/doc/barnowl/AUTHORS
/usr/share/doc/barnowl/README.Debian
/usr/share/doc/barnowl/advanced.txt.gz
/usr/share/doc/barnowl/changelog.Debian.amd64.gz
/usr/share/doc/barnowl/changelog.Debian.gz
/usr/share/doc/barnowl/changelog.gz
/usr/share/doc/barnowl/code.txt.gz
/usr/share/doc/barnowl/copyright
/usr/share/doc/barnowl/intro.txt.gz
/usr/share/doc/barnowl/owl-window.txt.gz
/usr/share/doc/barnowl/releasing-barnowl.txt
/usr/share/man/man1/barnowl.1.gz

Changelog

2013-05-29 - Sam Hartman <hartmans@debian.org>
barnowl (1.9-1) unstable; urgency=low
* New upstream version
* Fix "uses libnet-irc-perl, which is abandoned upstream"; upstream now
uses libanyevent-irc-perl (Closes: #640206) 
* Enable debhelper 9 and thus hardened build flags, Closes: #653506
* Include remote DOS fixes from upstream, Closes: #664465
2011-09-10 - Salvatore Bonaccorso <carnil@debian.org>
barnowl (1.6.2-1.1) unstable; urgency=low
* Non-maintainer upload.
* Add patch use-Digest-SHA.patch to use Digest::SHA from perl core instead
of Digest::SHA1. Drop libdigest-sha1-perl Depends in debian/control
(Closes: #625903).
2010-08-17 - Sam Hartman <hartmans@debian.org>
barnowl (1.6.2-1) unstable; urgency=low
* New Upstream version
* Fixes cve-2010-2725, Closes: #593299
* Build conflict with barnowl because t/mock.pl is broken and old
version of barnowl mess up current versions tests. 
2010-04-05 - Sam Hartman <hartmans@debian.org>
barnowl (1.5.1-1) unstable; urgency=low
* New upstream release, including solution to cve-2010-0793, Closes:
#574418
2010-02-02 - Sam Hartman <hartmans@debian.org>
barnowl (1.5-1) unstable; urgency=medium
* New upstream release
2009-11-25 - Sam Hartman <hartmans@debian.org>
barnowl (1.4-1) unstable; urgency=low
* New upstream version
* Fix test build failures: Closes: #543015
* We need to depend on perl 5.10.1-8 because prove --perl became prove
--exec.  Let's here it for backward compatibility 
2009-08-17 - Sam Hartman <hartmans@debian.org>
barnowl (1.3-1) unstable; urgency=low
* New upstream version
2009-07-22 - Sam Hartman <hartmans@debian.org>
barnowl (1.1.1-3) unstable; urgency=low
*  Depend on zephyr3
* Abolish cdbs in favor of debhelper 7
2009-06-09 - Sam Hartman <hartmans@debian.org>
barnowl (1.1.1-2) unstable; urgency=low
* Actually upload
2009-06-09 - Sam Hartman <hartmans@debian.org>
barnowl (1.1.1-1) UNRELEASED; urgency=low
* New upstream release

See Also

Package Description
barrage_1.0.4-1_amd64.deb Rather destructive action game
base-files_8+deb8u11_amd64.deb Debian base system miscellaneous files
base-passwd_3.5.37_amd64.deb Debian base system master password and group files
basex_7.9-1_all.deb XML database and XPath/XQuery processor
bash-builtins_4.3-11+deb8u1_amd64.deb Bash loadable builtins - headers & examples
bash-completion_2.1-4_all.deb programmable completion for the bash shell
bash-doc_4.3-11+deb8u1_all.deb Documentation and examples for the GNU Bourne Again SHell
bash-static_4.3-11+deb8u1_amd64.deb GNU Bourne Again SHell (static version)
bash_4.3-11+deb8u1_amd64.deb GNU Bourne Again SHell
bashburn_3.0.1-2_all.deb simplify cd/dvd burning at the command line
basket-data_2.10~beta+git6fed731-1_all.deb data files for BasKet Notepads
basket_2.10~beta+git6fed731-1_amd64.deb multi-purpose note-taking application for KDE
bastet_0.43-3+b1_amd64.deb ncurses Tetris clone with a bastard algorithm
batctl_2014.3.0-2_amd64.deb B.A.T.M.A.N. advanced control and management tool
batmand_0.3.2-15_amd64.deb better approach to mobile adhoc networking
Advertisement
Advertisement