artha_1.0.3-1_amd64.deb


Advertisement

Description

artha - Handy off-line thesaurus based on WordNet

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name artha
Package version 1.0.3
Package release 1
Package architecture amd64
Package type deb
Installed size 223 B
Download size 65.91 KB
Official Mirror ftp.br.debian.org
Artha is a off-line English thesaurus with distinct features like:
* hot-key press word look-up (select text on any window and press
a preset hot-key for look-up)
* regular expressions based search (broaden search using wild-cards
like *, ?, etc.)
* passive desktop notifications (of word definitions for
uninterrupted work-flow)
* spelling suggestions (when the exact spelling is vague/not known)
Once launched, it monitors for a preset hot-key combination. When
some text is selected on any window and the hot-key is pressed, it
pops-up with the word looked-up. Should the user prefer passive
notifications, this can be done by enabling the notifications option.
When the term looked for is vague/not known, then either the search
can be broadened with the use of regular expressions (*, ?, etc.) in
the search string or spelling suggestions when a term is incorrect.
For regular expressions based search to work, wordnet-sense-index
package is required.

Alternatives

Package Version Architecture Repository
artha_1.0.3-1_i386.deb 1.0.3 i386 Debian Main
artha - - -

Requires

Name Value
libc6 >= 2.4
libdbus-1-3 >= 1.0.2
libdbus-glib-1-2 >= 0.78
libglib2.0-0 >= 2.28.0
libgtk2.0-0 >= 2.24.0
libx11-6 -
wordnet -

Download

Type URL
Binary Package artha_1.0.3-1_amd64.deb
Source Package artha

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install artha deb package:
    # sudo apt-get install artha

Files

Path
/usr/bin/artha
/usr/share/applications/artha.desktop
/usr/share/artha/gui.glade
/usr/share/doc/artha/AUTHORS
/usr/share/doc/artha/NEWS.gz
/usr/share/doc/artha/README
/usr/share/doc/artha/TODO
/usr/share/doc/artha/changelog.Debian.gz
/usr/share/doc/artha/changelog.gz
/usr/share/doc/artha/copyright
/usr/share/man/man1/artha.1.gz
/usr/share/menu/artha
/usr/share/pixmaps/artha.png

Changelog

2013-11-08 - Andreas Tille <tille@debian.org>
artha (1.0.3-1) unstable; urgency=low
* New upstream version
* debian/control:
- cme fix dpkg-control
- debhelper 9
- canonical Vcs fields
* debian/rules: --with autotools_dev
Closes: #727844
* debian/make_sure_we_really_use_GTK_LIBS.patch:
Upstream avoids linking against @GTK_LIBS@ which results in a missing
library at linking time (-lgio).  We are reaching the wanted effect
eather by using `DEB_LDFLAGS_MAINT_APPEND += -Wl,--as-needed` in
debian/rules
2011-06-28 - Andreas Tille <tille@debian.org>
artha (1.0.2-1) unstable; urgency=low
[ Sundaram Ramaswamy ]
* New upstream version
Closes: #553965, #571948
LP: #531475
[ Andreas Tille ]
* debian/source/format: 3.0 (quilt)
* Standards-Version: 3.9.2 (no changes needed)
* Fixed Vcs fields
* Drop cdbs in favour of short dh rules file
2010-01-20 - Sundaram Ramaswamy <legends2k@yahoo.com>
artha (1.0.1-1) unstable; urgency=low
* New upstream version
2010-01-14 - Sundaram Ramaswamy <legends2k@yahoo.com>
artha (1.0.0-1) unstable; urgency=low
* New upstream version
* Removed libnotify-dev and python from Build-Depends as the newer version 
doesn't depend on them directly
* Added libnotify1 and wordnet-sense-index to Recommends since major 
functionalities are exposed on their availability
* Updated Description to suit the new version
* Updated year in copyright
2009-10-30 - Andreas Tille <tille@debian.org>
artha (0.9.1-1) unstable; urgency=low
* New upstream version
* Standards-Version: 3.8.3 (no changes needed)
2009-03-30 - Andreas Tille <tille@debian.org>
artha (0.8.0-1) unstable; urgency=low
[ Sundaram Ramaswamy ]
* Initial release (Closes: #514690)
[ Andreas Tille ]
* Removed libc6 dependency because it is just wrong
* Removed explicit Build-Depends libglib2.0-0 because it is implicitly
resolved by libgtk2.0-0 Dependency
* Standards-Version: 3.8.1 (no changes needed)
* Depends: ${misc:Depends}, ${shlibs:Depends}

See Also

Package Description
as31_2.3.1-6_amd64.deb Intel 8031/8051 assembler
asc-data_2.6.0.0-1_all.deb data files for the Advanced Strategic Command game
asc-music_1.3-2_all.deb music pack for ASC
asc_2.6.0.0-1+b1_amd64.deb turn-based strategy game
ascd_0.13.2-5_amd64.deb CD player and mixer
ascdc_0.3-15_amd64.deb AfterStep CD changer
ascii2binary_2.14-1_amd64.deb Convert between ASCII, hexadecimal and binary representations
ascii_3.14-2_amd64.deb interactive ASCII name and synonym chart
asciidoc_8.6.9-3_all.deb Highly configurable text format for writing documentation
asciidoctor-doc_0.1.4-3_all.deb AsciiDoc to HTML rendering for Ruby (documentation)
asciidoctor_0.1.4-3_all.deb AsciiDoc to HTML rendering for Ruby
asciijump_1.0.2~beta-7_amd64.deb Small and funny ASCII-art game about ski jumping
asciinema_0.9.8-1_all.deb Record and share your terminal sessions, the right way
asciio_1.02.71-1_all.deb dynamically create ASCII charts and graphs with GTK+2
asclock-themes_2.0.12-25_all.deb Theme files for ASclock, a clock applet
Advertisement
Advertisement