aribas_1.64-5_amd64.deb


Advertisement

Description

aribas - interpreter for arithmetic

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name aribas
Package version 1.64
Package release 5
Package architecture amd64
Package type deb
Installed size 472 B
Download size 208.33 KB
Official Mirror ftp.br.debian.org
ARIBAS is an interactive interpreter suitable for big integer
arithmetic and multiprecision floating point arithmetic.
It has a syntax similar to Pascal or Modula-2, but contains also
features from other programming languages like C, Lisp, Oberon.

Alternatives

Package Version Architecture Repository
aribas_1.64-5_i386.deb 1.64 i386 Debian Main
aribas - - -

Requires

Name Value
libc6 >= 2.2.5

Download

Type URL
Binary Package aribas_1.64-5_amd64.deb
Source Package aribas

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install aribas deb package:
    # sudo apt-get install aribas

Files

Path
/usr/bin/aribas
/usr/lib/aribas/aribas.hlp
/usr/share/doc-base/aribas
/usr/share/doc/aribas/aribas.doc.gz
/usr/share/doc/aribas/aribas.tut.gz
/usr/share/doc/aribas/changelog.Debian.gz
/usr/share/doc/aribas/changelog.gz
/usr/share/doc/aribas/copyright
/usr/share/doc/aribas/examples/README
/usr/share/doc/aribas/examples/factor.ari.gz
/usr/share/doc/aribas/examples/pi.ari.gz
/usr/share/doc/aribas/examples/queens.ari.gz
/usr/share/emacs/site-lisp/aribas/aribas.el
/usr/share/man/man1/aribas.1.gz

Changelog

2010-11-20 - Ralf Treinen <treinen@debian.org>
aribas (1.64-5) unstable; urgency=low
* Remove dependency on emacsen-common, do not byte-compile aribas.el.
Justifaction: debian emacs policy section 5, "Packages with only
marginal emacs relevance". Also drop "Suggests: emacsen".
* Rename some directories under debian/ according to debhelper(7).
2010-11-18 - Ralf Treinen <treinen@debian.org>
aribas (1.64-4) unstable; urgency=low
* Pre-Depend on emacsen-common instead of just Depends, to fix an
error occuring when upgrading from an earlier version of aribas
that does not depend on emacsen-common (closes: Bug#603788).
* Standards-Version 3.9.1 (no change).
2010-02-10 - Ralf Treinen <treinen@debian.org>
aribas (1.64-3) unstable; urgency=low
* debian/rules:
- use the standard Makefile on non-i386 architectures.
- use dh_install to install files
- use dh_installchangelogs to install upstream changelog
* Apply upstream's patch to fix warnings about casting from pointer to
integer of different size on 64bit architectures:
debian/patches/casting_pointers
2010-02-03 - Ralf Treinen <treinen@debian.org>
aribas (1.64-2) unstable; urgency=low
* use improved manpage sent in by upstream author (patch manpage-improved, 
replaces the patch manpage-dashes).
2010-01-28 - Ralf Treinen <treinen@debian.org>
aribas (1.64-1) unstable; urgency=low
* New upstream release
* Patch manpage-dashes: escape dashes in manpage.
* Standards-version 3.8.4 (no change)
2010-01-11 - Ralf Treinen <treinen@debian.org>
aribas (1.63-5) unstable; urgency=low
* Build-depend on ${misc:Depends}
2009-11-21 - Ralf Treinen <treinen@debian.org>
aribas (1.63-4) unstable; urgency=low
* Convert to source format 3.0 (quilt) :
- no longer build-depends on dpatch
- no patching in debian/rules
- debian/patches converted to quilt style
- added debian/source/format
* debian/watch: use passive ftp mode (closes: Bug#552545).
* Debhelper compatibility level 7.
- call dh_prep instead of dh_clean -k
* Standards-version 3.8.3 (no change)
* debian/copyright:
- add that users are free to choose a version of GPL later than 2
- point to versionend GPL-2 file.
2008-10-25 - Ralf Treinen <treinen@debian.org>
aribas (1.63-3) unstable; urgency=low
* Add dependency on emacsen-common (closes: Bug#503323).
* Do not mention homepage in long description.
* Standards-Version 3.8.0 (no change).
2008-04-30 - Ralf Treinen <treinen@debian.org>
aribas (1.63-2) unstable; urgency=low
* debian/control: add a Homepage field.
* debian/rules: fix bashism (closes: Bug#478360).
2008-03-21 - Ralf Treinen <treinen@debian.org>
aribas (1.63-1) unstable; urgency=low
* New upstream release.
* debian/copyright: put a proper copyright notice.
* debian/doc-base.aribas: place files in section Science/Mathematics.
* Standards-Version 3.7.3 (no change).

See Also

Package Description
ario-common_1.5.1-1.3_all.deb GTK+ client for the Music Player Daemon (MPD) (Common files)
ario_1.5.1-1.3_amd64.deb GTK+ client for the Music Player Daemon (MPD)
arista_0.9.7-5_all.deb multimedia transcoder for the GNOME Desktop
arj_3.10.22-13_amd64.deb archiver for .arj files
ark_4.14.2-2+deb8u1_amd64.deb archive utility
armada-backlight_1.1-8_amd64.deb adjust backlight of Compaq Armada laptops (E300, M500, M700)
armagetronad-common_0.2.8.3.2-4_all.deb Common files for the Armagetron Advanced packages
armagetronad-dedicated_0.2.8.3.2-4_amd64.deb dedicated game server for Armagetron Advanced
armagetronad_0.2.8.3.2-4_amd64.deb 3D Tron-like high speed game
arno-iptables-firewall_2.0.1.e-1_all.deb single- and multi-homed firewall script with DSL/ADSL support
aroarfw-dev_0.1~beta5-1_all.deb framework to build hardware with RoarAudio protocol support
aroarfw-doc_0.1~beta5-1_all.deb framework to build hardware with RoarAudio protocol support (documentation)
arora_0.11.0+qt5+git2014-04-06-1_amd64.deb simple cross platform web browser
arp-scan_1.8.1-2_amd64.deb arp scanning and fingerprinting tool
arpalert_2.0.11-7.1_amd64.deb monitor ARP changes in ethernet networks
Advertisement
Advertisement