alsa-base_1.0.27+1_all.deb


Advertisement

Description

alsa-base - dummy package to ease purging of obsolete conffiles

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name alsa-base
Package version 1.0.27+1
Package architecture all
Package type deb
Installed size 83 B
Download size 53.06 KB
Official Mirror ftp.br.debian.org
This is an empty dummy package with the only purpose of ensuring
obsolete kmod files will be removed from the system. This functionality
is now shipped in kmod.

Alternatives

Package Version Architecture Repository
alsa-base_1.0.27+1_all.deb 1.0.27+1 all Debian Main
alsa-base - - -

Requires

Name Value
dpkg >= 1.15.7.2~
kmod >= 17-1

Download

Type URL
Binary Package alsa-base_1.0.27+1_all.deb
Source Package alsa-base

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install alsa-base deb package:
    # sudo apt-get install alsa-base

Files

Path
/usr/share/doc/alsa-base/changelog.gz
/usr/share/doc/alsa-base/copyright

Changelog

2014-05-07 - Jordi Mallach <jordi@debian.org>
alsa-base (1.0.27+1) unstable; urgency=medium
* The still-useful bits of alsa-base (kmod configuration files) have moved
to kmod itself in version 17-1. There is nothing of use left in
alsa-base, so for jessie, it'll just become a dummy package that helps
cleaning up its old conffiles. It will be dropped after the jessie
release.
* Add a dependency on kmod (>= 17-1) (closes: #746799).
* Remove all package contents, and tweak package descriptions to note
this is an empty, dummy package.
* All of the above obsoletes and closes: #625233, #660801, #545415.
* Add maintscript handling for the three removed conffiles.
* Cleanup debian/rules, there's nothing to do now.
* Bump Standards-Version to 3.9.5.
2013-04-20 - Jordi Mallach <jordi@debian.org>
alsa-base (1.0.25+3) unstable; urgency=low
* Add Pre-Depends dpkg (>= 1.15.7.2~), for dpkg-maintscript-helper.
* In 1.0.25+2, we started using dh_installinit to install the
default file as /etc/default/alsa-base, and make it a proper conffile.
However, the alsa script still expected to read defaults from
/etc/default/alsa. Update it to use the new path (closes: #680914).
Additionally, make sure that if we're upgrading from versions prior to
this change, and a /etc/default/alsa file already exists and its
md5sum isn't known, it'll get renamed to alsa-base in order to
preserve user changes.
For testing users, the old file will be removed if it was pristine,
and otherwise it'll stay unused in the filesystem.
* Try to remove /etc/default/alsa on purge.
2012-08-26 - Cyril Brulebois <kibi@debian.org>
alsa-base (1.0.25+2+nmu2) unstable; urgency=high
* Non-maintainer upload.
* alsa-base.modprobe: Fix snd module autoloading by adding a trailing
':', as is done for snd-rawmidi and snd-emu10k1. Since d-i's switch
to kmod, speech synthesis would otherwise be broken for a number of
devices (Closes: #685885). Thanks to Samuel Thibault for reporting,
and Julien Cristau for the suggested patch.
2012-07-08 - Neil Williams <codehelp@debian.org>
alsa-base (1.0.25+2+nmu1) unstable; urgency=low
* Non-maintainer upload.
* Apply patch by Helmar Gerloni <helmar@gerloni.net> to
test for existence of directories before trying to
remove /etc/apm/suspend.d. (Closes: #673679)
2012-05-20 - Jordi Mallach <jordi@debian.org>
alsa-base (1.0.25+2) unstable; urgency=low
* Use dpkg-maintscript-helper to correctly remove /etc/apm/scripts.d/alsa
conffile (closes: #673608).
* Remove mentions of alsa-driver, alsa-source or building alsa-modules
from alsa-base's description.
* Decruft maintainer scripts:
- use dpkg-maintscript-helper to handle previous conffile renames and
removals, and remove obsolete pre-lenny code
- stop installing a default file in /usr/share and make
/etc/default/alsa a real conffile.
- get rid of postinst entirely.
- remove apm symlinks on preinst upgrade, not just postrm purge.
* Rely on dh_installmodules, dh_bugfiles and dh_installdefault instead
of manually installing corresponding files.
* Update Vcs-* urls to point to alsa-base, not alsa-driver.
* Remove obsolete alsa-base.modprobe-post-install.
* Rewrite copyright file in machine-readable format 1.0, removing all
mentions of alsa-driver.

See Also

Package Description
alsa-oss_1.0.28-1_amd64.deb ALSA wrapper for OSS applications
alsa-tools-gui_1.0.28-1_amd64.deb GUI based ALSA utilities for specific hardware
alsa-tools_1.0.28-1_amd64.deb Console based ALSA utilities for specific hardware
alsa-utils_1.0.28-1_amd64.deb Utilities for configuring and using ALSA
alsamixergui_0.9.0rc2-1-9.1_amd64.deb graphical soundcard mixer for ALSA soundcard driver
alsaplayer-alsa_0.99.81-1+b1_amd64.deb alsaplayer output module for ALSA
alsaplayer-common_0.99.81-1+b1_amd64.deb audio player (common files)
alsaplayer-daemon_0.99.81-1+b1_amd64.deb alsaplayer daemon
alsaplayer-esd_0.99.81-1+b1_amd64.deb alsaplayer output module for EsounD
alsaplayer-gtk_0.99.81-1+b1_amd64.deb alsaplayer gtk interface
alsaplayer-jack_0.99.81-1+b1_amd64.deb alsaplayer output module for JACK
alsaplayer-nas_0.99.81-1+b1_amd64.deb alsaplayer output module for NAS
alsaplayer-oss_0.99.81-1+b1_amd64.deb alsaplayer output module for OSS
alsaplayer-text_0.99.81-1+b1_amd64.deb alsaplayer text interface
alsaplayer-xosd_0.99.81-1+b1_amd64.deb alsaplayer XOSD display module
Advertisement
Advertisement