agda_2.4.0.2-2_all.deb


Advertisement

Description

agda - dependently typed functional programming language

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name agda
Package version 2.4.0.2
Package release 2
Package architecture all
Package type deb
Installed size 79 B
Download size 55.04 KB
Official Mirror ftp.br.debian.org
Agda is a dependently typed functional programming language: It has inductive
families, which are like Haskell's GADTs, but they can be indexed by values and
not just types. It also has parameterised modules, mixfix operators, Unicode
characters, and an interactive Emacs interface (the type checker can assist in
the development of your code).
Agda is also a proof assistant: It is an interactive system for writing and
checking proofs. Agda is based on intuitionistic type theory, a foundational
system for constructive mathematics developed by the Swedish logician Per
Martin-Löf. It has many similarities with other proof assistants based on
dependent types, such as Coq, Epigram and NuPRL.
This is a meta package which provides Agda's emacs mode, executable, standard
library and its documentation.

Alternatives

Package Version Architecture Repository
agda_2.4.0.2-2_all.deb 2.4.0.2 all Debian Main
agda - - -

Requires

Name Value
agda-bin -
agda-mode -
agda-stdlib -
agda-stdlib-doc -
libghc-agda-dev -

Download

Type URL
Binary Package agda_2.4.0.2-2_all.deb
Source Package agda

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install agda deb package:
    # sudo apt-get install agda

Files

Path
/usr/share/doc/agda/README.gz
/usr/share/doc/agda/buildinfo_all.gz
/usr/share/doc/agda/changelog.Debian.gz
/usr/share/doc/agda/changelog.gz
/usr/share/doc/agda/copyright

Changelog

2014-08-11 - Colin Watson <cjwatson@debian.org>
agda (2.4.0.2-2) unstable; urgency=medium
* [e33e7a9] Pregenerate the Primitive.agdai interface file in
libghc-agda-dev, since agda users typically can't write to that
directory.  Fixes agda-stdlib build.
2014-08-05 - Iain Lane <laney@debian.org>
agda (2.4.0.2-1) unstable; urgency=medium
* [6e140ac] Imported Upstream version 2.4.0.2
* [2049fc8] Update Build-Depends to match control
* [93dc4d4] Install the new primitives
* [e48f40f] Fix typo dev→doc
2013-11-06 - Iain Lane <laney@debian.org>
agda (2.3.2.2-1) unstable; urgency=low
* [244f29d] Use new watch file template
* [16a3f05] Imported Upstream version 2.3.2.2
* [bdb8574] Update BDs to match cabal file
* [9bc56ee] debian/patches/support-alex-3.1: Remove patch applied upstream
in this release
2013-10-19 - Iain Lane <laney@debian.org>
agda (2.3.2.1-2) unstable; urgency=low
* [da376f6] Update BDs per .cabal; extend hashable, remove packages provided
by ghc
* [e21e765] Cherry-pick from upstream: Suppoert Alex 3.1.x
* [2263659] Remove "dist" generated files accidently commited
2013-06-16 - Iain Lane <laney@debian.org>
agda (2.3.2.1-1) unstable; urgency=low
* [8cfbabf] Imported Upstream version 2.3.2.1
* [74f34b0] Bump BD on mtl per .cabal file
* [a3bff17] Drop Debian patches now obsoleted by this upstream release
2013-06-12 - Iain Lane <laney@debian.org>
agda (2.3.2-4) unstable; urgency=low
* [3d77fff] Build-Depend on ghc-ghci; we require this due to Template
Haskell
2013-05-29 - Joachim Breitner <nomeata@debian.org>
agda (2.3.2-3) unstable; urgency=low
* Clean up build dependencies 
2013-05-27 - Iain Lane <laney@debian.org>
agda (2.3.2-2) unstable; urgency=low
* Upload to unstable
* [0faee65] Use compat 9
* [02dba24] Standards Version → 3.9.4
* [bd2a43f] Use common substvars for description blurbs.
* [06ddb90] Remove obsolete DM-Upload-Allowed field
2013-04-10 - Iain Lane <laney@debian.org>
agda (2.3.2-1) experimental; urgency=low
[ Kiwamu Okabe ]
* New patch: Extend haskell-src-exts dependency and fix type miss.
[ Iain Lane ]
* [dfbca48] Imported Upstream version 2.3.2
* [7746bcc] Remove all patches — all upstream.
* [2cdb691] Update build-deps to match control file
* [868ebf4] agda-mode no longer depends on haskell-mode or GHCi.
Remove dependency and update .el file accordingly
* [9e0ba22] Add agda-bin package here, as the separate package has been
removed
* [75a240f] agda-mode needs to depend on agda-bin
* [d290f95] Allow Quickcheck up to 2.7. Fix haskeline build-dep.
* [79190e6] Add missing geniplate and parallel BDs
2012-05-25 - Joachim Breitner <nomeata@debian.org>
agda (2.3.0.1-2) unstable; urgency=low
* New patch: Extend mtl dependency

See Also

Package Description
agedu_9723-1_amd64.deb Unix utility for tracking down wasted disk space
aggregate_1.6-7_amd64.deb ipv4 cidr prefix aggregator
aghermann_1.0.2-1_amd64.deb Sleep-research experiment manager
aglfn_1.7-3_all.deb Adobe Glyph List For New Fonts
agtl_0.8.0.3-1_all.deb Tool for paperless geocaching
aha_0.4.7.2-1_amd64.deb ANSI color to HTML converter
ahcpd_0.53-2_amd64.deb Ad-Hoc Configuration Protocol
aide-common_0.16~a2.git20130520-3_all.deb Advanced Intrusion Detection Environment - Common files
aide-dynamic_0.16~a2.git20130520-3_amd64.deb Advanced Intrusion Detection Environment - dynamic binary
aide-xen_0.16~a2.git20130520-3_amd64.deb Advanced Intrusion Detection Environment - static binary for XEN
aide_0.16~a2.git20130520-3_amd64.deb Advanced Intrusion Detection Environment - static binary
aiksaurus_1.2.1+dev-0.12-6.2_amd64.deb an English-language thesaurus (utility)
air-quality-sensor_0.1.2-1_amd64.deb user space driver for AppliedSensor's Indoor Air Monitor
aircrack-ng_1.2-0~beta3-4_amd64.deb wireless WEP/WPA cracking utilities
airport-utils_2-3_all.deb configuration and management utilities for Apple AirPort base stations
Advertisement
Advertisement