yamagi-quake2-core_5.21~dfsg1-2+b1_i386.deb


Advertisement

Description

yamagi-quake2-core - enhanced version of id Software's Quake II - non-GUI part

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Contrib i386
Package filename yamagi-quake2-core_5.21~dfsg1-2+b1_i386.deb
Package name yamagi-quake2-core
Package version 5.21~dfsg1
Package release 2+b1
Package architecture i386
Package type deb
Category contrib/games game::fps implemented-in::c interface::daemon role::program use::gameplaying
Homepage http://www.yamagi.org/quake2/
License -
Maintainer Debian Games Team <pkg-games-devel@lists.alioth.debian.org>
Download size 271.02 KB
Installed size 873.00 KB
This is the Yamagi Quake II Server, an enhanced Version of id Software's
Quake II. This code is based upon Icculus Quake II,
which itself is built upon id Software's original code drop. Additional code
and patches by many contributers were used.
This package contains files common to the client and the server, and a
dedicated server engine is intended to be used via the wrapper script
and init scripts in the quake2-server package.

Alternatives

Package Version Architecture Repository
yamagi-quake2-core_5.21~dfsg1-2+b1_amd64.deb 5.21~dfsg1 amd64 Debian Contrib
yamagi-quake2-core - - -

Requires

Name Value
libc6 >= 2.15
zlib1g >= 1:1.1.4

Provides

Name Value
quake2-engine-server -

Replaces

Name Value
yamagi-quake2 << 5.11

Download

Type URL
Mirror ftp.br.debian.org
Binary Package yamagi-quake2-core_5.21~dfsg1-2+b1_i386.deb
Source Package yquake2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install yamagi-quake2-core deb package:
    # sudo apt-get install yamagi-quake2-core

Files

Path
/usr/lib/yamagi-quake2/q2ded
/usr/lib/yamagi-quake2/baseq2/game.so
/usr/share/doc/yamagi-quake2-core/changelog.Debian.gz
/usr/share/doc/yamagi-quake2-core/changelog.Debian.i386.gz
/usr/share/doc/yamagi-quake2-core/changelog.gz
/usr/share/doc/yamagi-quake2-core/copyright
/usr/share/lintian/overrides/yamagi-quake2-core

Changelog

2014-10-09 - Simon McVittie <smcv@debian.org>
yquake2 (5.21~dfsg1-2) unstable; urgency=medium
* Change libjpeg8-dev build-dependency to libjpeg-dev for libjpeg-turbo
transition
* Standards-Version: 3.9.6 (no changes needed)
2014-01-13 - Simon McVittie <smcv@debian.org>
yquake2 (5.21~dfsg1-1) unstable; urgency=low
* New upstream release
- the refresher (renderer) is now directly linked into the executable
- refresh patches
* Standards-Version: 3.9.5 (no changes needed)
* Release to unstable
2013-09-29 - Simon McVittie <smcv@debian.org>
yquake2 (5.11.v2~dfsg1-1) experimental; urgency=low
[ Fabian Greffrath ]
* Initial release (Closes: #689824).
* Filter potentially non-free stuff out of the upstream release tarball.
* Append to {C,LD}FLAGS instead of overriding them,
obey dpkg-buildflags thereby.
* Install port-specific architecture-dependent files
into a separate LIBDIR directory.
* Fix spelling-errors detected by lintian.
* Add Recommends: libgl1-mesa-glx | libgl1, libopenal1. They get dlopen()ed
and should be installed in all but unusual installations. This way they
also show up in reportbug templates.
[ Simon McVittie ]
* Add myself to Uploaders
* Enable pristine-tar support
* Fix git-import-orig filter syntax
* Also filter out src/backends/sdl_osx since those files' origin and
license are unclear
* debian/copyright: document why this is in contrib, and how the
orig tarball was filtered
* Provide a virtual package for the quake2-engine
* Take the engine and server off the $PATH, recommending the quake2
package (from src:quake >= 4) as the "user-facing" Quake II package
* Provide virtual packages for the quake2-engine and quake2-engine-server
* Split out a yamagi-quake2-core package with the server and shared files
* Link against libgl, libopenal1 libraries at compile time in the
usual way, instead of dlopen() + Recommends
* Set SYSTEMWIDE directory to the LIBDIR, so the wrapper scripts
in the quake2, quake2-server packages can select either demo data
(/usr/share/games/quake2-demo) or full data (/usr/share/games/quake2)
if both are installed
* yamagi-quake2-core: add Breaks/Replaces for the
yamagi-quake2 packages provided by upstream
* Upload to experimental

See Also

Package Description
yamagi-quake2_5.21~dfsg1-2+b1_i386.deb enhanced version of id Software's Quake II - client
ydpdict_1.0.2+1.0.3-1_i386.deb interface for Collins and Langenscheidt dictionaries
Advertisement
Advertisement