xvba-va-driver_0.8.0-9+deb8u1_i386.deb


Advertisement

Description

xvba-va-driver - XvBA-based backend for VA API (AMD fglrx implementation)

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Contrib i386
Package filename xvba-va-driver_0.8.0-9+deb8u1_i386.deb
Package name xvba-va-driver
Package version 0.8.0
Package release 9+deb8u1
Package architecture i386
Package type deb
Category admin::hardware contrib/video hardware::video implemented-in::c role::plugin use::driver
Homepage http://www.splitted-desktop.com/~gbeauchesne/
License -
Maintainer Fglrx packaging team <pkg-fglrx-devel@lists.alioth.debian.org>
Download size 7.04 KB
Installed size 7.00 KB
X-Video Bitstream Acceleration (XvBA), designed by AMD for its ATI/AMD Radeon
GPU, is a future extension of the X video extension (Xv) for the X Window
System on Linux operating-systems. XvBA API allows video programs to offload
portions of the video decoding process to the GPU video-hardware. Currently,
the portions designed to be offloaded by XvBA onto the GPU are motion
compensation (mo comp) and inverse discrete cosine transform (iDCT), and VLD
(Variable-Length Decoding) for MPEG-2, MPEG-4 AVC (H.264) and VC-1 encoded
video.
This driver only works with the proprietary fglrx driver from AMD.

Alternatives

Package Version Architecture Repository
xvba-va-driver_0.8.0-9+deb8u1_amd64.deb 0.8.0 amd64 Debian Contrib
xvba-va-driver - - -

Requires

Name Value
dpkg >= 1.15.6~
libfglrx-amdxvba1 >= 1:15.9

Provides

Name Value
va-driver -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package xvba-va-driver_0.8.0-9+deb8u1_i386.deb
Source Package xvba-video

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install xvba-va-driver deb package:
    # sudo apt-get install xvba-va-driver

Files

Path
/usr/share/doc/xvba-va-driver/AUTHORS
/usr/share/doc/xvba-va-driver/README
/usr/share/doc/xvba-va-driver/changelog.Debian.gz
/usr/share/doc/xvba-va-driver/changelog.gz
/usr/share/doc/xvba-va-driver/copyright

Changelog

2016-03-19 - Andreas Beckmann <anbe@debian.org>
xvba-video (0.8.0-9+deb8u1) jessie; urgency=medium
* xvba-va-driver as a separate package has been obsoleted by
fglrx-driver 1:15.9, turn it into an empty metapackage.
* Stop shipping fglrx_drv_video.so and xvba_drv_video.so.  (Closes: #813427)
* Bump Depends on libfglrx-amdxvba1 to (>= 1:15.9) which provides them.
* This breaks compatibility with libfglrx-legacy-amdxvba1 (but that package
exists only in wheezy-backports).
2014-09-27 - Andreas Beckmann <anbe@debian.org>
xvba-video (0.8.0-9) unstable; urgency=medium
[ Patrick Matthäi ]
* Provide va-driver.
Closes: #751591
[ Andreas Beckmann ]
* Bump Standards-Version to 3.9.5 (no changes needed).
* Pick patches from Gentoo to fix FTBFS:
- xvba-video-fix-mesa-gl.h.patch
- xvba-video-0.8.0-VAEncH264VUIBufferType.patch
2013-05-05 - Andreas Beckmann <anbe@debian.org>
xvba-video (0.8.0-8) unstable; urgency=low
* xvba-va-driver: Move to Section: contrib/video.  (See: #700666)
* Configure with --disable-valgrind. Thanks Adam Baxter!
* Use canonical Vcs-* URLs.
* Switch to debhelper 9.
* Build with dh_autoreconf.
* Drop lintian overrides.
* Add myself to Uploaders.
* Upload to unstable.
2013-02-01 - Patrick Matthäi <pmatthaei@debian.org>
xvba-video (0.8.0-7) experimental; urgency=low
* Set minimum required version for build dependency libva-dev to 1.0.15.
Closes: #698364
2012-12-12 - Patrick Matthäi <pmatthaei@debian.org>
xvba-video (0.8.0-6) experimental; urgency=low
* Bump Standards-Version to 3.9.4 (no changes needed).
* Switch to xz compression and add a Pre-Depends on dpkg.
* Also depend on libfglrx-legacy-amdxvba1 as alternative.
Closes: #688430
* Overwrite false positive lintian warnings about missing hardening.
2012-07-31 - Patrick Matthäi <pmatthaei@debian.org>
xvba-video (0.8.0-5) unstable; urgency=low
* Add patch 01-glx-assert from Norbert Berci to fix a triggered assert when
using the GLX backend.
Closes: #682419
* Change dependency from libxvbaw1 to new packagename libfglrx-amdxvba1.
2012-04-04 - Patrick Matthäi <pmatthaei@debian.org>
xvba-video (0.8.0-4) unstable; urgency=low
* Rebuild, so that dh_auto_install picks up the correct libdir.
Closes: #664487
2012-02-24 - Patrick Matthäi <pmatthaei@debian.org>
xvba-video (0.8.0-3) unstable; urgency=low
* Bump Standards-Version to 3.9.3 (no changes needed).
2011-09-25 - Patrick Matthäi <pmatthaei@debian.org>
xvba-video (0.8.0-2) unstable; urgency=low
[ Andreas Beckmann ]
* Switch Build-Depends from fglrx-driver to libxvbaw-dev.
* Switch Depends from fglrx-driver to libxvbaw1.
* Fix watch file to find the source tarball, not the prebuilt binaries.
* Bump debhelper compat level to 8 and switch build system from cdbs to dh.
* Install the upstream changelog (NEWS).
2011-06-26 - Patrick Matthäi <pmatthaei@debian.org>
xvba-video (0.8.0-1) unstable; urgency=low
* New upstream release.
- Move package to contrib/libs, it is released under the terms of the
GPLv2+ now, yeah!
- Adjust the debian licensing.
* Move packaging to cdbs.
* Bump Standards-Version to 3.9.2 (no changes needed).
* Remove .la files.
* Remove deprecated debian/links file.

See Also

Package Description
yamagi-quake2-core_5.21~dfsg1-2+b1_i386.deb enhanced version of id Software's Quake II - non-GUI part
yamagi-quake2_5.21~dfsg1-2+b1_i386.deb enhanced version of id Software's Quake II - client
ydpdict_1.0.2+1.0.3-1_i386.deb interface for Collins and Langenscheidt dictionaries
Advertisement
Advertisement