libsuitesparse-metis-3.1.0_3.1.0-2_i386.deb


Advertisement

Description

libsuitesparse-metis-3.1.0 - collection of libraries for computations for sparse matrices

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Contrib i386
Package filename libsuitesparse-metis-3.1.0_3.1.0-2_i386.deb
Package name libsuitesparse-metis-3.1.0
Package version 3.1.0
Package release 2
Package architecture i386
Package type deb
Category contrib/libs role::shared-lib
Homepage http://www.cise.ufl.edu/research/sparse/SuiteSparse/
License -
Maintainer Debian Science Team <debian-science-maintainers@lists.alioth.debian.org>
Download size 904.15 KB
Installed size 2.00 MB
Suitesparse is a collection of libraries for computations involving
sparse matrices. libsuitesparse-metis is a replacement for libsuitesparse
compiled with libmetis support. The package includes the following libraries:
AMD         approximate minimum degree ordering
CAMD        symmetric approximate minimum degree
BTF         permutation to block triangular form (beta)
COLAMD      column approximate minimum degree ordering
CCOLAMD     constrained column approximate minimum degree ordering
CHOLMOD     sparse Cholesky factorization
CSparse     a concise sparse matrix package
CXSparse    CSparse extended: complex matrix, int and long int support
KLU         sparse LU factorization, primarily for circuit simulation
LDL         a simple LDL' factorization
UMFPACK     sparse LU factorization
UFconfig    configuration file for all the above packages.
This package contains the dynamic libraries.
Homepage: <http://www.cise.ufl.edu/research/sparse/SuiteSparse/>

Alternatives

Package Version Architecture Repository
libsuitesparse-metis-3.1.0_3.1.0-2_amd64.deb 3.1.0 amd64 Debian Contrib
libsuitesparse-metis-3.1.0 - - -

Requires

Name Value
libatlas3gf-3dnow -
libatlas3gf-base -
libatlas3gf-sse -
libatlas3gf-sse2 -
libblas.so.3gf -
libblas3gf -
libc6 >= 2.7
liblapack.so.3gf -
liblapack3gf -
libparmetis3.1 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libsuitesparse-metis-3.1.0_3.1.0-2_i386.deb
Source Package suitesparse-metis

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libsuitesparse-metis-3.1.0 deb package:
    # sudo apt-get install libsuitesparse-metis-3.1.0

Files

Path
/usr/lib/libamd.so.3.1.0
/usr/lib/libbtf.so.3.1.0
/usr/lib/libcamd.so.3.1.0
/usr/lib/libccolamd.so.3.1.0
/usr/lib/libcholmod.so.3.1.0
/usr/lib/libcolamd.so.3.1.0
/usr/lib/libcsparse.so.3.1.0
/usr/lib/libcxsparse.so.3.1.0
/usr/lib/libklu.so.3.1.0
/usr/lib/libldl.so.3.1.0
/usr/lib/libumfpack.so.3.1.0
/usr/share/doc/libsuitesparse-metis-3.1.0/README.Debian
/usr/share/doc/libsuitesparse-metis-3.1.0/README.txt.gz
/usr/share/doc/libsuitesparse-metis-3.1.0/changelog.Debian.gz
/usr/share/doc/libsuitesparse-metis-3.1.0/copyright

Changelog

2010-05-14 - Sylvestre Ledru <sylvestre@debian.org>
suitesparse-metis (3.1.0-2) unstable; urgency=low
* Team upload.
* Updated Standards-Version to 3.8.4
* Package moved to the Debian Science umbrella
* Missing libraries installed (Closes: #541974)
* ${misc:Depends} added
2008-02-17 - Daniel Rus Morales <rus.daniel@gmail.com>
suitesparse-metis (3.1.0-1) unstable; urgency=low
* New upstream release.
* Install every provided library ChangeLog as LIB_ChangeLog to be able to
keep track of every change explained there by mainstream developers.
* debian/*-*_Lib_{GNUm,M}akefile.dpatch: Changed all dpatches to set the
soname of the shared libraries to lib*.so.3.1.0. This will avoid
problems with the future releases of the package. 
Thanks to Rafael Laboissiere for this change which was previously applied
in the suitesparse package. Also thanks to Adam C. Powell IV for the 
soname numbers suggestions.
* debian/libsuitesparse.overrides: Adjusted according to the new sonames.
* debian/control: (thanks to Rafael Laboissiere)
+ Switch from g77 to gfortran, adjusting all dependencies on the
appropriate versions of the blas, atlas and lapack packages.  Thanks
to Kumar Appaiah for the bug (closes: #463944).	
+ Drop the Conflicts/Replaces/Provides relationships for the
libsuitesparse-3.0.1 package.  This was needed for the
previous libsuitesparse package and is not necessary anymore.
+ Changed the deprecated Source-Version substvar by the recommended
binary:Version, which has to be used instead of source:Version,
otherwise the package will not be binNMUable
+ Use the Vcs-* headers instead of the deprecated XS-Vcs-* ones
+ Bumped Standards-Version to 3.7.3
2007-10-22 - Christophe Prud'homme <prudhomm@debian.org>
suitesparse-metis (3.0.0-3) unstable; urgency=low
[Christophe Prud'homme ]
* debian/control: libsuitesparse-metis-dev conflicts/replaces/provides
with libumfpack4-dev
* debian/control: added Homepage field
2007-07-28 - Christophe Prud'homme <prudhomm@debian.org>
suitesparse-metis (3.0.0-2) unstable; urgency=low
[Christophe Prud'homme ]
* debian/control: Conflicts with and Replaces libumfpack4, Provides
libumfpack4
[Daniel Rus Morales]
* Fixed patches to compile LDL with -fPIC 
2007-06-11 - Daniel Rus Morales <danirus@tol-project.org>
suitesparse-metis (3.0.0-1) unstable; urgency=low
[Daniel Rus Morales]
* Initial Release of suitesparse with metis support
* Fixed some lintian errors/warnings
[ Christophe Prud'homme ]
* debian/control: added libsuitesparse to Provides
* Uploaded to contrib
* Fixed some lintian errors/warnings

See Also

Package Description
libsuitesparse-metis-dev_3.1.0-2_i386.deb collection of libraries for computations for sparse matrices
libtrain-bin_0.9b-11_i386.deb Command line interface for libtrain
libtrain-dev_0.9b-11_i386.deb The train-routing calculator library - development
libtrain1_0.9b-11_i386.deb The train-routing calculator library - runtime
libydpdict2-dev_1.0.4-2_i386.deb library for reading Collins dictionaries - development files
libydpdict2_1.0.4-2_i386.deb library for reading Collins dictionaries
linux-wlan-ng-firmware_0.2.9+dfsg-5_all.deb firmware files used by the linux-wlan-ng driver
lugaru_0~20110520.1+hge4354+dfsg-4.1_all.deb transitional dummy package
mathematica-fonts_17+deb8u1_all.deb installer for Mathematica fonts
matlab-gdf_0.1.2-2_all.deb IO library for the GDF -- Matlab interface
matlab-support_0.0.19+nmu1_all.deb distro integration for local MATLAB installations
mess-desktop-entries_0.2-2_all.deb Desktop entries for MESS ROMs
microcode.ctl_1.18~0+nmu2_i386.deb Intel IA32/IA64 CPU Microcode Utility (transitional package)
nvidia-installer-cleanup_20141201+1_i386.deb cleanup after driver installation with the nvidia-installer
nvidia-kernel-common_20141201+1_i386.deb NVIDIA binary kernel module support files
Advertisement
Advertisement