libsocl-contrib-1.1-1_1.1.3+dfsg-3+b1_i386.deb


Advertisement

Description

libsocl-contrib-1.1-1 - Task scheduler for heterogeneous multicore machines

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Contrib i386
Package filename libsocl-contrib-1.1-1_1.1.3+dfsg-3+b1_i386.deb
Package name libsocl-contrib-1.1-1
Package version 1.1.3+dfsg
Package release 3+b1
Package architecture i386
Package type deb
Category contrib/libs role::shared-lib
Homepage http://starpu.gforge.inria.fr/
License -
Maintainer Samuel Thibault <sthibault@debian.org>
Download size 36.43 KB
Installed size 310.00 KB
StarPU is a runtime system that offers support for heterogeneous
multicore machines. While many efforts are devoted to design efficient
computation kernels for those architectures (e.g. to implement BLAS
kernels on GPUs or on Cell's SPUs), StarPU not only takes care of
offloading such kernels (and implementing data coherency across
the machine), but it also makes sure the kernels are executed as
efficiently as possible.
This package contains an OpenCL-compatible library interface to StarPU.

Alternatives

Package Version Architecture Repository
libsocl-contrib-1.1-1_1.1.3+dfsg-3+b1_amd64.deb 1.1.3+dfsg amd64 Debian Contrib
libsocl-contrib-1.1-1 - - -

Requires

Name Value
libc6 >= 2.3.6-6~
libstarpu-contrib-1.1-7 -

Provides

Name Value
libsocl-1.1-1 -

Conflicts

Name Value
libsocl-1.1-1 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libsocl-contrib-1.1-1_1.1.3+dfsg-3+b1_i386.deb
Source Package starpu-contrib

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libsocl-contrib-1.1-1 deb package:
    # sudo apt-get install libsocl-contrib-1.1-1

Files

Path
/usr/lib/libsocl-1.1.so.1
/usr/lib/libsocl-1.1.so.1.0.1
/usr/share/doc/libsocl-contrib-1.1-1/changelog.Debian.gz
/usr/share/doc/libsocl-contrib-1.1-1/changelog.gz
/usr/share/doc/libsocl-contrib-1.1-1/copyright

Changelog

2014-11-07 - Samuel Thibault <sthibault@debian.org>
starpu-contrib (1.1.3+dfsg-3) unstable; urgency=medium
* control: Make libsocl-1.1-1 and libsocl-contrib-1.1-1 conflict/provide each
other (Closes: Bug#767557).
* Bump Standards-Version to 3.9.6 (no changes).
2014-09-15 - Samuel Thibault <sthibault@debian.org>
starpu (1.1.3+dfsg-2) unstable; urgency=medium
* control: Make libstarpu-1.1-7 Replace libstarpu-1.1-6: the soname bump
actually happened earlier :/ (Closes: Bug#761483).
2014-09-12 - Samuel Thibault <sthibault@debian.org>
starpu (1.1.3+dfsg-1) unstable; urgency=medium
* New upstream release.
* Rename libstarpu-1.1-6 package into libstarpu-1.1-7 due to soname bump.
2014-06-19 - Samuel Thibault <sthibault@debian.org>
starpu (1.1.2+dfsg-2) unstable; urgency=medium
* Make starpu-contrib use gfortran 4.8 too (Closes: Bug#752030).
2014-06-18 - Samuel Thibault <sthibault@debian.org>
starpu (1.1.2+dfsg-1) unstable; urgency=medium
* New upstream release.
* control: Make libstarpu-dev depend on opencl-headers, since we now build
with OpenCL enabled (Closes: Bug#748101).
* control, rules: Drop libcuda1 build-dependency, it is brought through
nvidia-cuda-toolkit anyway (Closes: Bug#749430).
* rules: Default gcc version is now 4.9, nvcc can use 4.8.
* rules: Make mpicc use our selected version of gcc.
2014-05-13 - Samuel Thibault <sthibault@debian.org>
starpu (1.1.1+dfsg-2) unstable; urgency=medium
* control,rules: Build with gcc-4.9 instead of gcc-4.7 (Closes: Bug#748009).
* rules: Disable the GCC plugin, as it doesn't build with gcc-4.9.
2014-04-14 - Samuel Thibault <sthibault@debian.org>
starpu (1.1.1+dfsg-1) unstable; urgency=medium
* New upstream release.
- Bump soname of libstarpu to 1.1-6
- Add libsocl to main, now that we can build it against ocl-icd.
* README.source: matvecmult kernel included again, as it has been rewritten.
* control: Build-depend on opencl-headers, ocl-icd-opencl-dev to make main
support OpenCL.
* patches/build_fixes: Remove, merged upstream.
2013-12-29 - Samuel Thibault <sthibault@debian.org>
starpu (1.1.0+dfsg-2) unstable; urgency=medium
* patches/build_fixes: Fix sync_synchronize use on non-x86 archs.
* control: Depend on valgrind only on archs which have it.
2013-10-28 - Samuel Thibault <sthibault@debian.org>
starpu (1.1.0+dfsg-1) unstable; urgency=low
* New upstream release.
* Do not depend on install-info any more.
* Bump Standards-Version to 3.9.5.
* patches: refresh.
* control: Add valgrind and guile build-dependency.
* docs: Add pdf documentation.
2013-09-30 - Samuel Thibault <sthibault@debian.org>
starpu (1.0.5+dfsg-1) unstable; urgency=low
* Rebuild orig tarball without NVIDIA proprietary source code
(Closes: Bug#724919).
* watch: Mangle tarball name against +dfsg.

See Also

Package Description
libstarpu-contrib-1.1-7_1.1.3+dfsg-3+b1_i386.deb Task scheduler for heterogeneous multicore machines
libstarpu-contrib-dev_1.1.3+dfsg-3+b1_i386.deb Task scheduler for heterogeneous multicore machines - dev
libstarpu-contribfft-1.1-1_1.1.3+dfsg-3+b1_i386.deb Task scheduler for heterogeneous multicore machines
libstarpu-contribmpi-1.1-2_1.1.3+dfsg-3+b1_i386.deb Task scheduler for heterogeneous multicore machines
libsuitesparse-metis-3.1.0_3.1.0-2_i386.deb collection of libraries for computations for sparse matrices
libsuitesparse-metis-dev_3.1.0-2_i386.deb collection of libraries for computations for sparse matrices
libtrain-bin_0.9b-11_i386.deb Command line interface for libtrain
libtrain-dev_0.9b-11_i386.deb The train-routing calculator library - development
libtrain1_0.9b-11_i386.deb The train-routing calculator library - runtime
libydpdict2-dev_1.0.4-2_i386.deb library for reading Collins dictionaries - development files
libydpdict2_1.0.4-2_i386.deb library for reading Collins dictionaries
linux-wlan-ng-firmware_0.2.9+dfsg-5_all.deb firmware files used by the linux-wlan-ng driver
lugaru_0~20110520.1+hge4354+dfsg-4.1_all.deb transitional dummy package
mathematica-fonts_17+deb8u1_all.deb installer for Mathematica fonts
matlab-gdf_0.1.2-2_all.deb IO library for the GDF -- Matlab interface
Advertisement
Advertisement