python3-requests_0.12.1-1+deb7u1_all.deb


Advertisement

Description

python3-requests - elegant and simple HTTP library for Python3, built for human beings

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Security Updates Main amd64
Package name python3-requests
Package version 0.12.1
Package release 1+deb7u1
Package architecture all
Package type deb
Installed size 224 B
Download size 53.94 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
python3-requests_2.0.0-1~bpo70+2_all.deb 2.0.0 all Debian Backports Main
python3-requests_2.0.0-1~bpo70+2_all.deb 2.0.0 all Debian Backports Main
python3-requests_0.12.1-1+deb7u1_all.deb 0.12.1 all Debian Security Updates Main
python3-requests_0.12.1-1+deb7u1_all.deb 0.12.1 all Debian Main
python3-requests_0.12.1-1+deb7u1_all.deb 0.12.1 all Debian Main
python3-requests - - -

Requires

Name Value
ca-certificates -
python3 >= 3.2.3-3~
python3-six -

Download

Type URL
Binary Package python3-requests_0.12.1-1+deb7u1_all.deb
Source Package requests

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python3-requests deb package:
    # sudo apt-get install python3-requests

Changelog

2015-01-25 - Sebastien Delafond <seb@debian.org>
requests (0.12.1-1+deb7u1) wheezy-security; urgency=medium
* Non-maintainer upload by the security team
* Fix CVE-2014-1829 and CVE-2014-1830 by extracting the relevant changes
from version 2.3.0
2012-05-04 - Daniele Tricoli <eriol@mornie.org>
requests (0.12.1-1) unstable; urgency=low
* New upstream release
* debian/control
- Added python-oauthlib to python-requests' Recommends field
* debian/patches/01_do-not-use-python-certifi.patch
- Refreshed
2012-04-23 - Daniele Tricoli <eriol@mornie.org>
requests (0.11.2-1) unstable; urgency=low
* New upstream release
* debian/patches/01_do-not-use-python-certifi.patch
- Refreshed
2012-04-01 - Daniele Tricoli <eriol@mornie.org>
requests (0.11.1-1) unstable; urgency=low
* New upstream release
* debian/control
- Added python3-chardet to python3-requests' Recommends field
- Updated Description field
* debian/patches/02_do-not-use-embedded-python-six.patch
- Refreshed
2012-03-19 - Daniele Tricoli <eriol@mornie.org>
requests (0.10.8-1) unstable; urgency=low
[ Piotr O┼╝arowski ]
* Fix typo in python3-requests' ${python3:Depends}
[ Daniele Tricoli ]
* New upstream release (Closes: #663561)
* Removed embedded copy of python-six
- Added debian/patches/02_do-not-use-embedded-python-six.patch
- Added override_dh_auto_configure to debian/rules to remove
the embedded copy
- Added python(3)-six to Builds-Depends and Depends
* debian/control
- Bumped Standards-Version to 3.9.3 (no changes needed)
* debian/copyright
- Added forgotten stanzas about packages inside the fork
of python-urllib3
* debian/patches/01_do-not-use-python-certifi.patch
- Refreshed
* debian/patches/02_fix-python3-except-sintax-error.patch
- Removed as it is applied upstream
2012-02-05 - Daniele Tricoli <eriol@mornie.org>
requests (0.10.1-1) unstable; urgency=low
* New upstream release
- Adds Python 3 support
* Builded python 3 package
* debian/control
- Added python-chardet to Recommends
- Bumped X-Python-Version >= 2.6
- Added ca-certificates to Depends
- Added python3-all to Build-Depends
* debian/copyright
- Updated Format URI
- Updated copyright years
* debian/patches/01_do-not-use-python-certifi.patch
- To verify SSL certificates for HTTPS requests, use the bundle provided by
ca-certificates instead of python-certifi
* debian/patches/02_fix-python3-except-sintax-error.patches
- Fix SyntaxError on Python3 because "except Error, e" is not supported
anymore
* debian/rules
- Added override_dh_auto_clean to make the package build twice in a row
2011-11-25 - Daniele Tricoli <eriol@mornie.org>
requests (0.8.2-1) unstable; urgency=low
* New upstream release
* debian/watch
- Removed "debian uupdate" options
* debian/{copyright,README.source}
- Updated to reflect upstream changes: switched from poster to
urllib3
- Added a stanza about the embedded modified copy of the
standard module Cookie
2011-10-19 - Daniele Tricoli <eriol@mornie.org>
requests (0.6.4-1) unstable; urgency=low
* New upstream release
* debian/control
- Dropped python-eventlet from Depends field because it's not used
anymore
- Moved python-gevent from Depends field to Recommends field so
python-requests can be installed also in ia64 and sparc
2011-08-23 - Daniele Tricoli <eriol@mornie.org>
requests (0.6.1-1) unstable; urgency=low
* New upstream release
2011-06-26 - Daniele Tricoli <eriol@mornie.org>
requests (0.5.0-1) unstable; urgency=low
* New upstream release
* debian/control
- Updated description to mention proxy support

See Also

Package Description
python3-tornado_2.3-2+deb7u1_all.deb scalable, non-blocking web server and tools - Python 3 package
python3-uno_3.5.4+dfsg2-0+deb7u11_amd64.deb Python-UNO bridge
python3-uwsgidecorators_1.2.3+dfsg-5+deb7u2_all.deb module of decorators for elegant access to uWSGI API (Python 3)
python3-yaml_3.10-4+deb7u1_amd64.deb YAML parser and emitter for Python3
python3.2-dev_3.2.3-7+deb7u1_amd64.deb Header files and a static library for Python (v3.2)
python3.2-doc_3.2.3-7+deb7u1_all.deb Documentation for the high-level object-oriented language Python (v3.2)
python3.2-examples_3.2.3-7+deb7u1_all.deb Examples for the Python language (v3.2)
python3.2-minimal_3.2.3-7+deb7u1_amd64.deb Minimal subset of the Python language (version 3.2)
python3.2_3.2.3-7+deb7u1_amd64.deb Interactive high-level object-oriented language (version 3.2)
qbittorrent-nox_2.9.8-1+deb7u1_amd64.deb bittorrent client based on libtorrent-rasterbar (without X support)
qbittorrent_2.9.8-1+deb7u1_amd64.deb bittorrent client based on libtorrent-rasterbar with a Qt4 GUI
qemu-keymaps_1.1.2+dfsg-6+deb7u25_all.deb QEMU keyboard maps
qemu-kvm_1.1.2+dfsg-6+deb7u25_amd64.deb Full virtualization on x86 hardware
qemu-system_1.1.2+dfsg-6+deb7u25_amd64.deb QEMU full system emulation binaries
qemu-user-static_1.1.2+dfsg-6+deb7u25_amd64.deb QEMU user mode emulation binaries (static version)
Advertisement
Advertisement