gnupg2_2.0.19-2+deb7u2_amd64.deb


Advertisement

Description

gnupg2 - GNU privacy guard - a free PGP replacement (new v2.x)

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Security Updates Main amd64
Package name gnupg2
Package version 2.0.19
Package release 2+deb7u2
Package architecture amd64
Package type deb
Installed size 5.53 KB
Download size 2.18 MB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
gnupg2_2.0.25-1~bpo70+1_amd64.deb 2.0.25 amd64 Debian Backports Main
gnupg2_2.0.25-1~bpo70+1_i386.deb 2.0.25 i386 Debian Backports Main
gnupg2_2.0.19-2+deb7u2_i386.deb 2.0.19 i386 Debian Security Updates Main
gnupg2_2.0.19-2+deb7u2_amd64.deb 2.0.19 amd64 Debian Main
gnupg2_2.0.19-2+deb7u2_i386.deb 2.0.19 i386 Debian Main
gnupg2 - - -

Requires

Name Value
dpkg >= 1.15.4
gnupg-agent = 2.0.19-2+deb7u2
install-info -
libassuan0 >= 2.0.1
libbz2-1.0 -
libc6 >= 2.7
libcurl3-gnutls >= 7.16.2
libgcrypt11 >= 1.4.5
libgpg-error0 >= 1.10
libksba8 >= 1.2.0
libreadline6 >= 6.0
zlib1g >= 1:1.1.4

Conflicts

Name Value
gpg-idea <= 2.2

Download

Type URL
Binary Package gnupg2_2.0.19-2+deb7u2_amd64.deb
Source Package gnupg2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gnupg2 deb package:
    # sudo apt-get install gnupg2

Changelog

2014-06-26 - Eric Dorland <eric@debian.org>
gnupg2 (2.0.19-2+deb7u2) wheezy-security; urgency=high
* debian/patches/06-cve-2014-4617.diff: Fixes CVE-2014-4617 "infinite
loop when decompressing data packets". (Closes: #752498)
2013-10-08 - Eric Dorland <eric@debian.org>
gnupg2 (2.0.19-2+deb7u1) wheezy-security; urgency=high
* debian/patches/{03-cve-2013-4402_p1.diff,04-cve-2013-4402_p2.diff}:
Fix for CVE-2013-4402, "infinite recursion in the compressed packet
parser". (Closes: #725433)
* debian/patches/05-cve-2013-4351.diff: Fix for CVE-2013-4351, "treats
no-usage-permitted keys as all-usages-permitted". (Closes: #722724)
2013-01-04 - Eric Dorland <eric@debian.org>
gnupg2 (2.0.19-2) unstable; urgency=high
* debian/patches/02-cve-2012-6085.diff: Patch from upstream to fix
CVE-2012-6085, "gnupg key import memory corruption". (Closes: #697251)
* debian/control: Use canonical addresses for VCS.
* debian/control: Fix scdaemon short description.
2012-03-31 - Eric Dorland <eric@debian.org>
gnupg2 (2.0.19-1) unstable; urgency=low
* New upstream release. (Closes: #666092)
* debian/control: Add Multi-Arch: foreign to all packages.
* debian/rules: Update ChangeLog locations.
2011-10-15 - Eric Dorland <eric@debian.org>
gnupg2 (2.0.18-2) unstable; urgency=low
* debian/control, debian/gpgsm.install, debian/scdaemon.install: Add a
separate package for the scdaemon. (Closes: #416129)
* debian/control, debian/gpgsm.install, debian/gnupg2.install,
gnupg-agent.install: Move gpg-preset-passphrase and gpg-protect-tool
into the gnupg-agent.
* debian/control: Upgrade Standards-Version to 3.9.2.
* debian/rules: Install ChangeLog for new scdaemon package.
2011-08-30 - Eric Dorland <eric@debian.org>
gnupg2 (2.0.18-1) unstable; urgency=low
* New upstream release. (Closes: #635206)
* debian/copyright: Update ftp location. (Closes: #624404)
* debian/patches/01-gnupg2-rename.diff: Refresh patch.
2011-02-14 - Eric Dorland <eric@debian.org>
gnupg2 (2.0.17-3) unstable; urgency=low
* debian/rules: Convert the rules file to use the lovely dh format.
* debian/gnupg2.dirs, debian/gnupg-agent.dirs, debian/gpgsm.dirs: Remove
unless dirs files.
* debian/gnupg-agent.lintian-overrides, debian/gnupg2.lintian-overrides,
debian/gpgsm.lintian-overrides: Remove unneeded lintian-overrides files.
2011-02-13 - Eric Dorland <eric@debian.org>
gnupg2 (2.0.17-2) unstable; urgency=low
* debian/control: Add dependency on dpkg (>= 1.15.4) | install-info for
info install trigger.
* debian/control, debian/rules: Use debian build hardening.
2011-02-13 - Eric Dorland <eric@debian.org>
gnupg2 (2.0.17-1) unstable; urgency=low
* New upstream release. (Closes: #584316, #603985, #603983, #603984)
* debian/patches/02-encode-s2k.diff,
debian/patches/03-gpgsm-realloc.diff, debian/patches/series: Drop now
unneeded security patches.
* debian/rules, debian/patches/01-gnupg2-rename.diff,
debian/gnupg2.info, debian/gnupg2.install: No need to rename the info
file anymore.
* debian/patches/01-gnupg2-rename.diff: Rename the autoconf package for
better renaming of pkg directories. (Closes: #579006)
* debian/control, debian/compat: Upgrade to debhelper level 8.
* debian/control:
- Upgrade Standards-Version to 3.9.1.
- Update Build-Depends versions for the latest release.
* debian/gnupg2.install: Add the applygnupgdefaults command. (Closes:
#567537)
* debian/gnupg2.docs: doc/faq.html no longer exists.

See Also

Package Description
gnupg_1.4.12-7+deb7u9_amd64.deb GNU privacy guard - a free PGP replacement
gnutls-bin_3.0.22-3+really2.12.20-8+deb7u5_amd64.deb GNU TLS library - commandline utilities
gnutls26-doc_2.12.20-8+deb7u5_all.deb GNU TLS library 2.x - documentation and examples
golang-doc_1.0.2-1.1+deb7u3_all.deb Go programming language compiler - documentation
golang-go_1.0.2-1.1+deb7u3_amd64.deb Go programming language compiler
golang-mode_1.0.2-1.1+deb7u3_all.deb Go programming language - mode for GNU Emacs
golang-src_1.0.2-1.1+deb7u3_amd64.deb Go programming language compiler - source files
golang_1.0.2-1.1+deb7u3_all.deb Go programming language compiler - metapackage
gosa-desktop_2.7.4-4.3~deb7u3_all.deb Desktop integration for GOsa²
gosa-dev_2.7.4-4.3~deb7u3_all.deb GOsa² development utilities
gosa-help-de_2.7.4-4.3~deb7u3_all.deb German online help for GOsa²
gosa-help-en_2.7.4-4.3~deb7u3_all.deb English online help for GOsa
gosa-help-fr_2.7.4-4.3~deb7u3_all.deb French online help for GOsa²
gosa-help-nl_2.7.4-4.3~deb7u3_all.deb Dutch online help for GOsa
gosa-plugin-connectivity_2.7.4-4.3~deb7u3_all.deb connectivity plugin for GOsa²
Advertisement
Advertisement