ecryptfs-utils_99-1+deb7u1_amd64.deb


Advertisement

Description

ecryptfs-utils - ecryptfs cryptographic filesystem (utilities)

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Security Updates Main amd64
Package name ecryptfs-utils
Package version 99
Package release 1+deb7u1
Package architecture amd64
Package type deb
Installed size 399 B
Download size 92.58 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ecryptfs-utils_99-1+deb7u1_i386.deb 99 i386 Debian Security Updates Main
ecryptfs-utils_99-1+deb7u1_amd64.deb 99 amd64 Debian Main
ecryptfs-utils_99-1+deb7u1_i386.deb 99 i386 Debian Main
ecryptfs-utils - - -

Requires

Name Value
gettext-base -
keyutils -
libc6 >= 2.3
libecryptfs0 -
libgpg-error0 >= 1.10
libgpgme11 >= 1.1.2
libkeyutils1 -
libnss3-1d -
libpam-runtime -
libpam0g >= 0.99.7.1
libtspi1 >= 0.3.1

Download

Type URL
Binary Package ecryptfs-utils_99-1+deb7u1_amd64.deb
Source Package ecryptfs-utils

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ecryptfs-utils deb package:
    # sudo apt-get install ecryptfs-utils

Changelog

2016-01-18 - Salvatore Bonaccorso <carnil@debian.org>
ecryptfs-utils (99-1+deb7u1) wheezy-security; urgency=high
* Non-maintainer upload by the Security Team.
* CVE-2016-1572: privilege escalation by mounting over /proc/$pid.
2012-07-20 - Daniel Baumann <daniel.baumann@progress-technologies.net>
ecryptfs-utils (99-1) unstable; urgency=low
* Merging upstream version 99:
- force the MS_NOSUID mount flag in mount.ecryptfs_private to protect
against user controlled lower filesystems, such as an auto mounted
USB drive, that may contain a setuid-root binary, CVE-2012-3409
(Closes: #682220)
2012-06-29 - Daniel Baumann <daniel.baumann@progress-technologies.net>
ecryptfs-utils (98-2) unstable; urgency=low
* Renaming local kmod configuration file.
2012-06-29 - Daniel Baumann <daniel.baumann@progress-technologies.net>
ecryptfs-utils (98-1) unstable; urgency=low
* Merging upstream version 98:
- removes outdated documentation (Closes: #649544).
* Updating GPL boilerplate in copyright file.
* Switching to xz compression.
* Adding missing symlink to _libecryptfs.so.0.0.0 in python-ecryptfs
(Closes: #677248).
* Automatically loading ecryptfs kernel module with kmod (Closes:
#640745).
* Simplyfing backports compatible use of multiarch debhelper install
files.
* Dropping opencryptoki handling, there is no opencryptoki support
anymore in upstream code.
* Removing obsolete architecture specifics in trousers build-depends and
depends.
* Enable trousers support.
* Sorting configure flags.
* Trimming debhelper install override.
* Adding missing symlink to _libecryptfs.so in python-ecryptfs
(Closes: #677248).
2012-06-21 - Daniel Baumann <daniel.baumann@progress-technologies.net>
ecryptfs-utils (97-1) unstable; urgency=low
* Merging upstream version 97.
2012-05-18 - Daniel Baumann <daniel.baumann@progress-technologies.net>
ecryptfs-utils (96-1) unstable; urgency=low
* Merging upstream version 96.
* Updating to debhelper version 9.
* Updating to standards version 3.9.3.
* Updating copyright file machine-readable format version 1.0.
* Removing leading slashes from debhelper install entries.
* Disabling hardening build flags temporarily to avoid FTBFS.
* Updating packaging for multiarch.
* Removing /var/lib/ecryptfs on purge (Closes: #668738).
* Updating lintian overrides.
2011-12-26 - Daniel Baumann <daniel.baumann@progress-technologies.net>
ecryptfs-utils (95-1) unstable; urgency=low
* Merging upstream version 95.
* Removing manpage.patch, went upstream.
* Removing pam-doc.patch, went upstream.
2011-10-29 - Daniel Baumann <daniel.baumann@progress-technologies.net>
ecryptfs-utils (93-1) unstable; urgency=low
* Using compression level 9 also for binary packages.
* Merging upstream version 93.
* Moving chmod call for setting mount.ecryptfs_private setuid into
fixperms override, rather than excluding it from fixperms to improve
readability of rules.
* Sorting overrides alphabetically in rules.
2011-09-09 - Daniel Baumann <daniel.baumann@progress-technologies.net>
ecryptfs-utils (92-2) unstable; urgency=low
* Correcting wrong use of dh --with in rules.
* Temporarily only building module only for python 2.6.
* Removing obsolete python:Provides from control.
* Removing unused files of the python extension.
* Adding breaks and replaces for older ecryptfs-utils in python-
ecryptfs (Closes: #608597).
2011-09-08 - Daniel Baumann <daniel.baumann@progress-technologies.net>
ecryptfs-utils (92-1) unstable; urgency=low
* Merging upstream version 92.
* Updating maintainer and uploaders fields.
* Removing vcs fields.
* Removing references to my old email address.
* Makging packaging distribution neutral.
* Updating year in copyright file.
* Compacting copyright file.
* Dropping unsupported architectures from tpm build-depends.
* Making packages linux-any.
* Moving to dh_python2.

See Also

Package Description
edisplay_0.8.5-5+deb7u3_amd64.deb fast image manipulation programs (image viewer)
eglibc-source_2.13-38+deb7u12_all.deb Embedded GNU C Library: sources
ejabberd_2.1.10-4+deb7u2_amd64.deb distributed, fault-tolerant Jabber/XMPP server written in Erlang
eject_2.1.5+deb1+cvs20081104-13+deb7u1_amd64.deb ejects CDs and operates CD-Changers under Linux
emacs23-bin-common_23.4+1-4+deb7u1_amd64.deb The GNU Emacs editor's shared, architecture dependent files
emacs23-common_23.4+1-4+deb7u1_all.deb The GNU Emacs editor's shared, architecture independent infrastructure
emacs23-el_23.4+1-4+deb7u1_all.deb GNU Emacs LISP (.el) files
emacs23-lucid_23.4+1-4+deb7u1_amd64.deb The GNU Emacs editor
emacs23-nox_23.4+1-4+deb7u1_amd64.deb The GNU Emacs editor (without X support)
emacs23_23.4+1-4+deb7u1_amd64.deb The GNU Emacs editor (with GTK+ user interface)
enigmail_1.9.9-1~deb7u1_all.deb GPG support for Thunderbird and Debian Icedove
eog-dev_3.4.2-1+build1+deb7u1_all.deb Development files for the Eye of GNOME
eog_3.4.2-1+build1+deb7u1_amd64.deb Eye of GNOME graphics viewer program
erlang-appmon_15.b.1-dfsg-4+deb7u2_amd64.deb Erlang/OTP application monitor
erlang-asn1_15.b.1-dfsg-4+deb7u2_amd64.deb Erlang/OTP modules for ASN.1 support
Advertisement
Advertisement