cups-filters_1.0.18-2.1+deb7u2_amd64.deb


Advertisement

Description

cups-filters - OpenPrinting CUPS Filters

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Security Updates Main amd64
Package name cups-filters
Package version 1.0.18
Package release 2.1+deb7u2
Package architecture amd64
Package type deb
Installed size 966 B
Download size 378.40 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
cups-filters_1.0.18-2.1+deb7u2_i386.deb 1.0.18 i386 Debian Security Updates Main
cups-filters_1.0.18-2.1+deb7u2_amd64.deb 1.0.18 amd64 Debian Main
cups-filters_1.0.18-2.1+deb7u2_i386.deb 1.0.18 i386 Debian Main
cups-filters - - -

Requires

Name Value
fonts-liberation -
ghostscript >= 9.02~
libc6 >= 2.7
libcups2 >= 1.4.0
libcupsfilters1 >= 1.0~b1
libcupsimage2 >= 1.4.0
libfontconfig1 >= 2.9.0
libgcc1 >= 1:4.1.1
libijs-0.35 >= 0.35
liblcms2-2 -
libpoppler19 >= 0.18.4
libstdc++6 >= 4.1.1
ttf-dejavu -
ttf-freefont -
zlib1g >= 1:1.1.4

Replaces

Name Value
cups << 1.5.0-16
cups-common << 1.5.0-16
ghostscript-cups << 9.02~

Download

Type URL
Binary Package cups-filters_1.0.18-2.1+deb7u2_amd64.deb
Source Package cups-filters

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install cups-filters deb package:
    # sudo apt-get install cups-filters

Changelog

2015-07-03 - Didier Raboud <odyx@debian.org>
cups-filters (1.0.18-2.1+deb7u2) wheezy-security; urgency=high
* Backport upstream fixes for buffer overflows on size allocation in texttopdf.
(CVE-2015-3258, CVE-2015-3279)
2014-03-11 - Didier Raboud <odyx@debian.org>
cups-filters (1.0.18-2.1+deb7u1) stable-security; urgency=high
* Backport security fix from cups-filters 1.0.47:
pdftoopvp: SECURITY FIX for CVE-2013-6474, CVE-2013-6475, and
CVE-2013-6476: Introduction of gmallocn and gmallocn3 to protect against
arbitrary code execution with the privileges of the "lp" user via
malicious PDF files. Also restrict the directory from where OPVP drivers
can get loaded (Closes: #741318)
2012-11-20 - gregor herrmann <gregoa@debian.org>
cups-filters (1.0.18-2.1) unstable; urgency=low
* Non-maintainer upload.
* Fix "debian/copyright is misleading/incomplete": try to get it closer to
reality. Most of the work was done by Arthur de Jong, thanks.
(Closes: #682752)
2012-05-18 - Didier Raboud <odyx@debian.org>
cups-filters (1.0.18-2) unstable; urgency=low
[ Fabian Greffrath ]
* Add patch to avoid trimming the results of FcFontSort(), as this may
miss some reasonable candidates under certain circumstances. BTW,
fix passing a non-pointer as a pointer to "result". (Closes: #670055)
2012-05-16 - Till Kamppeter <till.kamppeter@gmail.com>
cups-filters (1.0.18-1) unstable; urgency=low
* New upstream release
- pdftops: Allow selection whether Ghostscript or Poppler is used
at runtime, setting the "pdftops-renderer" option to "gs" or
"pdftops". This way one can switch to Poppler per-queue if there
are incompatibilities with certain PostScript printers.
- pdftops: Allow setting an upper limit for the image rendering
resolution, also at runtime, setting the option
"pdftops-max-image-resolution-default" to the desired limit in dpi.
"0" means no limit. Default limit is 1440 dpi. This prevents slow
processing by the printer if very high resolutions are used or
if the printing resolution is mis-detected by the pdftops filter.
- pdftops: Fixed crash by wrong usage of sizeof() function when adding
"Collate" to the fifth command line argument for the "pstops" CUPS
filter call (LP: #982675).
- pdftops: Removed newline from copies value when reading it from
the "%%PDFTOPDFNumCopies" entry of the incoming PDF file.
- pdftops: Silenced compiler warning about ignoring the return
value of the write() function.
- pdftops: Added a crash guard.
- pdftops: Start determining the printing resolution with
cupsRasterInterpretPPD(), this is the most reliable as often
the choice names of the "Resolution" option are marketing names
with higher numerical values than the actual resolution. Also
ignore error exit values of cupsRasterInterpretPPD() as the
function can error out after having found the resolution.
- pdftops: If printing resolution is determined by
cupsRasterInterpretPPD() do not stick on 100 dpi if the
resolution cannot be determined (LP: #984082).
- pdftopdf: Fixed segmentation fault when printing selected pages
("page-ranges" option, LP: #980673).
2012-04-19 - Didier Raboud <odyx@debian.org>
cups-filters (1.0.16-2) unstable; urgency=low
* Drop libtiff5-dev, just use libtiff-dev, this fixes the FTBFS due to
incompatibility with cups.

See Also

Package Description
cups-ppdc_1.5.3-5+deb7u8_amd64.deb Common UNIX Printing System(tm) - PPD manipulation utilities
cups_1.5.3-5+deb7u8_amd64.deb Common UNIX Printing System(tm) - server
cupsddk_1.5.3-5+deb7u8_all.deb Common UNIX Printing System (transitional package)
curl_7.26.0-1+wheezy25+deb7u1_amd64.deb command line tool for transferring data with URL syntax
cvs_1.12.13+real-9+deb7u1_amd64.deb Concurrent Versions System
das-watchdog_0.9.0-2+deb7u1_amd64.deb solves system lock-ups by making all processes non-realtime
davfs2_1.4.6-1.1+wheezy1_amd64.deb mount a WebDAV resource as a regular file system
db4.7-util_4.7.25-21+deb7u1_amd64.deb Berkeley v4.7 Database Utilities
db4.8-util_4.8.30-12+deb7u1_amd64.deb Berkeley v4.8 Database Utilities
db5.1-doc_5.1.29-5+deb7u1_all.deb Berkeley v5.1 Database Documentation [html]
db5.1-sql-util_5.1.29-5+deb7u1_amd64.deb Berkeley v5.1 SQL Database Utilities
db5.1-util_5.1.29-5+deb7u1_amd64.deb Berkeley v5.1 Database Utilities
dbus-1-doc_1.6.8-1+deb7u6_all.deb simple interprocess messaging system (documentation)
dbus-x11_1.6.8-1+deb7u6_amd64.deb simple interprocess messaging system (X11 deps)
dbus_1.6.8-1+deb7u6_amd64.deb simple interprocess messaging system (daemon and utilities)
Advertisement
Advertisement