samba_3.6.6-6+deb7u9_amd64.deb


Advertisement

Description

samba - SMB/CIFS file, print, and login server for Unix

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Proposed Updates Main amd64
Package name samba
Package version 3.6.6
Package release 6+deb7u9
Package architecture amd64
Package type deb
Installed size 23.06 KB
Download size 4.14 MB
Official Mirror ftp.br.debian.org
Samba is an implementation of the SMB/CIFS protocol for Unix systems,
providing support for cross-platform file and printer sharing with
Microsoft Windows, OS X, and other Unix systems.  Samba can also function
as an NT4-style domain controller, and can integrate with both NT4 domains
and Active Directory realms as a member server.
This package provides the components necessary to use Samba as a
stand-alone file and print server.  For use in an NT4 domain or Active
Directory realm, you will also need the winbind package.
This package is not required for connecting to existing SMB/CIFS servers
(see smbclient) or for mounting remote filesystems (see cifs-utils).

Alternatives

Package Version Architecture Repository
samba_4.1.17+dfsg-1~bpo70+1_i386.deb 4.1.17+dfsg i386 Debian Backports Main
samba_4.1.17+dfsg-1~bpo70+1_amd64.deb 4.1.17+dfsg amd64 Debian Backports Main
samba_3.6.6-6+deb7u9_i386.deb 3.6.6 i386 Debian Proposed Updates Main
samba_3.6.6-6+deb7u7_i386.deb 3.6.6 i386 Debian Main
samba_3.6.6-6+deb7u7_amd64.deb 3.6.6 amd64 Debian Main
samba_3.6.6-6+deb7u16_amd64.deb 3.6.6 amd64 Debian Security Updates Main
samba_3.6.6-6+deb7u16_i386.deb 3.6.6 i386 Debian Security Updates Main
samba - - -

Requires

Name Value
adduser -
debconf >= 0.5
debconf-2.0 -
dpkg >= 1.15.7.2
libacl1 >= 2.2.51-8
libattr1 >= 1:2.4.46-8
libc6 >= 2.10
libcap2 >= 2.10
libcomerr2 >= 1.01
libcups2 >= 1.4.0
libgssapi-krb5-2 >= 1.10+dfsg~
libk5crypto3 >= 1.6.dfsg.2
libkrb5-3 >= 1.10+dfsg~
libldap-2.4-2 >= 2.4.7
libpam-modules -
libpam-runtime >= 1.0.1-11
libpam0g >= 0.99.7.1
libpopt0 >= 1.14
libtalloc2 >= 2.0.4~git20101213
libtdb1 >= 1.2.7+git20101214
libwbclient0 = 2:3.6.6-6+deb7u9
lsb-base >= 3.2-13
procps -
samba-common = 2:3.6.6-6+deb7u9
update-inetd -
zlib1g >= 1:1.1.4

Conflicts

Name Value
samba4 << 4.0.0~alpha6-2

Replaces

Name Value
samba-common <= 2.0.5a-2

Download

Type URL
Binary Package samba_3.6.6-6+deb7u9_amd64.deb
Source Package samba

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    deb http://ftp.debian.org/debian/ wheezy-proposed-updates main
  2. Update the package index:
    # sudo apt-get update
  3. Install samba deb package:
    # sudo apt-get install samba

Changelog

2016-04-12 - Salvatore Bonaccorso <carnil@debian.org>
samba (2:3.6.6-6+deb7u9) wheezy-security; urgency=high
* Non-maintainer upload by the Security Team.
* Update CVE patchset for regression fixes
2016-04-08 - Andrew Bartlett <abartlet+debian@catalyst.net.nz>
samba (2:3.6.6-6+deb7u8) wheezy-security; urgency=high
* Security update
+ Fixes:
- CVE-2015-5370 (Multiple errors in DCE-RPC code)
- CVE-2016-2110 (Man in the middle attacks possible with NTLMSSP)
- CVE-2016-2111 (NETLOGON Spoofing Vulnerability)
- CVE-2016-2112 (LDAP client and server don't enforce integrity)
- CVE-2016-2115 (SMB IPC traffic is not integrity protected)
- CVE-2016-2118 (SAMR and LSA man in the middle attacks possible)
+ The Samba 3.6 patches have been backported by Andreas Schneider
(Red Hat) and Ralph Böhme (SerNet). Thanks goes to Stefan Metzmacher
for finding and fixing the CVEs in the first place. Thanks for the
help with backporting to Günther Deschner (Red Hat) and Aurélien Aptel
(SUSE).
2016-03-11 - Salvatore Bonaccorso <carnil@debian.org>
samba (2:3.6.6-6+deb7u7) wheezy-security; urgency=high
* Non-maintainer upload by the Security Team.
* s3:smbd: fix a corner case of the symlink verification.
Address regression introduced by the patch for CVE-2015-5252. For the
share path "/", the introduced checks deny all operations in the share.
(Closes: #812429)
* CVE-2015-7560: Incorrect ACL get/set allowed on symlink path
2015-12-22 - Salvatore Bonaccorso <carnil@debian.org>
samba (2:3.6.6-6+deb7u6) wheezy-security; urgency=high
* Non-maintainer upload by the Security Team.
* Refresh waf-as-source.patch patch
* Add CVE-2015-5252-v3-6-bso11395.patch patch.
CVE-2015-5252: Insufficient symlink verification in smbd.
* Add CVE-2015-5299-v3-6-bso11529.patch patch.
CVE-2015-5299: Missing access control check in shadow copy code.
* Add CVE-2015-5296-v3-6-bso11536.patch patch.
CVE-2015-5296: Samba client requesting encryption vulnerable to
downgrade attack.
2015-02-19 - Ivo De Decker <ivodd@debian.org>
samba (2:3.6.6-6+deb7u5) wheezy-security; urgency=high
* Security update
* CVE-2015-0240: Unauthenticated code execution attack on smbd file
services
2014-06-22 - Ivo De Decker <ivo.dedecker@ugent.be>
samba (2:3.6.6-6+deb7u4) wheezy-security; urgency=high
* Security update
* CVE-2014-0178: Uninitialized memory exposure when handling shadow_copy
data
* CVE-2014-0244: nmbd denial of service
* CVE-2014-3493: smbd denial of service: server crash/memory corruption
2014-04-13 - Ivo De Decker <ivo.dedecker@ugent.be>
samba (2:3.6.6-6+deb7u3) wheezy; urgency=medium
* Security update
* CVE-2012-6150: pam_winbind login without require_membership_of
restrictions
* CVE-2013-4496: Password lockout not enforced for SAMR password changes
2013-12-03 - Ivo De Decker <ivo.dedecker@ugent.be>
samba (2:3.6.6-6+deb7u2) wheezy-security; urgency=high
* Security update
* CVE-2013-4475: ACLs are not checked on opening an alternate data stream on
a file or directory
* CVE-2013-4408: DCE-RPC fragment length field is incorrectly checked
2013-08-15 - Ivo De Decker <ivo.dedecker@ugent.be>
samba (2:3.6.6-6+deb7u1) wheezy; urgency=low
* Security update
* CVE-2013-4124: Denial of service - CPU loop and memory allocation
Closes: #718781
2013-04-15 - Ivo De Decker <ivo.dedecker@ugent.be>
samba (2:3.6.6-6) unstable; urgency=low
* Team upload.
* Move binary files out of /etc/samba to /var/lib/samba,
where they belong according to the FHS:
- schannel_store.tdb
- idmap2.tdb
- MACHINE.sid
Closes: #454770

See Also

Package Description
smbclient_3.6.6-6+deb7u9_amd64.deb command-line SMB/CIFS clients for Unix
swat_3.6.6-6+deb7u9_amd64.deb Samba Web Administration Tool
thunderbird-l10n-all_45.8.0-3~deb7u1_all.deb All language packages for Thunderbird (meta)
thunderbird-l10n-ar_45.8.0-3~deb7u1_all.deb Arabic language package for Thunderbird
thunderbird-l10n-ast_45.8.0-3~deb7u1_all.deb Asturian language package for Thunderbird
thunderbird-l10n-be_45.8.0-3~deb7u1_all.deb Belarusian language package for Thunderbird
thunderbird-l10n-bg_45.8.0-3~deb7u1_all.deb Bulgarian language package for Thunderbird
thunderbird-l10n-bn-bd_45.8.0-3~deb7u1_all.deb Bengali language package for Thunderbird
thunderbird-l10n-br_45.8.0-3~deb7u1_all.deb Breton language package for Thunderbird
thunderbird-l10n-ca_45.8.0-3~deb7u1_all.deb Catalan/Valencian language package for Thunderbird
thunderbird-l10n-cs_45.8.0-3~deb7u1_all.deb Czech language package for Thunderbird
thunderbird-l10n-da_45.8.0-3~deb7u1_all.deb Danish language package for Thunderbird
thunderbird-l10n-de_45.8.0-3~deb7u1_all.deb German language package for Thunderbird
thunderbird-l10n-el_45.8.0-3~deb7u1_all.deb Greek language package for Thunderbird
thunderbird-l10n-en-gb_45.8.0-3~deb7u1_all.deb English (Great Britain) language package for Thunderbird
Advertisement
Advertisement