libcore++-dev_1.7-12_amd64.deb


Advertisement

Description

libcore++-dev - C/C++ library for robust computation (development files)

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Nonfree amd64
Package name libcore++-dev
Package version 1.7
Package release 12
Package architecture amd64
Package type deb
Installed size 3.12 KB
Download size 675.92 KB
Official Mirror ftp.br.debian.org
The Core Library is a collection of C/C++ classes for exact computation
with real algebraic numbers. It embodies a precision-driven approach and is
useful for robust numerical (especially geometric) algorithms.
This package contains the header files and static libraries.

Alternatives

Package Version Architecture Repository
libcore++-dev_1.7-12_i386.deb 1.7 i386 Debian Nonfree
libcore++-dev - - -

Requires

Name Value
libcore++1c2 = 1.7-12
libgmp-dev -

Download

Type URL
Binary Package libcore++-dev_1.7-12_amd64.deb
Source Package core++

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libcore++-dev deb package:
    # sudo apt-get install libcore++-dev

Files

Path
/usr/include/CORE.h
/usr/include/CORE/BigFloat.h
/usr/include/CORE/BigFloatRep.h
/usr/include/CORE/BigInt.h
/usr/include/CORE/BigRat.h
/usr/include/CORE/CGAL_Expr.h
/usr/include/CORE/CORE.h
/usr/include/CORE/Config.h
/usr/include/CORE/CoreAux.h
/usr/include/CORE/CoreDefs.h
/usr/include/CORE/Expr.h
/usr/include/CORE/ExprRep.h
/usr/include/CORE/Filter.h
/usr/include/CORE/Gmp.h
/usr/include/CORE/Impl.h
/usr/include/CORE/Makefile
/usr/include/CORE/MemoryPool.h
/usr/include/CORE/Real.h
/usr/include/CORE/RealRep.h
/usr/include/CORE/RefCount.h
/usr/include/CORE/Timer.h
/usr/include/CORE/extLong.h
/usr/include/CORE/geombase.h
/usr/include/CORE/geometry2d.h
/usr/include/CORE/geometry3d.h
/usr/include/CORE/linearAlgebra.h
/usr/include/CORE/geom2d/circle2d.h
/usr/include/CORE/geom2d/line2d.h
/usr/include/CORE/geom2d/point2d.h
/usr/include/CORE/geom2d/segment2d.h
/usr/include/CORE/geom3d/line3d.h
/usr/include/CORE/geom3d/plane3d.h
/usr/include/CORE/geom3d/point3d.h
/usr/include/CORE/geom3d/polygon3d.h
/usr/include/CORE/geom3d/segment3d.h
/usr/include/CORE/geom3d/triangle3d.h
/usr/include/CORE/poly/Curves.h
/usr/include/CORE/poly/Curves.tcc
/usr/include/CORE/poly/Poly.h
/usr/include/CORE/poly/Poly.tcc
/usr/include/CORE/poly/Sturm.h
/usr/lib/libcore++.a
/usr/lib/libcore++.so
/usr/lib/libcorex++_level1.a
/usr/lib/libcorex++_level1.so
/usr/lib/libcorex++_level2.a
/usr/lib/libcorex++_level2.so
/usr/lib/libcorex++_level3.a
/usr/lib/libcorex++_level3.so
/usr/share/doc/libcore++-dev
/usr/share/doc/libcore++1c2/ANNOUNCEMENT
/usr/share/doc/libcore++1c2/FAQs.gz
/usr/share/doc/libcore++1c2/README.gz

Changelog

2011-09-16 - Joachim Reichel <reichel@debian.org>
core++ (1.7-12) unstable; urgency=low
* Add patch g++-4.6-compatibility.dpatch (Closes: #633578, thanks to
Stephen M. Webb).
* Fixed lintian warnings duplicate-long-description,
debhelper-but-no-misc-depends, missing-debian-source-format,
patch-system-but-no-source-readme,
copyright-with-old-dh-make-debian-copyright, and
spelling-error-in-copyright.
* Update Standards-Version to 3.9.2 (no changes needed).
2011-03-16 - Steve M. Robbins <smr@debian.org>
core++ (1.7-11.1) unstable; urgency=low
* NMU.  Change dependencies libgmp3-dev --> libgmp-dev.
2008-06-30 - Joachim Reichel <joachim.reichel@gmx.de>
core++ (1.7-11) unstable; urgency=low
* Add patch g++-4.3-compatibility.dpatch.
* debian/control: Adjust dependencies after TeX and Ghostscript transitions.
* debian/rules: Remove workaround for #428876 and #435229 (Closes: #488113).
* Update Standards-Version to 3.8.0 (explain in debian/copyright why package
is in non-free).
2008-03-19 - Joachim Reichel <joachim.reichel@gmx.de>
core++ (1.7-10) unstable; urgency=low
* Add patch bugfix-size-type.dpatch.
* Update patch make-library.dpatch: link extension libraries with
libcore++.so.
* debian/rules: Fix workaround for #428876 and #435229, extend to hppa and
mips.
2008-02-05 - Joachim Reichel <joachim.reichel@gmx.de>
core++ (1.7-9) unstable; urgency=low
* debian/rules: Add workaround for #428876 and #435229.
* debian/control: Add Homepage: field.
* Update Standards-Version to 3.7.3 (no changes needed).
2007-07-16 - Joachim Reichel <joachim.reichel@gmx.de>
core++ (1.7-8) unstable; urgency=low
* debian/rules: Remove bashisms (thanks to Barry deFreese).
* Add watch file.
2006-12-18 - Joachim Reichel <joachim.reichel@gmx.de>
core++ (1.7-7) unstable; urgency=low
* debian/control: Use Build-Depends instead of Build-Depends-Indep
to work around non-policy-conforming autobuilders.
* debian/control: Add tag XS-Autobuild.
* debian/copyright: Add note about autobuilding.
* debian/control: Make package binNMU-safe.
* debian/control: Add texlive alternatives to Build-Depends.
2006-06-19 - Joachim Reichel <joachim.reichel@gmx.de>
core++ (1.7-6) unstable; urgency=low
* Add patch g++-4.1-compatibility.dpatch.
* Update Standards-Version to 3.7.2 (no changes needed).
* debian/compat: Use debhelper compatibility level 5.
* debian/rules: Adjust dependency on debhelper accordingly.
2006-04-18 - Joachim Reichel <joachim.reichel@gmx.de>
core++ (1.7-5) unstable; urgency=low
* patch bugfix-avoid-internal-gmp-functions added
(do not use __gmp_free_func).
* patch makefile-output.dpatch updated
(whitespace changes for compatibility with newer make versions).
2005-10-12 - Joachim Reichel <joachim.reichel@gmx.de>
core++ (1.7-4) unstable; urgency=low
* patch bugfix-operatorplusplus.dpatch added.

See Also

Package Description
libcore++-doc_1.7-12_all.deb C/C++ library for robust computation (documentation)
libcore++1c2_1.7-12_amd64.deb C/C++ library for robust computation
libcublas4_4.2.9-2_amd64.deb NVIDIA CUDA BLAS runtime library
libcuda1-ia32_304.131-1_amd64.deb please switch to multiarch libcuda1:i386
libcuda1_304.131-1_amd64.deb NVIDIA CUDA runtime library
libcudart4_4.2.9-2_amd64.deb NVIDIA CUDA runtime library
libcufft4_4.2.9-2_amd64.deb NVIDIA CUDA FFT runtime library
libcuinj4_4.2.9-2_amd64.deb NVIDIA CUDA INJ runtime library
libcuneiform-dev_1.1.0+dfsg-4_amd64.deb multi-language OCR system (development)
libcuneiform0_1.1.0+dfsg-4_amd64.deb multi-language OCR system (shared library)
libcupti-dev_4.2.9-2_amd64.deb NVIDIA CUDA Profiler Tools Interface development files
libcupti-doc_4.2.9-2_all.deb NVIDIA CUDA Profiler Tools Interface documentation
libcupti4_4.2.9-2_amd64.deb NVIDIA CUDA Profiler Tools Interface runtime library
libcurand4_4.2.9-2_amd64.deb NVIDIA CUDA Random Numbers Generation runtime library
libcusparse4_4.2.9-2_amd64.deb NVIDIA CUDA Sparse Matrix runtime library
Advertisement
Advertisement